/mail/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
7/21/19
"The recipient server did not accept our requests to connect" from GMail after updating SSL/TLS cert 1 Recommended Answer 7 Replies 10 Upvotes
1 Recommended Answer
$0 Recommended Answers
Last edited 7/21/19
On Friday, 19 July 2019, we updated the SSL/TLS security certificates out our mailserver (c4.net and associated domains.)  After replacing the certificate, we noticed that mail stopped arriving from gmail.com and GApps-hosted domains.  Senders from those domains received a message about a temporary delivery problem after 24 hours, saying the response from our server was:

The recipient server did not accept our requests to connect.

I've confirmed we have a clear path for traffic through our firewalls for traffic from all the servers listed in the _spf.google.com IP blocks, as well as confirmed that none of those IPs are blacklisted on our mail server, as well as the IP's being exempted from Greylisting.

We did change our Certificate vendor from COMODO to LetsEncrypt in this most recent update, which is the only significant change on our end.  It did replace the by-now-expired certificate that was on SMTP 25.  Is it possible GMail is rejecting a connection because of the CA on the certificate?

Note that our domains that do not use TLS on SMTP are not impacted by the issue, strongly implicating the certificate in this problem.

Thanks,
John Brewer
C4.net
All Replies (7)
-
7/22/19
Update: I got bounces from a domain that doesn't use TLS or SSL for mailservices, and a bounce from icloud.com, suggesting this isn't an issue related to our unique configuration or our certificates.  Is anyone else experiencing these issues?
marked this as an answer
Helpful?
7/26/19
I'm seeing this too, in the last 48hrs (my letsencrypt cert last updated 4 days ago). Gmail is now rejecting connections from my mail server with "TLS error on connection (recv): Resource temporarily unavailable, try again."
marked this as an answer
Helpful?
8/25/19
Can you  please fix the problem for me
marked this as an answer
Helpful?
8/29/19
Am suddenly getting "msmtp: TLS certificate verification failed: the certificate hasn't got a known issuer" errors. It did go away this afternoon and I was able to send email for awhile, but now the problem is  back!! I also notice that there were certificate validity changes lately:

Common Name: Google Internet Authority G3
Validity:
    Activation time: Mon, Jul 29, 2019 11:35:48 AM
    Expiration time: Mon, Oct 21, 2019 11:23:00 AM

Just tried again and it worked.
Anyone else encountering issues sending email?
marked this as an answer
Helpful?
9/2/19
same issue :( Can't send emails to important clients
marked this as an answer
Helpful?
10/13/19
I'm having similar problems.
marked this as an answer
Helpful?
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/mail/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/mail/profile/0?hl=en