Can't install the Hangouts plug-ins

If you're having trouble installing the Hangouts plug-in, or you're receiving a message asking you to reinstall it, check to make sure that your settings are correct.

If you're using Chrome, you don't need the plug-in. You'll only need the plug-in if you're using Firefox, Safari, Internet Explorer or another browser.

  1. Try downloading and installing the Hangouts plug-in package again.
  2. Make sure that the plug-in is enabled.
    • Firefox: Click Menu > Tools > Add-ons > Plug-ins. Find the Hangouts plug-ins. They may be labelled “Google Talk Plug-in" and "Google Talk Plug-in Video Renderer”. Make sure that the plug-in is activated.
    • Safari: Click Preferences > Security > Plug-in settings. Find the Hangouts plug-ins. They may be labelled “Google Talk Plug-in" and "Google Talk Plug-in Video Renderer”. Make sure that the plug-in is allowed.
    • Internet Explorer: Click Tools  > Manage add-ons. Under "Show", click All add-ons. Find the Hangouts plug-ins. They may be labelled “Google Talk ActiveX Plug-in" and "Google Talk Video Renderer”. Make sure that the plug-in is enabled.
  3. If you use Internet Explorer, make sure that you have the 32-bit version (not 64-bit).
  4. If you use Windows 8 or newer, switch to desktop mode to allow the plug-in to work.
  5. Check your browser's extensions. Turn off any that enforce "click to run".

If you're still having problems after trying the recommendations above, try these troubleshooting steps:

  1. Refresh the browser page.
  2. Close down or exit your browser, then reopen it.
  3. Restart your computer.
  4. Uninstall the Hangouts plug-in, then download and install the Hangouts plug-in again.
  5. Try using the Chrome browser, which doesn't require the plug-in.

Megan is a Hangouts expert and the author of this help page. Help her improve this article by leaving feedback below.

Was this article helpful?