Gebruik van het recht REQUEST_INSTALL_PACKAGES

Google Play beperkt het gebruik van risicovolle of gevoelige rechten, waaronder het recht REQUEST_INSTALL_PACKAGES, waarmee een app installatiepakketten kan aanvragen. Apps die API-niveau 26 of hoger targeten, hebben dit recht nodig om Intent.ACTION_INSTALL_PACKAGE of de PackageInstaller API te gebruiken. Voor gebruik van dit recht moet de kernfunctionaliteit van je app het volgende bevatten:

  1. app-pakketten versturen of ontvangen, EN
  2. door de gebruiker gestarte installatie van app-pakketten mogelijk maken.

Als je app niet voldoet aan de onderstaande vereisten voor acceptabel gebruik, moet je dit recht uit het manifest van je app verwijderen om aan het Google Play-beleid te voldoen. Hieronder vind je ook suggesties voor alternatieve implementaties die aan het beleid voldoen.

Als je app voldoet aan de beleidsvereisten voor acceptabel gebruik van het recht REQUEST_INSTALL_PACKAGES, moet je via het Declaratieformulier voor rechten in de Play Console deze en andere mogelijk risicovolle rechten definiëren.

Apps die niet voldoen aan de beleidsvereisten of waarvoor geen Declaratieformulier voor rechten wordt ingediend, kunnen van Google Play worden verwijderd.

Belangrijk: Als je wijzigt hoe je app deze beperkte rechten gebruikt, moet je je declaratie herzien met geüpdatete en nauwkeurige informatie. Misleidend en niet-gedeclareerd gebruik van deze rechten kan leiden tot opschorting van je app en/of beëindiging van je ontwikkelaarsaccount.

Wanneer moet je het recht REQUEST_INSTALL_PACKAGES aanvragen?

Het recht REQUEST_INSTALL_PACKAGES wordt alleen van kracht als je app Android API-niveau 26 of hoger target op apparaten met Android 8 of hoger.

Voor gebruik van dit recht moet je app binnen de onderstaande toegestane toepassingen vallen en moet de app een kerndoel hebben om de installatie van pakketten mogelijk te maken. De kernfunctionaliteit is het belangrijkste doel van de app. Zonder deze kernmogelijkheid om extra apps op het apparaat te installeren, is de app 'defect' of wordt deze onbruikbaar. De kernfunctionaliteit en alle kernfuncties waaruit deze kernfunctionaliteit bestaat, moeten duidelijk worden beschreven en gepromoot in de beschrijving van de app.

Alles samenvouwen Alles uitvouwen

Toegestane toepassingen van het recht REQUEST_INSTALL_PACKAGES

Apps die de installatie van app-pakketten mogelijk moeten maken voor interoperabiliteitsdoeleinden, komen misschien in aanmerking voor dit recht.Toegestaan gebruik omvat:

  • browsen of zoeken op internet, OF
  • communicatieservices die bijlagen ondersteunen, OF
  • bestanden delen, overdragen of beheren, OF
  • zakelijk apparaatbeheer.

Apps die toegang hebben tot dit recht, moeten voldoen aan het Beleid voor gebruikersgegevens, waaronder de Vereisten voor prominente kennisgeving en toestemming, en mogen het gebruik niet uitbreiden naar niet-bekendgemaakte of ongeldige doeleinden.

Ongeldige toepassingen

Hieronder vind je een lijst met toepassingen die niet om het recht REQUEST_INSTALL_PACKAGES mogen vragen:

  • Als het gebruik van het recht niet rechtstreeks is gerelateerd aan het kerndoel van de app.
    • Dit geldt ook voor delen via peer-to-peer (P2P). P2P moet het kerndoel van de app zijn om als toegestaan gebruik te worden gezien.
  • Wanneer de vereiste taak kan worden uitgevoerd met een minder indringende methode.

Opmerking: Deze lijst is niet volledig.

Veelgestelde vragen

Waarom wil Google dit beleid introduceren?

Met het recht REQUEST_INSTALL_PACKAGES krijgen apps de mogelijkheid om nieuwe pakketten te installeren op het apparaat van een gebruiker. We willen misbruik op het Android-platform voorkomen en gebruikers beschermen tegen apps die zichzelf updaten met een andere methode dan het updatemechanisme van Google Play of door schadelijke APK's te downloaden. Daarom introduceren we het beleid voor het aanvragen van installatiepakketten om uit te leggen welke functies en acties zijn toegestaan voor het recht.

Hoe weet ik of mijn toepassing voor dit recht wel of niet is toegestaan?

We raden je aan het beleid zorgvuldig door te nemen voor toegestane toepassingen en de nodige wijzigingen aan te brengen om te zorgen dat je app aan het beleid voldoet. Als je app niet aan de criteria voor een toegestane toepassing voldoet, moet je vóór de ingangsdatum van het beleid dit recht uit je app verwijderen, zodat je app aan het beleid voldoet.

Wat zijn de tijdlijnen voor naleving?

Het nieuwe beleid wordt vanaf 11 juli 2022 afgedwongen.

Heeft deze nieuwe verduidelijking invloed op de tijdlijnen voor de beoordeling van apps?

We verwachten door deze update geen vertraging in de tijdlijnen voor de beoordeling van apps.

Wat moet ik doen als ik meer tijd nodig heb om aan de vereisten te voldoen?

Het nieuwe beleid gaat op 11 juli 2022 in. We raden je aan het beleid zorgvuldig en tijdig door te nemen voor toegestane toepassingen en de nodige wijzigingen aan te brengen om te zorgen dat je app aan het beleid voldoet. Als je app niet aan de criteria voor een toegestane toepassing voldoet, moet je vóór de ingangsdatum van het beleid dit recht uit je app verwijderen, zodat je app aan het beleid voldoet.

Mijn app is verwijderd van Google Play vanwege de schending van dit beleid. Ik denk dat dit onterecht was. Wat moet ik doen?

Bekijk de richtlijnen op deze Helpcentrum-pagina voor opties.

Was dit nuttig?
Hoe kunnen we dit verbeteren?

Meer hulp nodig?

Log in voor extra supportopties om uw probleem snel op te lossen

Zoeken
Zoekopdracht verwijderen
Zoekfunctie sluiten
Google-apps
Hoofdmenu
Zoeken in het Helpcentrum
true
92637
false