Google Play uygulamaları için hedef API düzeyi şartları

Her yeni Android sürümü, güvenlik ve performans iyileştirmeleri sağlamanın yanı sıra Android genelinde kullanıcı deneyimini geliştiren değişiklikler sunar. Her uygulamanın manifest dosyasında, uygulamanızın farklı Android sürümlerinde nasıl çalıştırıldığı konusunda bilgi veren bir targetSdkVersion vardır (hedef API düzeyi olarak da bilinir).

Uygulamanızın yeni bir API düzeyini hedeflemek üzere yapılandırılması, kullanıcıların önemli güvenlik, gizlilik ve performans iyileştirmelerinden yararlanmalarını sağlar. Aynı zamanda uygulamanızın daha eski Android sürümlerinde (minSdkVersion sürümüne kadar) çalışmaya devam etmesine olanak tanır.

Google Play; Android ve Google Play kullanıcılarına güvenli bir deneyim sunmak için tüm uygulamaların aşağıda listelenen hedef API düzeyi şartlarını karşılamasını zorunlu tutar.

Tanımlar

Yeni uygulama Henüz Play Store'da yayınlanmamış bir uygulama (ör. yepyeni bir uygulama).
Uygulama güncellemesi Play Store'da yayınlanmış bir uygulamanın yeni sürümü.
Mevcut uygulama Güncelleme almayan, yayınlanmış bir uygulama.

Şartlar

Android OS sürümü

Google Play uygulamalarının bu API düzeyini ne zaman hedeflemesi gerekir?
Yeni uygulamalar Uygulama güncellemeleri ** Mevcut uygulamalar

Android 12 (API düzeyi 31)

1 Ağustos 2022

1 Kasım 2022

1 Kasım 2023

Android 11 (API düzeyi 30)

2 Ağustos 2021

1 Kasım 2021

1 Kasım 2022

İpucu: Uygulamanızın hedef APK düzeyini bu şartları karşılayacak şekilde nasıl değiştireceğinizle ilgili teknik tavsiye için taşıma rehberine bakın.

Wear OS uygulamaları için şartlar

Android OS sürümü

Wear OS uygulamalarının bu API düzeyini ne zaman hedeflemesi gerekir?
Yeni uygulamalar Uygulama güncellemeleri ** Mevcut uygulamalar

Android 11 (API düzeyi 30)

1 Ağustos 2022

1 Kasım 2022

Şart geçerli değil

Android 10 (API düzeyi 29)

Şart geçerli değil

Android 9 (API düzeyi 28)

1 Ağustos 2019

1 Kasım 2019


** Uygulama güncellemelerine, şartın karşılanması için yeni uygulamalara kıyasla birkaç ay daha süre tanıyoruz. Bu şekilde geliştiriciler için geçiş sürecini kolaylaştırmayı amaçlıyoruz.

Uygulamalar üzerindeki olası etki

Uygulamanız, gereken hedef API düzeyini karşılamıyorsa aşağıdaki şekillerde etkilenebilir:

Uygulama

Etki

Yeni uygulamalar

Play Console'da hedef API düzeyi şartını karşılamayan uygulama paketlerini yayınlayamazsınız.

Uygulama güncellemeleri

Play Console'da hedef API düzeyi şartını karşılamayan uygulama paketlerini veya APK'ları gönderemezsiniz.

Mevcut uygulamalar

Uygulamanız, cihazlarında uygulamanızın hedef API düzeyinden daha güncel Android OS sürümleri çalıştıran yeni kullanıcılara Google Play'de sunulmaz. Bu durumda, yeni kullanıcılar uygulamanızı Google Play'de keşfedemez veya yükleyemezler.

Uygulamanızı daha önce Google Play'den yüklemiş olan kullanıcılar uygulamayı keşfetmeye, yeniden yüklemeye ve kullanmaya devam edebilirler. Yeni bir Android cihaza geçseler bile uygulamaya erişimleri devam eder.


Uygulama güncellemelerine, şartın karşılanması için yeni uygulamalara kıyasla birkaç ay daha süre tanıyoruz. Bu şekilde geliştiriciler için geçiş sürecini kolaylaştırmayı amaçlıyoruz.

Sık sorulan sorular

Tüm mevcut uygulamalarımda bu güncellemeyi yapmak için daha fazla zamana ihtiyacım varsa ne olacak?

Bazı geliştiricilerin politikaya uymak için daha fazla zamana ihtiyaç duyacağının farkındayız. Bu nedenle, tüm geliştiricilerin mevcut uygulamaları güncellemek için 1 Kasım 2022'ye kadar süresi olacak. Daha fazla zamana ihtiyacınız varsa bu yılın ilerleyen dönemlerinde Play Console'a eklenecek formu doldurarak ek süre isteğinde bulunabilirsiniz.

Bu ek süre, yeni uygulamalar veya yeni uygulama güncellemeleri için geçerli olmayacak.

Artık Google Play'de yayınlanmasını istemediğim eski uygulamalarım var. Ne yapabilirim?

Uygulamanızı nasıl yayından kaldıracağınızla ilgili talimatlar için bu Yardım Merkezi makalesini inceleyebilirsiniz.

Halihazırda önceki uygulamamı indirmiş olan kullanıcılarım bu durumdan nasıl etkilenecek?

Uygulamayı daha önce Google Play Store'dan yüklemiş olan kullanıcılar, uygulamanın desteklediği tüm Android OS sürümlerinde uygulamayı keşfetmeye, yeniden yüklemeye ve kullanmaya devam edebilecek.

Bu politika güncellemesinin, mevcut hedef API düzeyi şartından ne farkı var?

Google Play'in Hedef API Düzeyi Politikası tüm geliştiricileri yeni Android API düzeylerindeki güvenlik ve izin güncellemelerini kullanmaya teşvik eder. Böylece kullanıcılar için daha fazla koruma sağlanmış olur. Bu değişiklik uyarınca, mevcut uygulamalarını yeni cihazlardaki yeni kullanıcılara dağıtmak isteyen tüm geliştiricilerin güncel Android sürümlerini hedeflemesi gerekir.

Bu güncelleme, uygulama indirme düzeylerini etkileyecek mi?  

Bu konuda verebileceğimiz özel bir bilgi yok. Daha yeni Android OS sürümlerini çalıştıran cihazların kullanıcıları uygulamanızı Google Play'de keşfedemez veya indiremezse bu güncelleme uygulama indirme düzeylerinizi etkileyebilir.

Bu güncelleme, uygulama inceleme zaman çizelgelerini etkileyecek mi?  

Bu değişiklik, mevcut uygulama inceleme süresini etkilemeyecek. Geliştiriciler sürümlerini sunmaya devam etmek için mevcut uygulamalarını güncelleyebilecekler.
Bu size yardımcı oldu mu?
Bunu nasıl iyileştirebiliriz?

Daha fazla yardıma mı ihtiyacınız var?

Sorununuzu hızla çözmek için oturum açarak ek destek seçeneklerinden yararlanın

Arama
Aramayı temizle
Aramayı kapat
Google uygulamaları
Ana menü
Yardım Merkezinde Arayın
true
92637
false
false