Требования к целевому уровню API для приложений Google Play

С 31 августа 2024 года:

  • Все обновления и новые приложения, отправляемые на проверку в Google Play, должны поддерживать Android 14 (уровень API 34). Исключение – приложения для Wear OS и Android TV, которые должны поддерживать Android 13 или более поздних версий.
  • Существующие приложения должны поддерживать Android 13 (уровень API 33) или более поздних версий. Так они будут доступны новым пользователям на устройствах Android с ОС уровня выше, чем целевой уровень API приложения. Приложения, поддерживающие Android 12 (уровень API 31) или более ранних версий (для Wear OS – Android 10 или ниже, для Android TV – Android 11 или ниже), будут доступны только на устройствах Android с ОС не более высокого уровня, чем целевой уровень API приложения.

Если вам понадобится больше времени, чтобы привести продукт в соответствие требованиям, вы сможете запросить продление до 1 ноября 2024 года. Доступ к форме запроса продления в Play Console мы предоставим позднее в этом году.

В каждой новой версии Android улучшается безопасность и производительность, а также повышается удобство для пользователей. В манифесте любого приложения есть целевой уровень API (параметр targetSdkVersion), по которому можно понять, как приложение будет работать в разных версиях Android.

Если вы настроите приложение на новый целевой уровень API, то повысите безопасность, конфиденциальность и производительность. При этом оно продолжит работать в старых версиях Android. Указать минимальную поддерживаемую версию можно с помощью атрибута minSdkVersion.

Чтобы обеспечивать безопасность пользователей Android и Google Play, мы предъявляем указанные ниже требования к целевому уровню API для всех приложений в Google Play.

Требования не распространяются на следующие продукты:

  • Приложения, которые всегда будут частными, – доступ к ним предоставляется только сотрудникам определенной организации для внутреннего использования.
  • Приложения для Android Automotive OS или APK-файлы приложений для Android Automotive OS.

Определения

Новое приложение Приложение, которое ещё не опубликовано в Google Play (например, совершенно новая игра).
Существующее приложение Приложение, которое опубликовано в Google Play.
Обновление приложения Новая версия уже опубликованного приложения, которую вы отправляете на проверку в Google Play.

Требования для обновлений приложений

Версия ОС Android
(уровень API)

Срок, к которому в новых приложениях и обновлениях, отправляемых на проверку, следует использовать определенный уровень API
Новые приложения Обновления приложений

Android 14 (уровень API 34)*

31 августа 2024 г.

31 августа 2024 г.

Android 13 (уровень API 33)

31 августа 2023 г.

31 августа 2023 г.

* Разработчики могут запросить продление до 1 ноября.

Совет. Технические инструкции о том, как изменить целевой уровень API в соответствии с требованиями, можно найти в этом руководстве.

Требования к приложениям для Wear OS

Версия ОС Android (уровень API)

Срок, к которому в приложениях для Wear OS, отправляемых на проверку, должен использоваться этот уровень API
Новые приложения Обновления приложений
Android 13 (уровень API 33) или более поздних версий 31 августа 2024 г. 31 августа 2024 г.
Android 11 (уровень API 30) или более поздних версий 31 августа 2023 г. 31 августа 2023 г.

Требования к приложениям для Android TV

Версия ОС Android (уровень API)

Срок, к которому в приложениях для Android TV, отправляемых на проверку, следует использовать этот уровень API
Новые приложения Обновления приложений
Android 13 (уровень API 33) или более поздних версий 31 августа 2024 г. 31 августа 2024 г.

Условия доступности приложений

Согласно действующим требованиям, к 31 августа 2024 года существующие приложения для мобильных устройств и Android Auto должны поддерживать Android 13 (уровень API 33) или выше, для Wear OS – Android 11 (уровень API 30) или выше, а для Android TV – Android 12 (уровень API 32) или выше. Иначе приложения не будут показываться в Google Play пользователям устройств Android с ОС уровня выше, чем целевой уровень API. Это связано с тем, что такие приложения не отвечают стандартам безопасности и качества, которые ожидаются пользователями от новых версий ОС Android.

  • После 31 августа 2024 года приложения для Android 12 (уровень API 31)* или ниже станут недоступны новым пользователям на устройствах с ОС Android уровня выше, чем целевой уровень API приложения.
  • После 1 ноября 2023 года приложения для Android 11 (уровень API 30) и ниже стали недоступны новым пользователям на устройствах с ОС Android уровня выше, чем целевой уровень API приложения.

* Разработчики могут запросить продление до 1 ноября 2024 г. Доступ к форме запроса продления в Play Console мы предоставим позже.


Как обеспечить соответствие требованиям

Новые приложения

Существующие приложения

Если вы публикуете новое приложение, оно должно поддерживать Android 14 (уровень API 34) или выше.

Если существующее приложение поддерживает Android 13 (уровень API 33) или выше, оно соответствует требованиям.

Иначе оно не будет доступно новым пользователям на устройствах Android с ОС уровня выше, чем целевой уровень API приложения. Это связано с тем, что такие приложения не отвечают стандартам безопасности и качества, которые ожидаются пользователями от новых версий ОС Android.

  • Если вы планируете обновить приложение до версии с более высоким целевым уровнем API, можно запросить продление срока, чтобы ваше приложение было доступно всем пользователям Google Play до 1 ноября 2024 года. Разработчикам будет отправлено сообщение в Play Console со ссылкой, по которой можно заполнить форму и отправить запрос продления.
Если вы обновляете приложение, то должны установить целевой уровень API 34 или выше.


Требования к приложениям для Wear OS

Новые приложения

Существующие приложения

Если вы публикуете новое приложение для Wear OS, оно должно поддерживать Android 13 (уровень API 33) или выше.

Если существующее приложение поддерживает Android 11 (уровень API 30) или выше, оно соответствует требованиям.

Иначе оно не будет доступно в Google Play пользователям устройств Android с ОС уровня выше, чем целевой уровень API приложения. Это связано с тем, что такие приложения не отвечают стандартам безопасности и качества, которые ожидаются пользователями от новых версий ОС Android.

  • Если вы планируете добавить в приложение поддержку Android 13 (уровень API 33) или выше, можно запросить продление срока, чтобы ваше приложение было доступно всем пользователям Google Play до 1 ноября 2024 г. Разработчикам будет отправлено сообщение в Play Console со ссылкой, по которой можно заполнить форму и отправить запрос продления.
Если вы обновляете приложение, то должны установить целевой уровень API 33 (Android 13) или выше.

 

Требования к приложениям для Android TV

Новые приложения

Существующие приложения

Если вы публикуете новое приложение для Wear OS, оно должно поддерживать Android 13 (уровень API 33) или выше.

Если существующее приложение поддерживает Android 12 (уровень API 31) или выше, оно соответствует требованиям.

Иначе оно не будет доступно в Google Play пользователям устройств Android с ОС уровня выше, чем целевой уровень API приложения. Это связано с тем, что такие приложения не отвечают стандартам безопасности и качества, которые ожидаются пользователями от новых версий ОС Android.

  • Если вы планируете добавить в приложение поддержку Android 13 (уровень API 33) или выше, можно запросить продление срока, чтобы ваше приложение было доступно всем пользователям Google Play до 1 ноября 2024 г. Разработчикам будет отправлено сообщение в Play Console со ссылкой, по которой можно заполнить форму и отправить запрос продления.
Если вы обновляете приложение, то должны установить целевой уровень API 33 (Android 13) или выше.

Часто задаваемые вопросы

Для приложений с целевым уровнем API 31 или ниже

У моего приложения, опубликованного в Google Play, целевой уровень API 31 или ниже (29 или ниже у приложения для Wear OS), и я не планирую его обновлять. Что делать в этом случае?

Если вы хотите, чтобы приложение было доступно существующим пользователям, дополнительные действия не требуются. Однако оно не будет доступно в Google Play новым пользователям на устройствах Android с ОС уровня выше, чем целевой уровень API приложения. Оно будет доступно только тем, у кого на устройстве установлена ОС Android с уровнем API не выше, чем у приложения.

Если вам нужно больше времени на подготовку обновления, можно отправить запрос продления, чтобы ваше приложение было доступно всем пользователям Google Play до 1 ноября 2024 года. Форма запроса продления станет доступна в Play Console позднее в этом году.

Если вы хотите, чтобы приложение было недоступно новым пользователям даже на старых устройствах, можно отменить его публикацию.

Я хочу продлить срок, в течение которого приложение будет показываться в Google Play всем пользователям, до 1 ноября 2024 года. Где найти форму запроса?

Разработчики приложений, не соответствующих нашим правилам, получат сообщения и предупреждения в Play Console. Чтобы заполнить форму запроса продления, перейдите в раздел Соответствие правилам, а затем на страницу сведений о предупреждении или нарушении.

Я хочу отменить публикацию некоторых своих приложений в Google Play. Что мне делать?

Следуйте инструкциям по удалению в этой статье Справочного центра.

Как это изменение повлияет на пользователей, которые уже установили мое приложение?

Те, кто устанавливал ваше приложение из Google Play, не заметят никаких изменений и смогут по-прежнему находить, переустанавливать и использовать его на устройствах с любой версией ОС Android, поддерживаемой приложением.

Как это изменение повлияет на скачивание приложения?

Возможно снижение количества скачиваний, если пользователи на устройствах с новыми версиями ОС Android не смогут находить и скачивать ваше приложение в Google Play.

Что произойдет, если пользователь на новом устройстве перейдет по ссылке на контент и окажется на странице приложения с целевым уровнем API 31 или ниже?

В Google Play появится сообщение о том, что установить приложение на устройстве пользователя нельзя, так как приложение разработано для более ранней версии Android. На изображении ниже показано, как примерно будет выглядеть страница приложения для пользователей Google Play.

Есть ли исключения для опубликованных приложений с целевым уровнем API 30 или ниже?

Да. Мы предоставляем исключения для приложений, которые всегда будут частными, – доступ к ним предоставляется только сотрудникам определенной организации для внутреннего использования, а также приложений, которые предназначены для устройств Android Automotive OS.

Эта информация оказалась полезной?

Как можно улучшить эту статью?
true
Поиск
Очистить поле поиска
Закрыть поиск
Приложения Google
Главное меню