Wymagania dotyczące docelowego poziomu interfejsu API w aplikacjach w Google Play

Aby zapewnić większą przejrzystość terminów związanych z docelowym poziomem interfejsu API, ujednolicamy daty do 31 sierpnia każdego roku.

Od 31 sierpnia 2023 r.:

  • Nowe aplikacje muszą być kierowane na Androida w wersji 13 (poziom API 33) lub nowszej. Nie dotyczy to aplikacji na Wear OS, które muszą być kierowane na Androida w wersjach od 11 (poziom API 30) do 13 (poziom API 33).
  • Opublikowane aplikacje muszą być kierowane na interfejs API na docelowym poziomie 31 lub wyższym, aby były dostępne dla użytkowników urządzeń z systemem operacyjnym Android wyższym niż docelowy poziom interfejsu API aplikacji. Aplikacje, które są kierowane na interfejs API na docelowym poziomie 30 lub niższym (w przypadku Wear OS na poziomie 29 lub niższym), będą dostępne tylko na urządzeniach z tym samym lub niższym poziomem interfejsu API.
Jeśli potrzebujesz więcej czasu na zaktualizowanie aplikacji, możesz poprosić o przedłużenie terminu do 1 listopada 2023 r. Na początku sierpnia udostępnimy w Konsoli Play formularze przedłużenia terminu dla Twojej aplikacji. Znajdziesz je na stronie Stan zgodności z zasadami, gdy klikniesz odpowiednie ostrzeżenie lub problem.

Każda nowa wersja Androida wprowadza zmiany, które zwiększają wygodę użytkowników, poprawiają bezpieczeństwo i ogólną wydajność platformy Androida. Każda aplikacja określa w pliku manifestu parametr targetSdkVersion (nazywany również docelowym poziomem interfejsu API). Docelowy poziom interfejsu API przekazuje informacje o tym, jak uruchomić aplikację na różnych wersjach Androida.

Kierowanie aplikacji na aktualny poziom interfejsu API zapewnia użytkownikom korzyści wynikające z ulepszeń zabezpieczeń, wydajności i ochrony prywatności, ale jednocześnie pozwala uruchamiać ją na starszych wersjach Androida (do określonego poziomu minSdkVersion).

Z myślą o zapewnieniu użytkownikom Androida i Google Play większego bezpieczeństwa Google Play wymaga, aby wszystkie aplikacje spełniały podane poniżej wymagania dotyczące docelowego poziomu interfejsu API.

Oto kilka wyjątków od tych wymagań:

  • Aplikacje zawsze prywatne, które są dostępne tylko dla użytkowników w konkretnej organizacji i przeznaczone wyłącznie do dystrybucji wewnętrznej.
  • Aplikacje kierowane na format Automotive, które są zawarte w tym samym pakiecie, będą nadal widoczne dla wszystkich użytkowników Google Play.

Definicje

Nowa aplikacja Aplikacja, która nie została jeszcze opublikowana w Google Play (np. zupełnie nowa aplikacja).
Opublikowana aplikacja Aplikacja, która została opublikowana w Google Play.
Aktualizacja aplikacji Nowa wersja aplikacji, którą przesyłasz do sprawdzenia, aby zastąpić dotychczasową wersję.

Wymagania dotyczące aktualizacji aplikacji

Wersja systemu operacyjnego Android
(poziom interfejsu API)

Od kiedy konieczne jest przesyłanie nowych aplikacji i aktualizacji kierowanych na ten poziom interfejsu API?
Nowe aplikacje Aktualizacje aplikacji

Android 13 (poziom 33 interfejsu API)*

31 sierpnia 2023 roku

31 sierpnia 2023 roku

Android 12 (poziom 31 interfejsu API)

31 sierpnia 2022 roku

1 listopada 2022 roku

* Aby ułatwić deweloperom przejście na nowy poziom API, dajemy im możliwość przedłużenia terminu do 1 listopada.

Wskazówka: porady techniczne dotyczące zmiany docelowego poziomu interfejsu API aplikacji tak, aby spełniał te wymagania, znajdziesz w przewodniku po migracji.

Wymagania aplikacji na Wear OS

Wersja systemu operacyjnego Android (poziom interfejsu API)

Kiedy przesłane aplikacje na Wear OS muszą być kierowane na ten poziom API?
Nowe aplikacje Aktualizacje aplikacji
Android 11 (poziom API 30) (bez zmian) 1 sierpnia 2022 roku 1 listopada 2022 roku

Wymagania dotyczące dostępności aplikacji

Do 31 sierpnia 2023 r. opublikowane aplikacje (na urządzenia mobilne, Androida Auto i Androida TV) muszą być kierowane na interfejs API na poziomie 31 lub wyższym (w przypadku Wear OS na poziomie od 30 do 33). W przeciwnym razie przestaną być wykrywalne dla wszystkich użytkowników Google Play, którzy korzystają z urządzeń z systemem operacyjnym Android w wersji nowszej od docelowego poziomu interfejsu API aplikacji. Stanie się tak, ponieważ aplikacje takie nie będą spełniać standardów bezpieczeństwa i jakości, których oczekują użytkownicy nowszych wersji systemu operacyjnego Android.

  • Po 31 sierpnia 2023 roku nowi użytkownicy, którzy mają system operacyjny Android w wersji wyższej niż docelowy interfejs API, nie będą mogli korzystać z aplikacji, których docelowy poziom to Android 11 (poziom interfejsu API 30)* lub niższy.
  • Po 1 listopada 2022 roku (lub 1 maja 2023 roku, jeśli aplikacja ma rozszerzenie) nowi użytkownicy, którzy mają system operacyjny Android w wersji wyższej niż docelowy interfejs API, nie mogą korzystać z aplikacji, których docelowy poziom to Android 10 (poziom interfejsu API 29) lub niższy.

* Aby ułatwić deweloperom przejście na nowy poziom API, dajemy im możliwość przedłużenia terminu do 1 listopada 2023 roku. Na początku sierpnia udostępnimy w Konsoli Play formularze przedłużenia terminu dla Twojej aplikacji. Znajdziesz je na stronie Stan zgodności z zasadami, gdy klikniesz odpowiednie ostrzeżenie lub problem.


Co zrobić, aby zachować zgodność z zasadami

Nowe aplikacje

Opublikowane aplikacje

Gdy publikujesz nową aplikację, musisz kierować ją na interfejs API na poziomie 33 lub wyższym.

Jeśli docelowy poziom interfejsu API Twojej opublikowanej aplikacji to 31 lub wyższy, aplikacja jest zgodna z tymi zasadami.

Jeśli docelowy poziom interfejsu API Twojej aplikacji jest niższy niż 31, przestanie ona być dostępna dla wszystkich użytkowników Google Play, którzy korzystają z urządzeń z systemem operacyjnym Android w wersji nowszej od docelowego poziomu interfejsu API aplikacji. Stanie się tak, ponieważ Twoja aplikacja nie będzie spełniać standardów bezpieczeństwa i jakości, których oczekują użytkownicy nowszych wersji Androida.

  • Jeśli planujesz zaktualizować tę aplikację na wyższy poziom interfejsu API, możesz przesłać prośbę o przedłużenie możliwości udostępnienia aplikacji wszystkim użytkownikom Google Play do 1 listopada 2023 r. W przypadku aplikacji, których to dotyczy, pojawią się ostrzeżenia o naruszeniu zasad i wiadomości w skrzynce odbiorczej w Konsoli Play. Dostęp do formularza przedłużenia terminu będzie można uzyskać na stronie ze szczegółami dotyczącymi ostrzeżenia lub problemu (z poziomu strony Stan zgodności z zasadami).
Gdy aktualizujesz aplikację, musisz kierować ją na interfejs API na poziomie 33 lub wyższym.


Wymagania Wear OS

Nowe aplikacje

Opublikowane aplikacje

Gdy publikujesz nową aplikację, musisz kierować ją na interfejs API na poziomie 30 lub wyższym, aż do Androida w wersji 13 (poziom API 33).

Jeśli docelowy poziom interfejsu API Twojej opublikowanej aplikacji to 30 lub wyższy, aż do Androida w wersji 13 (poziom API 33), to aplikacja jest zgodna z tymi zasadami.

Jeśli docelowy poziom interfejsu API Twojej aplikacji jest niższy niż 30, przestanie ona być dostępna dla wszystkich użytkowników Google Play, którzy korzystają z urządzeń z systemem operacyjnym Android w wersji nowszej od docelowego poziomu interfejsu API aplikacji. Stanie się tak, ponieważ Twoja aplikacja nie będzie spełniać standardów bezpieczeństwa i jakości, których oczekują użytkownicy nowszych wersji Androida.

  • Jeśli planujesz zaktualizować tę aplikację do poziomu interfejsu API 30, możesz przesłać prośbę o przedłużenie możliwości dystrybucji wśród wszystkich użytkowników Google Play do 1 listopada 2023 r. W przypadku aplikacji, których to dotyczy, pojawią się ostrzeżenia o naruszeniu zasad i wiadomości w skrzynce odbiorczej w Konsoli Play. Dostęp do formularza przedłużenia terminu będzie można uzyskać na stronie ze szczegółami dotyczącymi ostrzeżenia lub problemu (z poziomu strony Stan zgodności z zasadami).
Podczas aktualizowania aplikacji musisz korzystać z interfejsu API na poziomie 30 lub wyższym, aż do Androida w wersji 13 (poziom API 33).

Najczęstsze pytania

Aplikacje kierowane na interfejs API na poziomie 30 lub niższym

Moja aplikacja opublikowana w Google Play jest kierowana na interfejs API na poziomie 30 lub niższym (w przypadku Wear OS kierowana na interfejs API na poziomie 29 lub niższym). Nie planuję jej aktualizować. Jakie mam możliwości?

Jeśli nadal chcesz udostępniać tę aplikację swoim dotychczasowym użytkownikom, nie musisz nic robić. Aplikacja nie będzie jednak dostępna w Google Play dla nowych użytkowników na urządzeniach z Androidem w wersji nowszej niż ta, na którą jest kierowana Twoja aplikacja. Będzie ona dostępna tylko dla użytkowników Google Play na urządzeniach z Androidem na poziomie API Twojej aplikacji lub niższym.

Do 31 sierpnia 2023 r. Twoja aplikacja musi spełnić wymóg dotyczący docelowego poziomu API. W przeciwnym razie przestanie być widoczna dla wszystkich użytkowników Google Play, którzy korzystają z urządzeń z systemem operacyjnym Android w wersji nowszej niż docelowy poziom interfejsu API aplikacji.

Jeśli planujesz aktualizację aplikacji do nowszej wersji docelowego poziomu API i potrzebujesz więcej czasu niż do 31 sierpnia, możesz poprosić o przedłużenie terminu na dalsze rozpowszechnianie aplikacji wszystkim użytkownikom Google Play do 1 listopada. Formularz przedłużenia będzie dostępny w Konsoli Play jeszcze w tym roku.

Jeśli nie chcesz udostępniać swojej aplikacji nowym użytkownikom także na starszych urządzeniach, możesz cofnąć jej publikację.

Gdzie znajdę formularz przedłużenia terminu, aby do 1 listopada 2023 roku móc nadal udostępniać aplikację wszystkim użytkownikom Google Play?

Tylko w przypadku aplikacji niezgodnych z zasadami pojawią się ostrzeżenia i wiadomości w skrzynce odbiorczej w Konsoli Play. Formularz przedłużenia terminu jest dostępny stronie ze szczegółami dotyczącymi ostrzeżenia lub problemu w Konsoli Play (z poziomu strony Stan zgodności z zasadami).

Mam aplikacje, których nie chcę już udostępniać w Google Play. Co mogę zrobić?

Instrukcje cofania publikacji aplikacji znajdziesz w artykule Aktualizowanie i wycofywanie aplikacji.

Jaki to będzie mieć wpływ na użytkowników, którzy pobrali już aplikację?

Nie będzie to miało wpływu na użytkowników, którzy wcześniej zainstalowali taką aplikację z Google Play. Wciąż będą oni mogli ją znaleźć, ponownie zainstalować i używać na dowolnej obsługiwanej przez nią wersji systemu operacyjnego Android.

Czy ta zmiana wpłynie na pobrania aplikacji?

Zmiana może mieć wpływ na wskaźniki pobrań, ponieważ nowi użytkownicy urządzeń z nowszymi wersjami systemu operacyjnego Android nie będą w stanie znaleźć ani pobrać Twojej aplikacji z Google Play.

Co się stanie, jeśli użytkownik na nowszym urządzeniu kliknie precyzyjny link do strony sklepu z aplikacjami, ale aplikacja będzie kierowana na interfejs API na poziomie 30 lub niższym?

Google Play poinformuje użytkownika, że na danym urządzeniu nie można zainstalować tej aplikacji, ponieważ została ona utworzona dla starszej wersji Androida.

Czy są jakieś wyjątki dla opublikowanych już aplikacji kierowanych na interfejs API 30 lub niższy?

Tak. Wyjątkiem są aplikacje zawsze prywatne, które są dostępne tylko dla użytkowników w konkretnej organizacji i przeznaczone wyłącznie do dystrybucji wewnętrznej, oraz aplikacje kierowane na format systemu operacyjnego Android Automotive.

Czy to było pomocne?

Jak możemy ją poprawić?

Potrzebujesz dodatkowej pomocy?

Wykonaj te czynności:

Szukaj
Wyczyść wyszukiwanie
Zamknij wyszukiwanie
Aplikacje Google
Menu główne