Persyaratan API level target untuk aplikasi Google Play

Mulai 1 November 2022, jika aplikasi Anda tidak menargetkan API level 30 atau yang lebih tinggi, pengguna baru dengan versi OS Android yang lebih baru tidak akan dapat menemukan atau menginstal aplikasi Anda di Google Play. Anda dapat meminta perpanjangan jika memerlukan tambahan waktu untuk mengupdate aplikasi. Periksa Pesan Kotak Masuk Konsol Play untuk mendapatkan link ke formulir perpanjangan setiap aplikasi Anda.

Setiap versi Android baru memperkenalkan perubahan yang meningkatkan pengalaman pengguna, keamanan, dan performa platform Android secara keseluruhan. Setiap aplikasi menentukan targetSdkVersion (disebut juga API level target) di file manifes. API level target menunjukkan bagaimana aplikasi Anda seharusnya berjalan pada versi Android yang berbeda.

Dengan mengonfigurasi aplikasi agar menargetkan API level terbaru, Anda memastikan bahwa pengguna mendapatkan manfaat dari peningkatan keamanan, privasi, dan performa, sembari tetap mengizinkan aplikasi Anda berjalan di versi Android yang lebih lama (sampai ke minSdkVersion yang ditentukan).

Untuk memberi pengguna Android dan Google Play pengalaman yang aman, Google Play mewajibkan semua aplikasi memenuhi persyaratan API level target yang tercantum di bawah ini.

Definisi

Aplikasi baru Aplikasi yang belum dipublikasikan di Google Play (yakni aplikasi baru).
Aplikasi yang sudah ada Aplikasi yang dipublikasikan di Google Play.
Update aplikasi Versi baru aplikasi yang Anda kirimkan untuk peninjauan guna mengganti aplikasi yang sudah ada.
 

Persyaratan update aplikasi

Versi Android OS (API level)

Kapan pengiriman aplikasi diwajibkan untuk memenuhi API level target ini?
Aplikasi baru Update aplikasi*

Android 13 (API level 33)

1 Agustus 2023

1 November 2023

Android 12 (API level 31)

1 Agustus 2022

1 November 2022

*Untuk memudahkan transisi bagi developer, kami memberi developer tambahan waktu untuk mengupdate aplikasi yang sudah ada.

Tips: Untuk mendapatkan panduan teknis mengenai cara mengubah API level target aplikasi agar memenuhi persyaratan ini, lihat panduan migrasi.

Persyaratan aplikasi Wear OS

Versi Android OS

Kapan aplikasi Wear OS diwajibkan untuk menargetkan API level ini?
Aplikasi baru Update aplikasi*

Android 11 (API level 30)

1 Agustus 2022

1 November 2022

*Untuk memudahkan transisi bagi developer, kami memberi developer tambahan waktu untuk mengupdate aplikasi yang sudah ada.

 

Persyaratan visibilitas aplikasi

Aplikasi yang sudah ada harus menargetkan API level 30 atau yang lebih tinggi sebelum 1 November 2022. Jika tidak memenuhinya, aplikasi tidak akan lagi dapat ditemukan oleh semua pengguna Google Play yang perangkatnya menjalankan versi Android OS yang lebih baru daripada API level target aplikasi Anda. Hal ini terjadi karena aplikasi Anda tidak di-build untuk memenuhi standar keamanan dan kualitas yang diharapkan pengguna dari versi OS Android yang lebih baru. 

Jika memerlukan tambahan waktu untuk mengupdate aplikasi agar memenuhi target API level 31 atau yang lebih tinggi, Anda dapat mengirimkan permintaan perpanjangan agar aplikasi Anda tetap dapat ditemukan oleh semua pengguna Google Play hingga 1 Mei 2023. Periksa Pesan di Kotak Masuk Konsol Play Anda untuk mendapatkan link ke formulir perpanjangan untuk setiap aplikasi Anda.

Catatan: Aplikasi Wear OS dikecualikan dari persyaratan visibilitas ini.

Hal yang perlu dilakukan untuk mematuhi kebijakan 

Aplikasi baru

Saat memublikasikan aplikasi baru, Anda harus menargetkan API level 31 atau yang lebih tinggi.

Aplikasi yang sudah ada

Jika aplikasi yang sudah ada menargetkan API level 30 atau yang lebih tinggi, berarti aplikasi Anda sudah mematuhi kebijakan ini. 

Jika target aplikasi yang sudah ada lebih rendah dari API level 30, aplikasi tersebut tidak akan lagi dapat ditemukan oleh semua pengguna Google Play yang perangkatnya menjalankan versi Android OS yang lebih baru daripada API level target aplikasi. Hal ini terjadi karena aplikasi Anda tidak di-build untuk memenuhi standar keamanan dan kualitas yang diharapkan pengguna dari versi OS Android yang lebih baru. 

  • Jika berencana mengupdate aplikasi ini untuk memenuhi target API level 31 atau yang lebih tinggi, Anda dapat mengirimkan permintaan perpanjangan agar aplikasi tetap didistribusikan ke semua pengguna di Google Play hingga 1 Mei 2023. Aplikasi yang terpengaruh akan menerima pesan yang berisi link formulir permintaan perpanjangan di pesan Kotak Masuk Konsol Play.

Saat mengupdate aplikasi, Anda harus menargetkan API level 31 atau yang lebih tinggi.

  • Jika Anda ingin mengirimkan update aplikasi tetapi memerlukan tambahan waktu untuk menargetkan API level 31 atau yang lebih tinggi, Anda dapat meminta pengecualian hingga 1 Desember 2022 melalui formulir dukungan kami. Setelah tanggal ini, Anda tidak akan lagi dapat mengirimkan update aplikasi yang menargetkan API level yang lebih lama.

Pertanyaan umum (FAQ)

Untuk semua aplikasi

Setelah tanggal 1 November 2022, apakah saya dapat mengirimkan aplikasi yang tidak menargetkan API level 31 atau yang lebih tinggi? Jika tidak, bagaimana cara meminta pengecualian sementara?

Setelah tanggal 1 November 2022, kebijakan kami mewajibkan pengiriman aplikasi yang menargetkan API level 31 atau yang lebih tinggi. Jika Anda ingin mengirimkan update aplikasi tetapi memerlukan tambahan waktu untuk menargetkan API level 31 atau yang lebih tinggi, Anda dapat meminta pengecualian hingga 1 Desember 2022 melalui formulir dukungan kami. Setelah tanggal ini, Anda tidak akan lagi dapat mengirimkan update aplikasi yang menargetkan API level yang lebih lama.

Untuk aplikasi yang menargetkan API level 29 atau yang lebih rendah

Saya memiliki aplikasi yang tersedia di Google Play Store yang menargetkan API level 29 atau yang lebih rendah dan saya tidak berencana untuk mengupdatenya. Apa opsi saya?

Jika ingin tetap membuat aplikasi ini tersedia bagi pengguna yang ada, Anda tidak perlu melakukan apa pun. Namun, aplikasi Anda akan mengalami penurunan distribusi mulai 1 November karena menargetkan API level yang lebih lama. Aplikasi tersebut hanya akan tersedia untuk perangkat yang menjalankan API level 29 atau yang lebih lama. 

Jika ingin aplikasi Anda tetap dapat ditemukan oleh semua pengguna di Google Play, Anda harus mengupdatenya ke API level target yang lebih baru. Anda dapat mengupdate aplikasi Anda kapan saja. Jika berencana mengupdate aplikasi ke API level target yang lebih baru dan memerlukan tambahan waktu, Anda dapat meminta perpanjangan agar aplikasi tetap didistribusikan ke semua pengguna Google Play hingga 1 Mei 2023. Mulai 1 Mei 2023, aplikasi Anda harus memenuhi persyaratan API level target ini. Jika tidak, aplikasi Anda tidak akan lagi dapat ditemukan oleh semua pengguna Google Play yang perangkatnya menjalankan versi Android OS yang lebih baru daripada API level target aplikasi Anda.

Jika ingin menghentikan ketersediaan aplikasi Anda bagi pengguna baru meski di perangkat lama, Anda dapat membatalkan publikasi aplikasi.

Di mana saya dapat menemukan formulir perpanjangan agar aplikasi saya tetap didistribusikan ke semua pengguna Google Play hingga 1 Mei 2023?

Hanya aplikasi yang tidak mematuhi kebijakan yang akan menerima formulir perpanjangan melalui pesan di Kotak Masuk Konsol Play. Pesan tersebut berjudul “Perubahan kebijakan API level target akan memengaruhi ketersediaan aplikasi di Google Play mulai 1 November 2022”.

Saya ingin menghentikan publikasi aplikasi saya di Google Play. Apa yang dapat saya lakukan? 

Lihat artikel Pusat Bantuan ini untuk mendapatkan petunjuk cara membatalkan publikasi aplikasi. 

Bagaimana dampak dari perubahan ini pada pengguna yang sudah mendownload aplikasi saya? 

Pengguna yang sebelumnya telah menginstal aplikasi tersebut dari Google Play tidak akan terkena dampak dan tetap dapat menemukan, menginstal ulang, dan menggunakannya di versi Android OS apa pun yang didukung aplikasi Anda.

Apakah perubahan ini akan berdampak pada download aplikasi?  

Perubahan ini mungkin berdampak pada tingkat download aplikasi Anda jika pengguna baru yang menggunakan versi Android OS yang lebih baru di perangkatnya tidak dapat menemukan atau mendownload aplikasi tersebut dari Google Play.

Seperti apa dampaknya terhadap pengalaman pengguna jika pengguna mengunjungi deep link ke halaman app store menggunakan perangkat dengan versi Android OS yang lebih baru, tetapi aplikasi tersebut menargetkan API level 29 atau yang lebih rendah?

Google Play akan memberi tahu pengguna bahwa aplikasi ini tidak tersedia untuk diinstal di perangkatnya. 
Apakah ini membantu?
Bagaimana cara meningkatkannya?

Perlu bantuan lain?

Login untuk opsi dukungan tambahan guna memecahkan masalah dengan cepat

Telusuri
Hapus penelusuran
Tutup penelusuran
Aplikasi Google
Menu utama
Pusat Bantuan Penelusuran
false
false
true
92637
false
false