A Google Play-alkalmazások megcélzott API-szintjére vonatkozó követelmények

Minden új Android-verzió olyan módosításokat tartalmaz, amelyek biztonsági és teljesítménybeli fejlesztéseket hoznak, valamint összességében javítják az Android felhasználói élményét. Minden alkalmazás rendelkezik targetSdkVersion értékkel (más néven a megcélzott API-szinttel) a manifestfájlban, amely arról tájékoztat, hogy az adott alkalmazás hogyan fut a különféle Android-verziókon.

Ha alkalmazást úgy konfigurálod, hogy valamelyik legutóbbi API-szintet célozza meg, akkor a felhasználóid számára biztosíthatod a fontos biztonsági és teljesítménybeli fejlesztéseket, miközben az alkalmazásod továbbra is futhat a régebbi Android-verziókon is (egészen a minSdkVersion verzióig visszamenően).

Annak érdekében, hogy az Android- és a Google Play-felhasználók biztonságos élményben részesüljenek, a Google Play előírja, hogy az alkalmazásoknak meg kell felelnie az alább felsorolt, megcélzott API-szintre vonatkozó összes követelménynek.

Fogalommeghatározások

Új alkalmazás Olyan alkalmazás, amely még nincs közzétéve a Play Áruházban (például vadonatúj alkalmazás).
Alkalmazásfrissítés A Play Áruházban már közzétett alkalmazás új verziója.
Meglévő alkalmazás Olyan közzétett alkalmazás, amely nem kap frissítéseket.

Követelmények

Android operációs rendszer verziója

Mikor kell a Google Play-alkalmazásoknak kötelezően megcélozni ezt az API-szintet?
Új alkalmazások Alkalmazásfrissítések ** Meglévő alkalmazások

Android 12 (31-es API-szint)

2022. augusztus 1.

2022. november 1.

2023. november 1.

Android 11 (30-as API-szint)

2021. augusztus 2.

2021. november 1.

2022. november 1.

Tipp: Ha technikai tanácsra van szükséged azzal kapcsolatban, hogy az alkalmazásod által megcélzott API-szintet miként kell a követelményeknek megfelelően módosítanod, olvasd el a migrációs útmutatót.

Wear OS-alkalmazásokra vonatkozó követelmények

Android operációs rendszer verziója

Mikor kell a Wear OS-alkalmazásoknak kötelezően megcélozni ezt az API-szintet?
Új alkalmazások Alkalmazásfrissítések ** Meglévő alkalmazások

Android 11 (30-as API-szint)

2022. augusztus 1.

2022. november 1.

Nincs követelmény

Android 10 (29-es API-szint)

Nincs követelmény

Android 9 (28-as API-szint)

2019. augusztus 1.

2019. november 1.


** Annak érdekében, hogy megkönnyítsük az áttérést a fejlesztőknek, az alkalmazásfrissítéseknek több hónapot adunk a követelményeknek való megfelelésre, mint az új alkalmazásoknak.

Lehetséges alkalmazáshatás

Ha az alkalmazás nem éri el a kötelezően megcélzandó API-szintet, akkor ez az alábbiak szerint lehet hatással az alkalmazására: 

Alkalmazás

Hatás

Új alkalmazások

Nem tudsz majd olyan alkalmazáscsomagokat közzétenni, amelyek nem felelnek meg a megcélzott API-szintre vonatkozó követelményeknek a Play Console-ban.

Alkalmazásfrissítések

Nem tudsz majd olyan alkalmazáscsomagokat vagy APK-kat beküldeni, amelyek nem felelnek meg a megcélzott API-szintre vonatkozó követelményeknek a Play Console-ban.

Meglévő alkalmazások

Az alkalmazásod nem jelenik meg a Google Playen olyan új felhasználók számára, akiknek az eszközén futó Android OS-verzió újabb, mint az alkalmazás megcélzott API-szintje. Ez azt jelenti, hogy az új felhasználók nem tudják majd felfedezni és telepíteni az alkalmazást a Google Playről.

Azok a felhasználók, akik korábban már telepítették az alkalmazást a Google Playről, továbbra is felfedezhetik, újratelepíthetik, illetve használhatják. Akkor is hozzáférhetnek az alkalmazáshoz, ha új Android-eszközre térnek át.


Annak érdekében, hogy megkönnyítsük az áttérést a fejlesztőknek, az alkalmazásfrissítéseknek több hónapot adunk a követelményeknek való megfelelésre, mint az új alkalmazásoknak.

Gyakran Ismételt Kérdések

Mi a teendő, ha több időre van szükségem a frissítés elvégzéséhez az összes meglévő alkalmazásomnál?

Tudjuk, hogy egyes fejlesztőknek több időre lesz szükségük az irányelveknek való megfeleléshez, ezért 2022. november 1-jéig van ideje a fejlesztőknek frissíteni a meglévő alkalmazásokat. Ha még több időre van szükséged, akkor a Play Console-ban majd az év második felében rendelkezésre álló űrlapon igényelhetsz hosszabbítást.

Ez a hosszabbítás nem vonatkozik az új alkalmazásokra és az új alkalmazásfrissítésekre.

Régebbi alkalmazásaim vannak, amelyeket már nem szeretnék közzétenni a Google Playen. Mit tehetek?

Ebben a súgócikkben utasításokat találsz az alkalmazás közzétételének visszavonásával kapcsolatban. 

Milyen hatással lesz ez azokra a felhasználókra, akik már letöltötték az előző alkalmazásomat?

Azok a felhasználók, akik korábban már telepítették az alkalmazást a Google Playről, továbbra is felfedezhetik, újratelepíthetik és használhatják az alkalmazást az általa támogatott bármely Android operációs rendszeren.

Miben különbözik ez az irányelvfrissítés a megcélzott API-szintre vonatkozó meglévő követelménytől?

A Google Play Megcélzott API-szintre vonatkozó irányelve további védelmet biztosít a felhasználók számára, mivel arra ösztönzi az összes fejlesztőt, hogy az új Android API-szinteken alkalmazza a biztonsággal és az engedélyekkel kapcsolatos legújabb frissítéseket. A módosítás előírja, hogy a fejlesztők célozzák meg a legutóbbi Android-kiadásokat, hogy a meglévő alkalmazások terjeszthetők legyenek az új eszközökkel rendelkező új felhasználók számára.

Érinti ez a frissítés az alkalmazásletöltéseket?  

Nem tudunk konkrét útmutatást nyújtani. Hatással lehet az alkalmazás letöltési szintjeire, ha az újabb Android-verziót használó eszközök felhasználói nem tudják felfedezni vagy letölteni az alkalmazást a Google Playről.

Érinti ez a frissítés az alkalmazások felülvizsgálatának idővonalát?  

Ez a módosítás nem lesz hatással az alkalmazás felülvizsgálatának jelenlegi idejére, a fejlesztők pedig frissíteni tudják meglévő alkalmazásaikat a folyamatos kiadások érdekében.
Hasznosnak találta?
Hogyan fejleszthetnénk?

További segítségre van szüksége?

Jelentkezzen be a további támogatási lehetőségek igénybevételéhez, hogy gyorsabban megoldhassa a problémát

Keresés
Keresés törlése
A keresés bezárása
Google-alkalmazások
Főmenü
Keresés a Súgóoldalakon
true
92637
false
false