Google Play's Target API Level Policy

To provide users with a safe and secure experience, Google Play requires the following target API levels for all apps:

New apps and app updates MUST target an Android API level within one year of the latest major Android version release. New apps and app updates that fail to meet this requirement will be prevented from app submission in Play Console.

Existing Google Play apps that are not updated and that do not target an API level within two years of the latest major Android version release, will not be available to new users with devices running newer versions of Android OS. Users who have previously installed the app from Google Play will continue to be able to discover, re-install, and use the app on any Android OS version that the app supports.

For technical advice on how to meet the target API level requirement, please consult the migration guide

For exact timelines and exceptions, please refer to this Help Center article.

Was this helpful?

How can we improve it?
Search
Clear search
Close search
Google apps
Main menu
2942701294320807842
true
Search Help Center
true
true
true
true
true
92637