在应用中使用第三方 SDK

您在应用中内置第三方 SDK 之后,相应 SDK 可能会对应用的兼容性、性能、安全性和质量产生重大影响。

关于第三方 SDK 的变更

为帮助您确保应用使用的所有第三方软件都符合 Google Play 开发者计划政策,并且确保这类软件还能对应用的用户体验产生积极影响,Google Play 将着手在 Play 管理中心内指出常用 SDK 存在的已知问题。

为确定您的应用使用了哪个 SDK,我们会使用应用中包含的依赖项文件。依赖项文件会列出应用依赖的所有版本化库。默认情况下,使用 Android App Bundle 的应用会提供依赖项文件。2021 年 8 月之前使用 Android Gradle 插件 4.0 或更高版本创建且采用 APK 发布格式的应用包含依赖项文件。

了解应用的第三方 SDK 存在的问题

在适用情况下,Play 管理中心内的正式版页面顶部或版本概览页面上会详细指出应用所用的 SDK 版本存在的问题。

如果您的应用使用的 SDK 版本可能会导致该应用违反 Google Play 开发者计划政策,那么使用该 SDK 的新应用版本可能会被拒。根据违规行为类型,我们会指引您确保 SDK 使用情况符合我们的用户数据政策、改为使用 SDK 提供商建议使用的其他版本,或者移除相应 SDK。

如果您的应用使用的 SDK 版本已过时或存在严重问题,您会收到警告,可能需要采取进一步措施。例如,如果 SDK 提供商通知我们您的应用使用的 SDK 版本已过时,那么您仍然可以发布该应用,但将无法再发布使用过时 SDK 版本的其他应用版本;您将需要使用更新的 SDK 版本。如果根据 SDK 提供商报告,您的应用使用的 SDK 版本存在严重问题,您会看到一个警告,其中会提供 SDK 提供商针对该类型问题所做的详细说明。

如果您对已过时或存在严重问题的 SDK 版本存在疑问,我们建议您与 SDK 提供商联系。

该内容对您有帮助吗?
您有什么改进建议?

需要更多帮助?

登录可获取更多支持选项,以便快速解决您的问题

搜索
清除搜索查询
关闭搜索框
Google 应用
主菜单
搜索支持中心
true
92637
false