Uygulamanızda üçüncü taraf SDK'ları kullanma

Uygulamanıza eklendiğinde üçüncü taraf SDK'lar, uygulamanın uyumluluğunu, performansını, güvenliğini ve kalitesini önemli derecede etkileyebilir.

Üçüncü taraf SDK'larla ilgili değişiklikler

Google Play, uygulamanızın kullandığı üçüncü taraf yazılımların hem Google Play'in Geliştirici Program Politikaları'na uygun olmasını hem de diğer şekillerde kullanıcı deneyiminize olumlu katkıda bulunmasını sağlamanıza yardımcı olmak için Play Console'da popüler SDK'larla ilgili bilinen sorunları işaretlemeye başlayacak.

Uygulamanızın hangi SDK'yı kullandığını öğrenmek için uygulamanızda bulunan bağımlılık dosyasını kullanırız. Bağımlılık dosyası, uygulamanın bağımlı olduğu sürümlerdeki tüm kitaplıkları listeler. Android App Bundle'ı kullanan uygulamalar, varsayılan olarak bağımlılık dosyasını sağlar. Ağustos 2021'den önce oluşturulan ve APK'larla yayınlanan uygulamalar, Android Gradle Eklentisi 4.0 sürümünden itibaren bağımlılık dosyası içerir.

Uygulamanızın üçüncü taraf SDK'larla ilgili sorunlarını anlama

Varsa uygulamanızın kullandığı SDK sürümleriyle ilgili sorunlar, Play Console'daki Üretim sayfasının üst kısmında veya Sürüme genel bakış sayfasında ayrıntılı olarak yer alır.

Google Play'in Geliştirici Program Politikaları ile uyumsuzluğa neden olabilecek bir SDK sürümünü kullanan yeni uygulama sürümleri reddedilebilir. İhlalin türüne bağlı olarak, SDK kullanımınızın Kullanıcı Verileri Politikalarımıza uygun olmasını sağlamak, SDK sağlayıcının önerdiği farklı bir sürüme geçmek veya SDK'yı kaldırmak üzere yönlendirilirsiniz.

Uygulamanız, eski veya önemli sorunlar bulunan bir SDK sürümü kullanıyorsa ek işlem yapılmasını gerektirebilecek uyarı alırsınız. Örneğin, SDK sağlayıcısı, uygulamanızın eski bir SDK sürümünü kullandığını bize bildirdiyse uygulamanızı yine de yayınlayabilirsiniz. Ancak SDK'nın eski sürümünü kullanarak uygulamanızın başka bir sürümünü yayınlayamazsınız. SDK'nın güncellenmiş sürümünü kullanmanız gerekir. Uygulamanız, SDK sağlayıcısının önemli sorunlar bulunduğunu bildirdiği bir SDK sürümü kullanıyorsa SDK sağlayıcının belirttiği sorun türünü açıklayan bir uyarı görürsünüz.

Eski veya önemli sorunlar bulunan bir SDK sürümü hakkında sorularınız varsa SDK sağlayıcısına başvurmanız önerilir.

Bu size yardımcı oldu mu?
Bunu nasıl iyileştirebiliriz?

Daha fazla yardıma mı ihtiyacınız var?

Sorununuzu hızla çözmek için oturum açarak ek destek seçeneklerinden yararlanın

Arama
Aramayı temizle
Aramayı kapat
Google uygulamaları
Ana menü
Yardım Merkezinde Arayın
true
92637
false