SDK's van derden gebruiken in je app

Zodra externe SDK's zijn ingebouwd in je app, kunnen ze een aanzienlijke impact hebben op de compatibiliteit, prestaties, veiligheid, beveiliging en kwaliteit van de app.

Wijzigingen voor SDK's van derden

Google Play markeert bekende problemen met populaire SDK's in de Play Console zodat je ervoor kunt zorgen dat software van derden die je app gebruikt, voldoet aan het Programmabeleid voor ontwikkelaars van Google Play en een positieve bijdrage aan de gebruikerservaring levert.

We gebruiken het bestand met afhankelijkheden dat is opgenomen in je app om erachter te komen welke SDK je app gebruikt. Het bestand met afhankelijkheden bevat alle versiebibliotheken waarvan de app afhankelijk is. Apps die de Android App Bundle gebruiken, leveren standaard het bestand met afhankelijkheden. Apps met APK's bevatten het bestand met afhankelijkheden vanaf versie 4.0 van de Android-plug-in voor Gradle.

Inzicht krijgen in problemen met de SDK van derden in je app

Indien van toepassing worden problemen met SDK-versies die door je app worden gebruikt, beschreven in de Play Console bovenaan de pagina Productie of op de pagina Releaseoverzicht.

Als je app een SDK-versie gebruikt die ervoor kan zorgen dat je app niet voldoet aan het Programmabeleid voor ontwikkelaars van Google Play, wordt je gevraagd een andere SDK-versie te gebruiken.

Als je app een SDK-versie gebruikt die verouderd is of kritieke problemen bevat, krijg je een waarschuwing waarvoor verdere actie kan zijn vereist. Als een SDK-provider ons bijvoorbeeld heeft laten weten dat de SDK-versie die je app gebruikt, verouderd is, kun je de app nog steeds vrijgeven. Je kunt niet nog een versie van de app vrijgeven via de verouderde SDK-versie. Je moet dan de geüpdatete SDK-versie gebruiken. Als je app een SDK-versie gebruikt waarvoor de SDK-provider meldt dat deze kritieke problemen bevat, zie je een waarschuwing met een beschrijving van het type probleem, zoals aangegeven door de SDK-provider.

Als je vragen hebt over een SDK-versie die verouderd is of kritieke problemen bevat, raden we je aan contact op te nemen met de SDK-provider.

Was dit nuttig?
Hoe kunnen we dit verbeteren?

Meer hulp nodig?

Log in voor extra supportopties om uw probleem snel op te lossen