앱에서 타사 SDK 사용하기

앱에 빌드된 타사 SDK는 앱의 호환성, 성능, 안전, 보안 및 품질에 상당한 영향을 미칠 수 있습니다.

타사 SDK 관련 변경사항

앱이 사용 중인 타사 소프트웨어가 Google Play 개발자 프로그램 정책을 준수하고 사용자 환경에 긍정적인 영향을 미칠 수 있도록 지원하기 위해 Google Play에서는 Play Console에 인기 SDK와 관련해 알려진 문제를 표시할 예정입니다.

앱에서 사용 중인 SDK를 확인하기 위해 Google에서는 앱에 포함된 종속 항목 파일을 사용합니다. 종속 항목 파일에는 앱이 종속된 버전 지정 라이브러리가 모두 표시됩니다. Android App Bundle을 사용하는 앱은 기본적으로 종속 항목 파일을 제공합니다. Android Gradle 플러그인 4.0부터는 APK를 사용하는 앱에 종속 항목 파일이 포함됩니다.

앱의 타사 SDK 문제 이해하기

해당하는 경우 앱에서 사용되는 SDK 버전 관련 문제는 Play Console의 프로덕션 페이지 상단 또는 출시 개요 페이지에 자세히 설명되어 있습니다.

앱에서 사용 중인 SDK 버전으로 인해 Google Play 개발자 프로그램 정책을 위반할 가능성이 있는 경우 이 SDK 버전을 사용하는 새로운 앱 버전이 거부될 수 있습니다. 위반 유형에 따라 SDK 사용이 사용자 데이터 정책을 준수하는지 확인하거나, SDK 제공업체가 권장하는 다른 버전으로 전환하거나, SDK를 삭제하라는 안내를 받게 됩니다.

앱에서 오래되었거나 중요한 문제가 있는 SDK 버전을 사용 중인 경우 추가 조치가 필요할 수 있다는 경고가 표시됩니다. 예를 들어, SDK 제공업체가 앱에서 사용 중인 SDK 버전이 오래되었다는 점을 알렸더라도 개발자는 여전히 앱을 출시할 수 있지만 오래된 버전의 SDK를 사용하는 다른 버전의 앱을 출시할 수는 없습니다. 업데이트된 SDK 버전을 사용해야 합니다. 앱이 SDK 제공업체가 심각한 문제를 보고한 SDK 버전을 사용 중인 경우, SDK 제공업체에서 자세히 설명한 문제의 유형을 설명하는 경고가 표시됩니다.

오래되었거나 중요한 문제가 있는 SDK 버전에 관해 궁금한 점이 있으면 SDK 제공업체에 문의하시기 바랍니다.

도움이 되었나요?
어떻게 하면 개선할 수 있을까요?

도움이 더 필요하신가요?

로그인하여 추가 지원 옵션으로 문제를 빠르게 해결하세요.

검색
검색어 지우기
검색 닫기
Google 앱
기본 메뉴
도움말 센터 검색
true
92637
false