アプリでサードパーティの SDK を使用する

アプリにサードパーティの SDK を組み込むと、アプリの互換性、パフォーマンス、安全性、セキュリティ、品質に大きな影響を与える可能性があります。

サードパーティの SDK に関する変更点

アプリが使用しているサードパーティ ソフトウェアが Google Play のデベロッパー プログラム ポリシーを確実に遵守し、それ以外の点でも、ユーザー エクスペリエンスに積極的に貢献できるようにするため、Google Play は一般的な SDK に関する既知の問題の通知を Google Play Console で開始する予定です。

アプリで使用されている SDK を確認するため、Google はアプリに含まれている依存関係ファイルを使用します。依存関係ファイルには、アプリが依存しているバージョン管理されたライブラリがすべて記載されています。Android App Bundle を使用するアプリは、デフォルトで依存関係ファイルを備えています。APK 公開形式を使用して 2021 年 8 月より前に作成したアプリには、Android Gradle プラグイン 4.0 以降の依存関係ファイルが含まれています。

アプリのサードパーティの SDK に関する問題を把握する

該当する場合、アプリで使用している SDK バージョンに関する問題が、Google Play Console の [製品版] ページまたは [リリースの概要] ページの上部に掲載されます。

Google Play のデベロッパー プログラム ポリシーを遵守しなくなる原因となる SDK バージョンをアプリが使用している場合、その SDK バージョンを使用するアプリの新しいリリースは承認されない可能性があります。違反の種類に応じて、SDK の使用がユーザーデータに関するポリシーを遵守しているかどうか、SDK プロバイダが推奨する別のバージョンに切り替えるか、SDK を削除するよう求められます。

古くなった SDK バージョンや重大な問題がある SDK バージョンをアプリが使用している場合は、今後の対応を求める警告が表示されます。たとえば、SDK プロバイダから Google に対し、アプリで使用されている SDK バージョンが古くなったことが通知された場合、デベロッパーは引き続きアプリをリリースできますが、古くなった SDK バージョンを使用してアプリの別のバージョンをリリースすることはできなくなります。つまり、更新された SDK バージョンを使用する必要があります。SDK プロバイダから重大な問題があると報告されている SDK バージョンをアプリが使用している場合、SDK プロバイダが詳述している問題の種類を示した警告が表示されます。

古くなった SDK バージョンや重大な問題がある SDK バージョンについてご不明な点がある場合は、SDK プロバイダにお問い合わせいただくことをおすすめします。

この情報は役に立ちましたか?
改善できる点がありましたらお聞かせください。

さらにサポートが必要な場合

問題を迅速に解決できるよう、ログインして追加のサポート オプションをご利用ください。

検索
検索をクリア
検索終了
Google アプリ
メインメニュー
ヘルプセンターを検索
true
92637
false