Harmadik féltől származó SDK-k használata az alkalmazásodban

Miután beépítetted az alkalmazásodba, a harmadik féltől származó SDK jelentősen befolyásolhatja az alkalmazás kompatibilitását, teljesítményét, biztonságát és minőségét.

A harmadik féltől származó SDK-kat érintő változások

Hogy segítsünk gondoskodni róla, hogy az alkalmazásod által használt minden harmadik féltől származó szoftver megfeleljen a Google Play Fejlesztői programszabályzatának, és kedvezően járuljon hozzá a felhasználói élményhez, a Google Play mostantól megjelöli a Play Console-ban a népszerű SDK-k ismert problémáit.

Az alkalmazásba épített függőségi fájl segítségével megtudhatod, hogy melyik SDK-t használja az alkalmazásod. A függőségi fájl kilistázza az összes, verziószámmal ellátott függvénytárat, amelytől az alkalmazás függ. Az Android App Bundle csomagot használó alkalmazások alapértelmezés szerint biztosítják a függőségi fájlt. A 2021 augusztusa előtt létrehozott alkalmazások APK-kkal való közzététele tartalmazza a függőségi fájlt az Androidos Gradle beépülő modul 4.0 verziójától kezdve.

Az alkalmazás harmadik féltől származó SDK-ival kapcsolatos problémák megértése

Adott esetben az alkalmazás által használt SDK-verziókkal kapcsolatos problémák részletei a Play Console-ban, az Éles verzió oldal tetején vagy a Kiadás áttekintése oldalon találhatók.

Ha az alkalmazásod olyan SDK-verziót használ, amely miatt előfordulhat, hogy az alkalmazásod nem felel meg a Google Play Fejlesztői programszabályzatának, akkor elutasíthatjuk az adott SDK-verziót használó új alkalmazáskiadásokat. A szabályzat megsértésének jellegétől függően arra kérünk, hogy biztosítsd a felhasználói adatokra vonatkozó irányelveinknek megfelelő SDK-használatot, válts az SDK szolgáltatója által javasolt másik verzióra, vagy távolítsd el az SDK-t.

Ha az alkalmazásod olyan SDK-verziót használ, amely akár elavult, akár kritikus problémákkal rendelkezik, figyelmeztetést kapsz, amely további lépéseket tehet szükségessé. Például ha valamelyik SDK-szolgáltató arról tájékoztat bennünket, hogy az alkalmazásod által használt SDK-verzió elavult, akkor továbbra is kiadhatod az alkalmazásod. Nem fogod tudni azonban az SDK elavult verziójával kiadni az alkalmazásod újabb verzióját; a frissített SDK-verziót kell használnod. Ha az alkalmazásod olyan SDK-verziót használ, amelynek az SDK szolgáltatójának jelentése szerint kritikus problémái vannak, akkor a probléma típusát az SDK-szolgáltató által részletezett módon ismertető figyelmeztetés jelenik meg.

Ha kérdésed merülne fel valamely – akár elavult, akár kritikus problémákkal rendelkező – SDK-verzióval kapcsolatban, javasoljuk, hogy vedd fel a kapcsolatot az SDK szolgáltatójával.

Hasznosnak találta?
Hogyan fejleszthetnénk?

További segítségre van szüksége?

Jelentkezzen be a további támogatási lehetőségek igénybevételéhez, hogy gyorsabban megoldhassa a problémát

Keresés
Keresés törlése
A keresés bezárása
Google-alkalmazások
Főmenü
Keresés a Súgóoldalakon
true
92637
false
false