Upotreba SDK-ova trećih strana u vašoj aplikaciji

Nakon što se ugrade u vašu aplikaciju, SDK-ovi trećih strana mogu imati značajan utjecaj na njezinu kompatibilnost, izvedbu, sigurnost, zaštićenost i kvalitetu.

Promjene u vezi s SDK-ovima trećih strana

Kako biste lakše provjerili je li softver treće strane koji vaša aplikacija upotrebljava usklađen s programskim pravilima za razvojne programere Google Playa te doprinosi li pozitivnom korisničkom doživljaju, Google Play počet će upozoravati na poznate poteškoće u vezi s popularnim SDK-ovima na Play konzoli.

Da bismo saznali koji SDK koristi vaša aplikacija, upotrebljavamo datoteku zavisnosti uključenu u vašu aplikaciju. U toj datoteci navode se sve verzionirane biblioteke na koje se aplikacija oslanja. Aplikacije koje upotrebljavaju Android App Bundle pružaju datoteku zavisnosti prema zadanim postavkama. Aplikacije izrađene prije kolovoza 2021. za objavljivanje s APK-ovima uključuju datoteku zavisnosti počevši od Android dodatka za Gradle 4.0.

Objašnjenje poteškoća sa SDK-om treće strane za vašu aplikaciju

Ako se pojave, poteškoće s verzijama SDK-a koje upotrebljava vaša aplikacija detaljno se opisuju na Play konzoli pri vrhu stranice Produkcija ili na stranici Pregled izdanja.

Ako vaša aplikacija upotrebljava verziju SDK-a koja može uzrokovati njezinu neusklađenost s programskim pravilima za razvojne programere Google Playa, nova izdanja aplikacije koja koriste tu verziju SDK-a možda će se odbiti. Ovisno o vrsti kršenja savjetovat ćemo vam da uskladite upotrebu SDK-a s našim pravilima o korisničkim podacima, prijeđite na verziju SDK-a koju preporučuje njegov davatelj ili uklonite SDK.

Ako vaša aplikacija upotrebljava verziju SDK-a koja je zastarjela ili ima kritične poteškoće, primit ćete upozorenje nakon kojeg ćete možda morati nešto poduzeti. Na primjer, ako nas je davatelj SDK-a obavijestio da je verzija SDK-a koju upotrebljava vaša aplikacija zastarjela, i dalje možete objaviti aplikaciju, no nećete moći objaviti drugu verziju aplikacije koristeći se zastarjelom verzijom SDK-a. Trebat ćete upotrijebiti ažuriranu verziju SDK-a. Ako vaša aplikacija upotrebljava verziju SDK-a za koju je davatelj SDK-a prijavio da ima kritične poteškoće, dobit ćete upozorenje u kojem se opisuje vrsta poteškoće kao što je naveo davatelj SDK-a.

Ako imate pitanja o verziji SDK-a koja je zastarjela ili ima kritične poteškoće, preporučujemo da se obratite davatelju SDK-a.

Je li to bilo korisno?
Kako to možemo poboljšati?

Trebate li dodatnu pomoć?

Prijavite se da bi vam bile dostupne dodatne opcije podrške kako biste brzo riješili problem

Pretraživanje
Izbriši pretraživanje
Zatvaranje pretraživanja
Googleove aplikacije
Glavni izbornik
Pretraži Centar za pomoć
true
92637
false