अपने ऐप्लिकेशन में तीसरे पक्ष के SDK टूल इस्तेमाल करना

तीसरे पक्ष के SDK टूल इस्तेमाल करने पर, उनका असर आपके ऐप्लिकेशन की परफ़ॉर्मेंस, सुरक्षा, क्वालिटी, और डिवाइस या सॉफ़्टवेयर के साथ काम करने की क्षमता पर पड़ सकता है.

तीसरे पक्ष के SDK टूल से जुड़े बदलाव

आपके ऐप्लिकेशन में तीसरे पक्ष के जिस सॉफ़्टवेयर का इस्तेमाल किया जा रहा है वह Google Play की डेवलपर कार्यक्रम की नीतियों का पालन करता हो या फिर आपके उपयोगकर्ता अनुभव को बेहतर बनाता हो, यह पक्का करने के लिए Google Play, लोकप्रिय SDK टूल की जानी-पहचानी समस्याओं को Play Console में फ़्लैग करेगा.

आपका ऐप्लिकेशन किस SDK टूल का इस्तेमाल कर रहा है, यह पता करने के लिए हम आपके ऐप्लिकेशन में शामिल डिपेंडेंसी फ़ाइल का इस्तेमाल करते हैं. डिपेंडेंसी फ़ाइल में उन सभी वर्शन की लाइब्रेरी शामिल होती हैं जिन पर ऐप्लिकेशन निर्भर करता है. Android ऐप्लिकेशन बंडल का इस्तेमाल करने वाले ऐप्लिकेशन में डिपेंडेंसी फ़ाइल डिफ़ॉल्ट रूप से मौजूद होती है. अगस्त 2021 से पहले बनाए गए ऐसे ऐप्लिकेशन जिन्हें APKs के साथ प्रकाशित किया जाएगा उनमें डिपेंडेंसी फ़ाइल, Android Gradle प्लग इन 4.0 से शुरू होती है.

अपने ऐप्लिकेशन में इस्तेमाल हुए तीसरे पक्ष के SDK टूल से जुड़ी समस्याएं समझना

अगर लागू हो, तो आपके ऐप्लिकेशन के लिए इस्तेमाल किए गए SDK टूल के वर्शन से जुड़ी समस्याओं का ब्यौरा, Play Console में प्रोडक्शन पेज पर या रिलीज़ की खास जानकारी वाले पेज पर सबसे ऊपर दिखेगा.

अगर आपका ऐप्लिकेशन, SDK टूल के ऐसे वर्शन का इस्तेमाल कर रहा है जिसकी वजह से आपका ऐप्लिकेशन Google Play की डेवलपर कार्यक्रम की नीतियों का पालन नहीं कर पा रहा है, तो उस SDK वर्शन का इस्तेमाल करने वाले ऐप्लिकेशन की नई रिलीज़ को अस्वीकार किया जा सकता है. उल्लंघन किस तरह का है, इसके हिसाब से आपको यह पक्का करने के लिए कहा जाएगा कि आपका SDK टूल उपयोगकर्ता का डेटा इस्तेमाल करने की हमारी नीतियों का पालन करता है या नहीं. SDK टूल की सेवा देने वाली कंपनी ने मौजूदा वर्शन के बजाय जिस वर्शन का इस्तेमाल करने का सुझाव दिया है उसका इस्तेमाल करें या मौजूदा SDK टूल हटा दें.

अगर आपका ऐप्लिकेशन, SDK टूल के किसी ऐसे वर्शन का इस्तेमाल कर रहा है जो पुराना हो चुका है या उसमें गंभीर समस्याएं हैं, तो आपको चेतावनी मिलेगी. इसके बाद, आपको आगे की कार्रवाई करनी पड़ सकती है. उदाहरण के लिए, अगर SDK टूल की सेवा देने वाली कंपनी हमें यह जानकारी देती है कि आपका ऐप्लिकेशन SDK टूल के जिस वर्शन का इस्तेमाल कर रहा है वह पुराना हो चुका है, तब भी आप अपना ऐप्लिकेशन रिलीज़ कर पाएंगे. हालांकि, आप SDK टूल के पुराने हो चुके वर्शन का इस्तेमाल करके, अपने ऐप्लिकेशन का नया वर्शन लॉन्च नहीं कर पाएंगे. इसके लिए, आपको SDK टूल के अपडेट किए हुए वर्शन का इस्तेमाल करना होगा. अगर आपका ऐप्लिकेशन, SDK टूल के किसी ऐसे वर्शन का इस्तेमाल कर रहा है जिसके बारे में SDK टूल की सेवा देने वाली कंपनी ने गंभीर समस्याओं की शिकायत की है, तो आपको कंपनी की दी हुई जानकारी के मुताबिक चेतावनी दिखेगी. इस चेतावनी में, उन समस्याओं की जानकारी शामिल होगी.

अगर आप SDK टूल के पुराने हो चुके या गंभीर समस्याओं वाले वर्शन के बारे में कुछ पूछना चाहते हैं, तो हम आपको SDK टूल की सेवा देने वाली कंपनी से संपर्क करने का सुझाव देते हैं.

क्या यह उपयोगी था?
हम उसे किस तरह बेहतर बना सकते हैं?

और मदद चाहिए?

मदद के दूसरे तरीकों के लिए साइन इन करें ताकि आपकी समस्या झटपट सुलझ सके

true
खोजें
खोज साफ़ करें
खोज बंद करें
Google ऐप
मुख्य मेन्यू
खोज मदद केंद्र
true
92637
false