Brug af tredjeparts-SDK'er i din app

Når tredjeparts-SDK'erne er indbygget i din app, kan de have en betydelig indvirkning på appens kompatibilitet, effektivitet, sikkerhed, beskyttelse og kvalitet.

Ændringer i forbindelse med tredjeparts-SDK'er

For at hjælpe dig med at sikre, at tredjepartssoftware, som din app anvender, overholder Google Plays programpolitikker for udviklere og bidrager til en positiv brugeroplevelse, begynder Google Play at rapportere kendte problemer med populære SDK'er i Play Console.

Vi bruger den afhængighedsfil, der er inkluderet i din app, til at finde ud af, hvilken SDK din app bruger. Afhængighedsfilen angiver alle de versionerede samlinger, som appen er afhængig af. Apps, der anvender Android App Bundle, angiver som standard afhængighedsfilen. Apps, der er oprettet før august 2021 og anvender APK-filer, inkluderer den afhængighedsfil, der stammer fra version 4.0 af Android Gradle-pluginnet.

Forstå problemer med din apps tredjeparts-SDK

Du kan se eventuelle problemer med SDK-versioner, der anvendes af din app, øverst på siden Produktion i Play Console eller på siden Oversigt over udgivelse.

Hvis din app anvender en SDK-version, der kan være skyld i, at din app ikke overholder Google Plays programpolitikker for udviklere, kan nye appudgivelser, der bruger denne SDK-version, blive afvist. Afhængigt af overtrædelsestypen vil du blive bedt om at sikre, at din SDK-brug overholder vores politikker for brugerdata, om at skifte til en anden version, som SDK-udbyderen anbefaler, eller om at fjerne SDK'en.

Hvis din app anvender en SDK-version, som enten er forældet eller har kritiske problemer, får du en advarsel, der muligvis kræver yderligere handling. Hvis en SDK-udbyder f.eks. har informeret os om, at den SDK-version, din app anvender, er forældet, kan du stadig udgive din app. Du kan dog ikke udgive en anden version af din app ved hjælp af en forældet version af SDK'en. Du skal i stedet bruge den opdaterede SDK-version. Hvis din app anvender en SDK-version, som SDK-udbyderen har rapporteret kritiske problemer for, vil du se en advarsel, der beskriver problemtypen, fra SDK-udbyderen.

Hvis du har spørgsmål om en SDK-version, der er forældet eller har alvorlige problemer, anbefaler vi, at du kontakter SDK-udbyderen.

Var disse oplysninger nyttige?
Hvordan kan vi forbedre siden?

Har du brug for mere hjælp?

Log ind for at se yderligere supportmuligheder, så du hurtigt kan løse problemet

Søgning
Ryd søgning
Luk søgning
Google-apps
Hovedmenu
Søg i Hjælp
true
92637
false
false