We've moved! Check out our community and ask a question at googlenestcommunity.com

/googlenest/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
replacement heat link
1
I need a replacement Heat Link, as the current one has broken in less than a year (never had this problem with the previous Hive set-up). Tried to contact through chat in the UK but got bounced out of system. Really poor service, Can anyone help before I go to Twitter? Do I get a replacement or do I need to buy one. On looking through threads, other are experiencing the same problem. Is there a design fault?
Details
Pinned
Locked
Latest Update Latest Updates (0)
Relevant Answer Relevant Answers (1)
Relevant Answer
Hi - same issue. 3rd gen heat link is dead. If someone can confirm next steps to replace, that would be appreciated.
marked this as an answer
3
All Replies (429)
Relevant Answer
 
 
We are sorry to hear about your Nest Thermostat. Let's see what's going on with your Heat Link.
 
First of all, can you confirm if the Heat Link has no LED? If this the case, we can try a few things: 
 
  • Turn on Manual Mode to verify boiler activation by pressing its button once. Does anything happen?
  • In some cases the boiler will have an additional isolation switch which can turn off the power to both the Heat Link and the boiler. Can you try switching that off/on again to see if anything changes?
  • Check that the breaker switches are set to on.
After having carried out the troubleshooting steps, I will reach you out through email on the address associated with your forum profile so I can further assist you.
 
Let me know how it goes.
 
Best,
Karina
marked this as an answer
Relevant Answer
@Karina - I have exactly the same issue. I have followed all suggestions and even got a professional to check and there is power to the heat link, it is clearly a fault with the unit itself. 

Can you arrange a replacement, please?
Thanks.
marked this as an answer
Relevant Answer
 
Thanks for reaching out. Can you send a photo with the Heat Link showing it has no LED on it? Also, did the professional provide you with a diagnostic report by any chance with the tests he had done on the Heat Link?
 
@Philip Coen have you tried the suggested steps above? 
 
Let me know, and I will reach out to you through email on the address associated with your forum profile.

I hope to hear from you very soon.
 
 
Regards, 
Karina
 
 
marked this as an answer
Relevant Answer
Hi I am having difficulty with getting my Nest 3rd gen thermostat to connect to my Heat Link. My original thermostat became faulty and would not connect to the Wifi, but would still connect to the Heatlink. I had a replacement thermostat sent as the unit was still under warranty and it came with a new Heat Link as well. I have installed the new Heat Link and had it checked by a Nest Pro installer, but now I cannot get the thermostat to connect to the new Heat Link and I am unable to contact phone or chat support as they appear to be closed at the moment. I am very frustrated with the apparent unreliability of the equipment and the extreme difficulty in obtaining support. Please advise me what to do next.
marked this as an answer
Relevant Answer
 
 
Thank you for dropping by here at the Google Nest community forum. I appreciate your time on bringing this to our attention. There is a thread which has similar concern as what you're experiencing. Please refer to this thread moving forward for more troubleshooting.
 
Let me know how it goes.
 
Best,
Karina
marked this as an answer
Relevant Answer
Hi Karina, I am having the same problem with the Heat Link, on Friday (30Oct20) it stop working. I had it check by an electrician on Saturday and they advised the unit was faulty. Can you contact me by email so I can send you a picture of the unit. Many thanks in advanced

Edit: To confirm my Nest is 11 months old
marked this as an answer
Relevant Answer
I have the exact same issue and dont seem to be able to get a response from anyone. The google support website is useless and just sends me round in circles. I am an electrician and have verified 230v supply to the heatlink, so it is clearly broken. 
It is only 10 months old, can a replacement be arranged?

Thanks
marked this as an answer
Relevant Answer
Hi everyone, 


Thank you for your response. I've reached out to you through email on the address associated with your forum profile.

I hope to hear from you very soon.
 
 
Best,
Karina
marked this as an answer
Relevant Answer
Hi Karina,

I am having the same issue with a heat link.  The unit is receiving power, as I've tested the wires going into the heat link, but no LED light at all is showing on the Heat Link unit.

2 x thermostats purchased 17th Feb 2020 and installed on 29th February by a Nest Pro installer. 

Your help would be greatly appreciated in order to arrange a replacement unit.

Thanks 

Lee
marked this as an answer
Relevant Answer
Hello. I also have this fault with my heat link. Boiler is working fine but the white box has no light and doesn’t respond to any reset instructions. I had a qualified plumber look at it today and he confirmed that the white box is dead. The dial has the same error message instructions as the others on this thread. I’ve had no problems until now and it looks like a fault with manufacture given so many others are having the same problem. I’d appreciate if you can let me know how I can get a replacement part so we can get our heating going again. Thank you 
marked this as an answer
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
Report post
What type of post are you reporting?
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/googlenest/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Removed from Updates
Marked as Recommended Answer
Marked as Update
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
Known Issue
Fixed
Marked Fixed
Unmarked Fixed
Unable to mark fixed
Unable to unmark fixed
/profile/0
false
Search
Clear search
Close search
Google apps
Main menu
Search Help Center
true
1633396
false