This content is likely not relevant anymore. Try searching or browse recent questions.
Device setting keeps showing: "Some settings are unavailable right now" 0 Recommended Answers 35 Replies 52 Upvotes
1 Recommended Answer
$0 Recommended Answers
Last edited 4/21/19
I've reset both devices several times, disconnect and reconnect the Wifi, nothing seems to be working. Anybody can help?
All Replies (35)
Are you connected to the same wifi? 
marked this as an answer
Yes they are connected in the same wifi.
marked this as an answer
I've been having this exact same problem,I invited a family member and when he tries to use the chromecast it prompts "Not available" when selecting the device in the room. When going into settings it's the same issue.
marked this as an answer
I am having be the same issue with my Google Home. It's saying not available. But I am on the same Wi-Fi.
marked this as an answer
Same here... Is this a chromecast screwing up or the home app no longer working properly?
marked this as an answer
Same problem here
marked this as an answer
On mi accont
marked this as an answer
Yep my Chromecast one has the same issue.
marked this as an answer
Me 2 same thing and both on same wifi factory rest 2 times no luck
marked this as an answer
If you have a wireless router that creates two networks with the same SSID (name) but different frequencies (eg. 2.4GHZ and 5GHZ), Home devices seem to have problems here, even they’re on the same logical network. 

My phone and at least one Google home (due to distance, stronger signal, etc) would connect to my 2.4, while others would connect to the 5 because they were closer. They would however show as “limited” in the home app.

I solved the problem by disabling the 2.4 and now all devices connect to the same radio and appear in app. Another solution would be to name the frequencies differently (eg. Wifi 2.4 and Wifi 5) then explicitly set your home devices to one specific access point. They should all appear in app, provided you me phone connects to the same access point as well. 

If you have something like a mesh network or range extender however, I’m not sure this will provide a solution as the radios will still be different. Hope you find this useful. Cheers
marked this as an answer
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Unable to lock
Unable to unlock
Unable to pin
Unable to unpin
Unable to mark
Reported as off topic