/googlenest/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
3/3/19
"Google Home can't communicate with Android tv." 0 Recommended Answers 186 Replies 355 Upvotes
1 Recommended Answer
$0 Recommended Answers
Last edited 4/1/19
I purchased a Sony XBR-55X800E (Android tv) because of its advertised ability to be controlled by Google Home.  Using the Google Home app I was able to find the device and add it to a room.  I can see the device in Google Home, but under its settings the only thing I can do is control the device's volume.  I am unable to rename the device, group the device's speakers, see photos in Ambient Mode or use voice commands to control the device.  Any attempts to perform those functions results in the infamous " ... can't communicate with the Android tv" message.

Is there a simple work around to access these features?

While I can use the mic to access the Google Assistant on the device I do not have off/on functions by voice using Google Home.  I understand this is because it has built in Chromecast (really???).

Any help is appreciated.
All Replies (186)
3/4/19
Even I'm facing the same issue with my Sony Android TV. On Google Hub , I cant even see control settings to manage ON/OFF and Volume UP/DOWN as well.
Last edited 3/24/19
marked this as an answer
Helpful?
3/23/19
I'm having the same issue with my Sony thought I may be doing something wrong
Last edited 7/25/19
marked this as an answer
Helpful?
3/24/19
Me also!  Was able to to control TV with voice commands before update!
marked this as an answer
Helpful?
3/26/19
I also have a Sony Android TV and I'm having the same issue. I used to be able to voice command anything to play on my tv as long as my account was linked to Google Home . Now all I get is the error message. I've had this issue for about a month now. Seems to be update related.
marked this as an answer
Helpful?
3/27/19
Agree with Nate. around the update of my android tv stopped working a month ago.  I can only control the volume now....   if i look at the cast version and google this i did read some about problems with this version in the real chromecast device... but there is no update of the cast version in the app store of my tv...
Last edited 3/27/19
marked this as an answer
Helpful?
3/28/19
Seems like something changed because a week ago I was able to voice command to turn on or off, play music, now it keeps answering "something went wrong please try again later". I tried uninstalling updates of chromescast, reinstalling it, removing the device from GHome, rebooting. Even using the voice command from within the tv using the remote I get the same answer when asking to play music. Hopefully a fix to this will come.soon
marked this as an answer
Helpful?
3/28/19
Same since one month with Android TV on Philips Ambilight. I m gonna be crazy. Nothing works now.
Last edited 4/13/19
marked this as an answer
Helpful?
3/28/19
jai une smartTV Philips de 2018 avec android TV (dernière MàJ) :
une google home mini.
Ca faisait un an Que tout fonctionne à merveille :
ok google mets "nom de la série" sur Netflix sur la tv
ok google mets "nom de la musique" sur Spotify sur la tv 
Ok google mets vidéo de (...) sur YouTube 
depuis 3 mois, avec la MaJ dandroid TV 
impossible de lancer Netflix par commande vocal.
 
Et la sans aucune MaJ depuis une semaine plus Rien ne peut se lancer depuis Google Home mini / application gooogle Home
La seule chose qui fonctionne avec la commande vocal ou application Google Home Cest l'ouverture / fermeture de la TV....
 
Jai passe mon samedi : à tout reset tout réinstaller 
TV / Android TV / google Home l'application & enceinte / les différentes comptes liés.
 
Toujours le même problème : " ok je mets Spotify sur la tv.... une erreur s'est produite, veuillez réessayer plus tard"
marked this as an answer
Helpful?
3/28/19
Le plus agaçant dans cette histoire, c'est qu'il y a 6 mois tout était fonctionnel.
Je mets à jour mon post au passage :
 
Désormais, la TV ne peut ni s'allumer ni s'éteindre non plus par Google Home mini / application Google Home (Dernière chose qui fonctionnait)
 
Donc plus aucune commande de Google Home mini / Application Google Home vers Android TV. 
 
Je suis fâché.
marked this as an answer
Helpful?
9/14/19
Just to add another perspective Google seemed to have changed something because on/off controls using google home devices now seem to work without me doing DH's solution.
marked this as an answer
Helpful?
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/googlenest/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/googlenest/profile/0?hl=en-IN