/googlenest/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
This post is a trending issue.
-
I have to ask google twice to play music every time 1 Recommended Answer 256 Replies 525 Upvotes
1 Recommended Answer
$0 Recommended Answers
1 Relevant Answer
$0 Relevant Answers
When I ask my google home hub to play music it says ok, but I have to ask again for it to actually play
Most Relevant Answer Most Relevant Answers (0)
All Replies (256)
Most Relevant Answer
Alright, Google, what's the answer? As of right now 66 people say they have this problem.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I get the issue when trying to play radio from tunein.  It acknowledges I've asked but doesn't play.  Normally second time it works, though had to ask 3 times today.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Google? Hello? This is obviously an issue
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I have the same issue. It says it’s play what I asked for on pandora but it doesn’t the first time. Normally it will do it the second time. Sometimes it takes a third try before the music will play.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
We have the exact same issue
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Piling on, exact same issue (Pandora for me).
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Hello, thanks for taking the time to post your issue.
 
Try each of the following before moving on to the next:
  • Are you using the Google Home app  
  • Are your Apple or Android devices on current Minimum system requirement?
  • If iOS, turn on Bluetooth:
    1. On the home screen, tap Settings > Bluetooth.
    2. Make sure the slider is On (toggled to the right and green).
    3. Close out of Settings and return to the Google Home app .
  • Reboot your router
  • If you have a dual-band router, make sure it is on the 2.4 GHz band for better coverage.
  • Make sure you power the Home device with the provided power supply into an open electrical outlet, not using a USB input on your TV or other device.
  • Try placing your Google Home device about 20 feet away from your router, or less.
  • Unplug your Router and Google Home device from electrical wall outlets for 5 minutes
  • See original post by David King about other settings
marked this as an answer
Most relevant based on info available
Most Relevant Answer
None of those suggestions has resolved my issue. Would it be possible to get a regular conversation going on this? It looks like a lot of people are having the same issue.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I was on with Customer Support today. They are aware of an issue with their radio station provider, and are working on it. When it happens (no audible radio after Google acknowledges and says it's streaming, but getting nothing but silence, or "...try again later")  say "Hey Google, Send Feedback" When Google says "sure..", say "GHT3, Something went wrong error."    The more feedback reports they get, the better, and the quicker it will get fixed.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I have the same issue.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same issue but with netflix
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I've been looking at so many websites hoping for an answer because I am having this issue on all my Google devices : (  I bought a google hub Lenovo for 4 rooms, 2 google home minis and a google hub and they all have this issue! they also lose connection when you play music on all devices. only one plays while all the others intermittently play then stop. hopefully we can get an answer or a fix sometime soon.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same issue with Pandora... have to ask twice, like a disobedient employee...
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same issue with deezer
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I also have the same issue on my Home Hub. My mini works great. Google help!!
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same issue here, it's not a gigantic problem, just a slight annoyance when I'm already feeling silly talking out loud to a device
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Agreed! Please fix
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I've had this exact issue for a long time now.  Very frustrating!
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I have the SAME issue. I say “ok google play some relaxing music” and it will say “ok here’s a sTATION for relaxing Music” and .... NOTHING. Then I ask google what is it playing? And it will say it is not playing anything and then I have to redo the whole thing again!
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same, but not a hub, Pandora, Netflix or anything, just regular use of search engine on my android phone.  EVERY TIME I use Google, I type it in, nothing happens, I close it out and do it the same again, and viola...results.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same bug since some weeks.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same issue as everyone else.  It's embarrassing that Google would put out a product that blatantly doesn't work.  I've had the Home since December and the issue has been going on at least that long.  

I see easy advertising potential here for Amazon.  A compilation of Google Home customers yelling at the machines that don't listen followed by Alexa doing what is asked first try.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I'm having the same problem. It doesn't play my radio even after multiple requests. Even though it says it will..
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I've had the problem for several months.  Nothing to do with home systems, just my Pixel XL, original version.  I'm not even asking for music to be played.  I can't seem to ask a longer question, or give a long command on the first try.  It seems to time out fast.  When I ask again I seem to have more time with questions or lengthy commands.  Sometimes short commands ("turn on Bluetooth") will work the first time, but it's temperamental and may take two shots as well.  Running the latest OS but maybe a recent update "broke" it
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Another for deezer. Just asking to play a radio station though works the majority of the time (eg bbc)...come on Google get that big data brain working .
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Still no fix for this??
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I am having the same issue. Have to ask it twice for it to work.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Hi google, are you going to fix this? Are you going to support this product we all paid for? Or are you going to abandon it like half of your other projects?
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same issue for several months now. I use Google play music. You think that would work with Google assistant without a hitch. Embarrassing...
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same here...  I hate having to repeat myself.   For a smart device, it sure can be stupid.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I have this same issue. Any update?
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I have this problem too. Has anyone figured it out?
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I’m having this exact issue with any command at all, it simply ignores me the first time even thought it reacts to my voice
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I am having the same problem.  I ask Google assistant to play music and it says "ok playing music on Pandora" but then it doesn't load Pandora and doesn't play any music.  I ALWAYS have to ask again to play music, and then it does.

Google,

Can you PLEASE FIX this?  I'm seriously tired of having to ask twice!
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Exact same problem. Would be nice to get an actual Google rep to acknowledge this
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I too am required to ask my Hub multiple times to play music. Clearly from the number of respondents this is an issue that is not being resolved by the basic troubleshooting steps offered by Google. I’m frustrated by the lack of acknowledgement from Google that this is an issue worth fixing.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same issue for me. Every single time I ask my Google mini to play music on my home group via pandora I have to ask it twice. This has been happening for quite a while now.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I have to ask him to play a song on pandora like 5 times he will say ok but still not play it. It sits close to router
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same problem for me....very frustrating.  I mostly use my devices to play music throughout the house.  Hopefully Google comes up with a solution soon.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Me too.  I have just laugh each time...hoping it gets fixed soon
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same issue with Pandora and Spotify on Google home hub and JBL link view. Ask once, it acknowledges and says it's playing but nothing. Ask a second time, it acknowledges and plays. Happens almost, if not, always.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same issue. Since we bought the device in December. Pretty lame.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I've got the same issue. This for sure is a google issue. I've had my hub for some time and have been waiting for a fix.

If it doesnt gets an update to fix it by Prime Day, I'll be replacing all but one of my google devices with Amazon.  I've been patient long enough. I spend enough time repeating myself to my fiancee'. Do I really have to keep doing this to google to play music?  Ugh.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Ed M 2797, that's pretty funny. 
I'm having the same problem (with my Google Home mini, not my fiancé), only it's when I try to play music on the Home Mini via the Google Home app on my phone. It used to work the first time, every time, in every room on every mini, now it takes 3 taps - with a considerable amount of optimistic waiting in between - before it says 'playing music.'
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same issue here with Pandora on one Home Hub specifically.  Ironically enough it doesn't seem to happen at all or at least as often on my Home Hubs, Minis and one of our Home Hubs.  Its fairly annoying.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I am like 
Please
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Piling on! I am having the same problem - Pandora!
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same issue. It’s utterly irresponsible of Google to not even ack this. I mean, they clearly have seen this thread by now, so how come not even the usual “we’re working on it” BS?
marked this as an answer
Most relevant based on info available
Most Relevant Answer
We have the same issue when asking something to play on Pandora. Happens on both our google home minis and our google home hub.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same issue
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same issue using Pandora!
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same issue with Pandora.  I have to ask twice to get it to play.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same issue for me. Have to ask it twice to get pandora to play
marked this as an answer
Most relevant based on info available
Most Relevant Answer
EXACT SAME ISSUE on GOOGLE HUB..bought at Christmas 2018...FRUSTRATING!  hey google...................
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same issue on all three of my Google Hubs. Using Pandora. Please correct.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
My home google has gotten worse and worse. It will agree to play a apecific song or artist and then go silent or continue what was playing.  I have rebooted ans reinstalled the app amd all the suggested things. It's solbed nothing
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I am having to regularly ask it twice, even though it responds as if it is complying the first time, exactly the same as when it actually plays it, after second request. Frustrating!
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I have the same problems like everyone else! I even reset my device and still having the same issue! I thought my google home hub was defective. Google need this fix asap. I spend money on your products. I would like to return it all if I could.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Okay, Google.

Every thing was working fine. Google Home and Google Home Hub playing Spotify without any issue with Voice Commands and by selecting the Speakers from the Spotify App. No lag, no issues, fine. But then out of the blue everything stops working. I send the Voice Command to Play Spotify and then just loads the Spotify UI on my Google Home Hub and nothing happens. Sometimes after a couple minutes it plays a song, but then when I select a different one. Same thing again, stuck. When I select the Speaker from the Spotify App, same issue.

Already did:
  • Restart my Router.
  • Connect both devices to another WiFi Network (Phone and Google Home x2).
  • Reset to Default the Google Home and Google Home Hub.
  • Re Add the Devices to my Google Account using the Home App.
  • Adding them to a different Home on my Home App and Google Account.
  • Uninstall and then Re-Install the Spotify App on my Phone.
  • Selecting the Google Home or Google Home Hub from my Spotify Web Player and the Spotify Desktop Player. Same issue.
Everything else works fine. 
  • Voice Commands for my Smart Devices are working fine.
  • I can stream Audio from YouTube to my Google Home Devices.
  • I can stream YouTube on my Google Home Hub.
  • Even installed YouTube Music on my Phone to see if it works. It does. Google Home Hub can stream YouTube Music without no issue.
So at this moment I am suspecting that this is being done on purpose to get people to switch to your YouTube Music Paid Services and dropping their other Paid Music Services.

I would really like for this to be fixed as soon as possible since I bought almost 3 more Google Homes for my house to had a very good surround speaker system in my house using the Groups features on the Home App. But this is a very big letdown since this has been going on for about 3 days already and I don't see  any official statement acknowledging that you guys have an issue with this.

Regards.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same exact issue and super annoying when it is the middle of the night and you are quietly trying to play more music but you have to ask two or three times.  This was not the case 6 months ago but it progressively getting worse and you have over 100 replies on here with only one Google rep response and it was a HORRIBLE response at that. Like all of these folks have not done all of that if not several times and it is not just this website, it is listed all over Google searches with no answers anywhere.  Extremely rude not even to give us an response when several have followed your recommendations and still this does not work.  Where is this amazing Google customer support you are supposed to be known for?  Hopefully this isn't all you have.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same issue. Ask for a radio on TuneIn, Google Home Mini says it's ok but nothing happen... have to ask a second time.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same issue. Didn’t happen when we first purchased. Hopefully google will fix the issue and push an update soon.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Hi all, 
 
Sorry for the delay in response here. I know this has been a rather frustrating issue for many of you where your Google Home is not playing the media you want, when you want.
 
The team is currently investigating this issue and it would be helpful for their investigation if you could send feedback using the keywords, "Asking Google Home twice to play media". For additional instructions on how to send feedback using your Google Home, feel free to check this out.
 
I'll update this thread once I have an update and thank you for your patience as we look into this issue. 
 
Thanks, 
Rachel
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Any idea when this will be resolved? I've been waiting for MONTHS!
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Feedback sent!
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Thank you Rachel. I look forward to the teams answer.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I have sent feedback but find it amazing that this post has been around for months and is still not fixed.  Last time I called support I had to delete my entire Home and reset it up (I have ten or more devices, not an easy process) to try and get Google Home to set a repeating radio alarm from a Pandora station.  It worked once - I have gone back to using routines for radio alarms because an every day alarm that only goes off once and never again isn't exactly useful!) . Come on Google, how can you put out devices that are so buggy...?
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I ask my Google home devices twice or more to play Pandora before they actually do it.
"Hey Google play Greg's Favorite station on Pandora." -- asking Pandora to play some music....... And then nothing! Then I ask again... And again...
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same here! Is there a fix?!