/googlenest/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
8/10/19
Unable to turn on alarm via nest app. Reports message “can’t set the alarm. I 0 Recommended Answers 14 Replies 0 Upvotes
1 Recommended Answer
$0 Recommended Answers
Unable to set nest alarm. Repeated message “it’s taking a while to connect to Nest Guard. Try again. 
All Replies (14)
8/13/19
Hi Andrew,

Thanks for reaching — let's check on this further.

There are several things that can keep Nest Secure from fully arming or block arming altogether. If you have any of the issues below, Guard’s Info button will turn red and the Nest app will tell you what’s happening.

Things that will block arming:
1. Very low battery on Guard
2. A software update is in progress
3. Hardware failure
4. Wireless interference

You might need to restart your Nest Guard and your router to refresh their connection and try again. Check this link for the steps.

Let us know how it goes.

Thanks,
Melba
 
marked this as an answer
Helpful?
-
8/13/19
Performed all of the above. Still inconsistent connection between app and Nest Secure. Unable to arm and disarm nest secure
marked this as an answer
Helpful?
8/14/19
Hi Andrew, 
 
Thanks for the prompt response. Can you try toggling the Wi-Fi button Off then back On on your phone then try again? If still the issue persists, try uninstalling then reinstalling the Nest app and also reboot your phone. You might also need to try another mobile device and see how it goes.
 
Keep us posted. 
 
Best, 
Melba
marked this as an answer
Helpful?
10/13/19
I’ve got the same problem and have tried the fixes listed above, but nothing has worked so far.
marked this as an answer
Helpful?
10/13/19
Hey Cody, 
 
Sorry to hear that you're experiencing the same. Is happening only on a specific mobile device or across all mobile devices that has the Nest app installed? Also, is this happening if your mobile device is both on mobile data or WiFi?
 
Best, 
Melba
marked this as an answer
Helpful?
10/16/19
I've been having this same issue.

Both on my phone and my wife's phone (both of which are Pixel 3 XL devices, fully updated) have this issue when trying to arm the Nest Secure.  Our Nest apps are up to date, as is (so far as I can tell) the Nest Secure itself.  The Nest Secure is only maybe 10 feet from my router, so it should have plenty of signal strength.  The issue occurs on both of our phones regardless of whether we're connected to LTE, 3G, or Wifi (including when we're connected to the same wifi as the Nest itself).

This is extremely frustrating.  Often, we'll leave the house and try to arm the device as we're driving out of the neighborhood, but it will consistently fail.  We'll have to sit there and retry a dozen times before it finally actually works.  We've also had issues sitting at our desk and trying to arm it from the Nest app when we're connected to the very same wifi network as the Nest Secure.

I've tried restarting both phones, reinstalling the app on both phones, and restarting the Nest Secure all to no avail.  It's at the point where I wonder if the device will actually do me any good if someone were to actually break in to the house.  The device wont arm consistently, why should I trust that it will be able to alarm consistently?
marked this as an answer
Helpful?
10/17/19
I've recently started experiencing this same issue about 3 days ago.  I haven't changed anything regarding my wifi connection or the placement of my nest guard and this issue just suddenly suddenly arose after months without any issues.

What is really interesting is that I have nest thermostats and nest cameras that I haven't experienced any issues with controlling them from the app. Also, I can still use my Nest home to set my alarm through a voice command without any issue, but I cannot set my alarm through the app inside or outside the home.

Please help with this issue as this is a nuisance. 
marked this as an answer
Helpful?
10/17/19
Hey Folks, 
 
Sorry to hear that you're experiencing the same issue.  
 
@Michael Polson, other than your Pixel 3 phones, is it also happening on other mobile devices that has the Nest app installed? Do the Nest app on your Pixel 3 phones have the same version number?
 
@Richard Mordecai, I have the same questions too. Is it only happening on your mobile device or across all mobile devices that has the Nest app? Can you also provide us the Nest app version of your mobile phone?
 
Best, 
Melba
 
marked this as an answer
Helpful?
10/17/19
I deleted my current Nest app and downloaded the version 5.40.0. However, that did not correct the issue (I believe I downloaded the same version I had before).

Then I reset my nest guard by holding down the #5 button for a few seconds. Now, my Nest app has the ability to set my alarm again. I tried it in my home last night and it worked. I also tried on my way to work this morning (not on the home wifi) and it worked again.

I hope this solution works for others!
marked this as an answer
Helpful?
10/19/19
 
Since the above step did not work for you, you might need to have your Nest Guard reset to its default settings. Resetting Nest Guard will make all of your Google Nest Detects appear as offline in the Nest app. To continue using Nest Secure you will have to go through the setup process again. Note: As a security precaution, a factory reset can’t be done if Nest Guard is armed in Home and Guarding or Away and Guarding, speaking a Heads-Up, sounding the alarm, or if the battery is critically low. Check the steps below:
  1. Remove Nest Secure from your account in the Nest app.
  2. Set Nest Secure to Off Nest Guard off with Nest Guard’s keypad, or the alarm may sound.
  3. Press and hold down the 2 button on Guard’s keypad.
  4. Keep holding down the button while Guard goes through a software version and check.
  5. When Guard says, “Release to erase all settings,” let go of the button.
  6. Guard will speak again and say, “Erasing all settings and returning to factory defaults in five seconds. Press any button to cancel.”
  7. You’ll see the light ring turn yellow and begin a five second countdown. Press any button before the countdown ends to cancel the reset.
  8. If you don’t cancel, the light ring will spin blue and Guard will say, “Erasing all settings. This might take a minute."
  9. When it’s about to restart you’ll hear, "Nest Guard is restarting. Be right back."
Let us know how it goes. 
 
Best,
Melba
 
marked this as an answer
Helpful?
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/googlenest/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/googlenest/profile/0?hl=en