Add rows to existing tables

You can add rows to an existing table in two ways:
  • Use Edit > Add Row to enter a new row one-at-a-time
  • Use File > Import more rows to bring in rows from a file

When importing more rows from a file, the new file should have the same columns in the same order as the existing table. Fusion Tables supports either the original or the current column order, and allows extra columns to be dropped during import.

During import, the dialog panel will present the columns from the existing table and the columns detected in the new file.

Dropping extra columns: By default the first columns of the new file are selected for import. For example, if the existing table has 10 columns, the first ten columns of the new file will be selected. A checkbox above the column header indicates that it is selected. The total number of columns imported in the new file cannot exceed the columns in the existing table. To change the selection, uncheck an unwanted column. Other checkboxes will become active. Check the desired column.

Changing column order: If the order of the columns in the existing table has been changed, Fusion Tables offers a checkbox to "Show columns in original import order." This will restore the order of the columns in the existing table prior to being re-ordered for the purposes of matching columns in the import process.

Adding new columns: If the file contains new columns, they should be added in classic Fusion Tables using Edit > Modify columns before importing the new rows.