/fi/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
4/30/19
WIFI CALLING ON GOOGLE FI NETWORK USING GOOGLE PIXEL 3 XL HAS NEVER WORKED Worst customer service!!! 1 Recommended Answer 15 Replies 21 Upvotes
1 Recommended Answer
$0 Recommended Answers
So I’m an extremely busy person constantly traveling to multiple countries running multiple businesses.

With new dual sim technology, I thought I’d give the google fi network using a pixel 3xl a try.
This way I only have to carry 3 phones when I travel opposed to 5 or 6.  I stay at all 5 star hotels in developed countries with great unrestricted wifi connections.
 
Sad to say the wifi calling features have never worked, ever. Not even inside the USA. Keep in mind I only use this phone to make/receive calls and occasional text messages (probably about 10 messages a month), I do nothing else with the phone, no cancerous social media apps that would cause a potential conflict, nothing.
 
Where it gets worse is the google fi customer service has no ideal what they are doing. After spending hours and hours with them sending screen shots of the phone it still doesn’t work.
What’s more remarkable is that the customer service for google fi uses iPhones!!!! Not even a pixel emulator to properly navigate me through what to do.
 
This is evident because throughout the interactions with all the customer service agents they would say things that don’t pertain to the Pixel (Android) but rather the navigation structure on iOS. I’d have to remind them I’m using a Pixel 3XL, this after they have my screenshots showing the latest Android build, I know WTF. To make matters worse, I went as far to ask what phone they are using, because of all this frustration. The customers service agent said they can’t say, WTF. You can go into any apple store and ask an employee what phone they use and they probably wouldn’t say they can’t tell you.   
 
On a side note since I have multiple phones on all various carriers. The other phones not the Pixel not on Google Fi, connect to Wi-Fi calling just fine. Also, on an iPhone you know that you are connected to calling on Wi-Fi. On a Pixel there is no way to know this, they said you should be able to know this if you enable airplane mode and enable Wi-Fi, however I’ve never been able to place a Wi-Fi call, ever. My ability to test on different phones with working results in the same room negate the carriers or countries restrictions to Wi-Fi calling.  
 
Some of the things that hours and hours of customer service has had me try are but not limited to:

Make sure that Hangouts, Google Connectivity Services, Carrier Services, and Google Play Services are enabled, fully updated, and do not have their data usage restricted.

Complete the following steps for each app.
Head to your device Settings > Apps > [Applicable App] and check to make sure the app is enabled (The App info should show a "Disable" button when the app is enabled.) Tap Data Usage. The wording will differ depending on the OS.
  • If you see "Background data", the switch should be ON.
  • If you see "Unrestricted data usage", the switch should be ON.
  • If you see "Restrict background data", the switch should be OFF.​
Tap the back arrow to return to the App info > select Permissions. (Phone, SMS and Location permissions should be ON.
Make sure it is enabled in the "Phone" app.
Configure IMS calling >> Wifi calling ON
 
Reboot phone
Hold power button >> restart
 
Check for system updates.
All is updated
 
Check for app updates for "Phone", "Carrier Services", and "Google FI".
 
Check Permissions for "Google Fi", "Phone", and "Carrier Services".
Settings >> Apps & Permissions >> Phone >> Permissions >> All is checked besides "Storage"
Settings >> Apps & Permissions >> Carrier Services >> All is checked besides "Storage"
Settings >> Apps & Permissions >> Google Fi >> All is checked
 
Clear app data & cache on "Phone", and "Carrier Services"
Settings >> Apps & Permissions >> Phone >> Storage >> "Clear cache" & "Clear Storage"
Settings >> Apps & Permissions >> Carrier Services >> Storage >> "Clear cache" & "Clear Storage"
 
Force Wifi Call via airplane made.
"Turn off airplane mode to make a call"
Attempt to make call. Cannot make call.
Retry in safe mode. Cannot make call

THIS IS NOT EVEN THE COMPLETE LIST!!!! And it still doesn’t work. But, lord have mercy on your soul if in 2019 you have to do this every time you attempted to make a Wi-Fi call.

Here’s how you do it in iOS (iphone), make sure it’s enabled (duh). Make a phone call, it will say Wi-Fi calling at the top of the screen, DONE. You can even do this on older builds, that support it, you don’t even need to update.
All Replies (15)
4/30/19
Are you using the dual sim functionality? Is Fi set as your primary SIM?
marked this as an answer
Helpful?
-
4/30/19
Haha you're kidding right. Let's skip all the basic questions. I have two google fi sim's including the esim set to google fi. It is well know that previous iterations of google sim cards have problems.

I've also tried:
  • Uninstall & Reinstall Hangouts
    • Open Play Store>Search Hangouts> Uninstall then Install/Update
  • Clear Hangouts cache & data
    • Settings>Apps & Notifications> Show all apps>Hangouts>Storage>Clear Data(this will clear cache as well)
  • Confirm the correct email is logged into Hangouts
  • Clear the dialer (phone) app cache & data
    • Settings>Apps & Notifications>Show all apps>Phone>Storage>Clear Data
  • Confirm all permissions are on for Project Fi,  Hangouts & Google Play Services
    • Settings>Apps & Notifications>Show all apps>(Hangouts/Project Fi/Google Play Services)>Permissions> confirm all are toggled ON
  • Confirm all permissions are on for Carrier Services & no data restrictions
    • Settings>Apps & Notifications>Show all apps>three dots on top right>Show system>Carrier Services>Permissions> confirm all are ON (Reboot phone)
    • Settings>Apps & Notifications>Show all apps>three dots on the top right>Show system> Carrier Services>Data Usage>Confirm Background data ON & Unrestricted data ON
  • Confirm there are no data restrictions set for; Hangouts, Project Fi, Messenger, Google Play Services & Phone(dialer) app
    • Settings>Apps & Notifications>Show all apps> (any of the apps listed above)>Data Usage>Confirm Background data ON & Unrestricted data ON
  • Confirm if user is dialing full 10 digit number or not.
  • Install the Hangouts Dialer App.
  • Place a call using the Hangouts Dialer App.
  • Afterwards, try using the regular Phone/Dialer App once more.

Remember the list provided wasn't complete.
marked this as an answer
Helpful?
-
4/30/19
Please reply if you have successfully used wifi calling on a pixel 3xl with google fi without issues
marked this as an answer
Helpful?
-
4/30/19
Just to be clear when I meant different fi sim's, I'm fortunate to have access to different accounts due to various businesses. This is not one account tied to many sims etc....

Also note that google hangouts isn't pre-installed into the factory operating system. Why should I start downloading VOIP apps to get the main call functionality to work? What's next download skype etc....
marked this as an answer
Helpful?
10/25/19
No matter what phone one has the ONLY way to test wifi calling is to do it in AIRPLANE mode!.  I have used a Moto X4 for ca. 18 months.  I have used wifi calling in the USA and in Sweden using my own supplied wifi source/connection.  Many times it works but sometimes it does NOT!  For instance,  I used wifi calling in the USA in March 2019 and then traveled to Sweden in April 2019 where wifi calling did NOT work using the blue dialer alone.  In Sweden I had to use Hangouts also to get it to work.  On my return to the US in May 2019 wifi calling only worked with Hangouts enabled.  I spent many hours with Fi support on email, etc. and they were NO help.  Wifi calling in airplane mode without Hangouts suddenly started working a few weeks later.  There is no rhyme or reason for these wifi dropouts and if anyone at Fi knows why, they are not making it evident!!
marked this as an answer
Helpful?
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/fi/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/fi/profile/0?hl=en