UPnP 라이브러리 취약점 해결을 위한 휴대용 SDK로 앱을 수정하는 방법

본 정보는 libupnp라고 알려져 있는 UPnP 기기용 휴대용 SDK의 1.6.18 이전 버전을 활용하는 앱의 개발자를 대상으로 합니다. libupnp은 미디어 파일을 재생하거나 사용자의 네트워크 내에 있는 다른 기기에 연결하는 데 사용되는 라이브러리입니다.최대한 빨리 앱을 libupnp v1.6.18 이상으로 이전하고 업그레이드된 APK의 버전 번호를 올리시기 바랍니다.

현재 상태

2016년 5월 9일부터 Google Play에서는 libupnp 1.6.18 이전 버전을 사용하는 새 앱과 업데이트의 게시를 차단했습니다. Play Console 공지사항을 참조하세요. Play Console에 표시된 기한이 지난 후에도 보안 취약점이 수정되지 않은 앱은 모두 Google Play에서 삭제될 수 있습니다.

필요한 조치​

  1. Play Console에 로그인한 후 알림 섹션으로 이동하여 영향을 받는 앱과 문제 해결 기한을 확인합니다.
  2. 영향을 받는 앱을 업데이트하여 취약점을 수정합니다.
  3. 영향을 받는 앱의 업데이트된 버전을 제출합니다.

다시 제출하면 앱은 다시 검토 절차를 거치게 되며 이 절차는 몇 시간 정도 걸릴 수 있습니다. 앱이 검토 과정을 통과하고 게시가 완료되면 더 이상의 조치가 필요하지 않습니다. 앱이 검토 과정을 통과하지 못할 경우 새로운 앱 버전은 게시되지 않으며 이메일 알림을 받게 됩니다.

추가 세부정보

취약점은 libupnp 1.6.18에서 해결되었습니다. libupnp 사이트에서 libupnp SDK의 최신 버전을 다운로드할 수 있습니다. 업그레이드와 관련하여 도움을 받으려면 libupnp 지원 페이지를 참조하세요. libupnp을 번들로 제공하는 타사 라이브러리를 사용 중인 경우 libupnp 1.6.18 이상을 번들로 제공하는 버전으로 업그레이드하셔야 합니다.

영향을 받은 libupnp 버전에는 스택 버퍼 오버플로 취약점이 포함되어 있으며, 이를 통해 공격자가 대상 기기에서 임의의 코드를 실행할 수 있습니다. 취약점에 대한 자세한 내용은 TrendMicro 블로그 게시물을 참조하세요. 다른 기술 관련 질문이 있으면 Stack Overflow에 'android-security' 및 'libupnp' 태그를 추가하여 게시하세요.

이러한 문제가 libupnp를 사용하는 모든 앱에 영향을 주는 것은 아니지만, 모든 보안 패치를 최신 상태로 유지하는 것이 가장 좋습니다. 사용자를 보안 위험에 노출시키는 취약점이 있는 앱은 콘텐츠 정책 및 개발자 배포 계약의 4.4항을 위반하는 위험한 제품으로 간주될 수 있습니다.

또한 앱은 개발자 배포 계약콘텐츠 정책을 준수해야 합니다. 

도움이 필요하신가요?

취약점에 관한 기술적인 문의사항이 있다면 'android-security' 태그를 사용하여 Stack Overflow에 게시해 주시기 바랍니다. 문제 해결 절차에 관해 궁금하신 점이 있으면 Google 개발자 지원팀에 문의하세요.

도움이 되었나요?
어떻게 하면 개선할 수 있을까요?