如何修復有 AdMarvel 安全漏洞的應用程式

開發人員請注意,如果您的應用程式使用了 2.5.4 以下版本的 AdMarvel 平台,請詳閱本文資訊。這些版本含有安全漏洞,違反了《內容政策》的危險產品條款和《開發人員發布協議》第 4.4 條請儘快將您的應用程式升級至 AdMarvel 2.5.4 以上版本,並依照累加原則為升級的 APK 設定版本號碼。

問題說明

自 2016 年 5 月 9 日起,只要新的應用程式或更新內容使用了 2.5.4 之前的 AdMarvel 版本,一律禁止在 Google Play 發布。請參閱 Play Console 的通知內容。Play Console 顯示的修正期限過後,Google Play 會將尚未修復安全漏洞的應用程式下架。

須採取行動​

  1. 登入 Play Console,然後前往「快訊」專區查看受影響的應用程式以及解決這些問題的期限。
  2. 更新受影響的應用程式並修復安全漏洞。
  3. 提交受影響應用程式的更新版本。

我們將再次審查您重新提交的應用程式,過程可能需要數小時。如果應用程式可以通過審查並成功發布,您就不必採取進一步行動。如果應用程式未能通過審查,就無法發布新的版本,而且您將收到電子郵件通知。

其他詳細資訊

AdMarvel 2.5.4 版已解決安全漏洞問題。您可以從 AdMarvel 資訊主頁下載最新版的 AdMarvel SDK。如要確認您的版本號碼,請查看 AdMarvelUtils 類別。如果您使用的第三方程式庫包含 AdMarvel,請升級至包含 AdMarvel 2.5.4 以上版本的程式庫。

如需更多資訊,您可以傳送電子郵件至 adsupport@admarvel.com 與 AdMarvel 支援小組聯絡,也可以前往 Stack Overflow 張貼問題 (使用「android-security」和「AdMarvel」標記)。

明確啟用 setAllowUniversalAccessFromFileURLs 布林值標記的 WebView 設定過於寬鬆,因此會造成安全漏洞。攻擊者可利用這個漏洞,在廣告素材中植入惡意 JavaScript 程式碼以存取裝置上的本機資源。如有其他技術問題,請前往 Stack Overflow 張貼問題並加上「android-security」和「AdMarvel」標記。

雖然這些特定問題不一定會對所有使用 AdMarvel 的應用程式造成影響,我們仍建議您安裝所有最新的安全性修補程式。如果應用程式有安全漏洞,導致使用者的資料有外洩之虞,我們就可能將該應用程式視為危險產品 (違反《內容政策》和《開發人員發布協議》第 4.4 條)。

此外,應用程式也必須遵循《開發人員發布協議》和《內容政策》。

我們很樂意提供協助

如有關於安全漏洞的技術問題,請前往 Stack Overflow 張貼問題並加上「android-security」標記。如需進一步瞭解這個問題的解決步驟,歡迎與開發人員支援小組聯絡。

這篇文章實用嗎?
我們應如何改進呢?