false
//accounts.google.com/ServiceLogin
Unable to update subscription.
You have been unsubscribed
Browse the Expeditions Community
Updated: Today
Updated: Yesterday
Updated: This week
Updated: This month
I'm attempting to contact a representative, either by email or phone, regarding Expeditions. I'm trying to contact a representative regarding Google Expeditions.
0 Recommended Answers 6 Replies 1 Upvote
Problems loading tours try again. Version 2.2190108036 Samsung Nokia 5 We have 30 Samsung Nokia Phones that are used with our VR headsets in the high school. We are using … how do i place navigation arrows for a tour? Im trying to create a tour of a business to post on google maps. I cant get the navigational arrows … When i run an expedition a few of my smartphones view this blurred and lagging like motion sickness Trying to run a google expedition which runs fine on 12/14 android devices however two of these are … For a new Expeditions kit- does each device need it's own Google account, or can they share? I'm trying to set up a new expeditions kit for our library. Before I go too far down the rabbit hole… AR + Android + Chrome OS + Kiosk Mode When I have my Acer ChromeTab Student devices in the Expeditions Kiosk mode and joined in a guided s… Which VR viewers can I buy that will work with google expedition that are not made of cardboard I am looking for a VR viewer that will support the Google Expedition apps. I was thinking of getting… Audio narration not working even after turned on during tour in settings. Works on desktop. Audio tours are not working even after activated during tours in settings. They work on the desktop … I just got dream vr with buttons attached to the headset. These aren't working with google cardboard I have tried switching the mode, hasn't worked.
0 Recommended Answers 1 Reply 0 Upvotes
We have ACER Spin 11s and cannot get any of them to connect to any expeditions on the network We have multiple ACER Spin 11 Chromebooks that run the Android app. They work fine in Guide mode, bu… Having issues using a self-created VR tour in Google expeditions with iPads/Lenovo Mirage Solo We are trying to use Lenovo Mirage solo headsets to guide self-created tours from an iPad. We have a… Accessing Google Expeditions content on a school network. Thumbnails don't load and can't download. Hi Google Community, We are at a school based in Australia and use a filtering service called Cyberh… Mirage Solo Google Expeditions cannot see host on Android tablet I have been trying to get our set of Mirage Solo headsets to work in our school district for weeks n… Is there an age recommendation to use Google Expeditions? Specifically in any terms or service Is there any age recommendation to use Google Expeditions? Specifically mentioned in terms of servic… When guiding an expedition using a Chromebook, some of the slides do NOT have the orange play button There are missing start buttons on some slides when I try and be the guide for a Google Expedition. …
Updated: Earlier
Not what you're looking for? Try asking the Help Community
Ask now
$0 selected
Filter
Contains
Question type
Details
Has words