System requirements

In order for Google Earth to run on your computer, you must have all minimum system requirements. Please look below to learn more about the system requirements for your specific operating system.

 

PC System Configuration
Minimum:
  • Operating System: Windows XP and later
  • CPU: Pentium 3, 500Mhz
  • System Memory (RAM): 512MB
  • Hard Disk: 500MB free space
  • Network Speed: 128 Kbits/sec
  • Graphics Card: DirectX9 and 3D capable with 64MB of VRAM
  • Screen: 1024x768, "16-bit High Color" - DirectX 9 (to run in Direct X mode)
  • Mail: Outlook 2007+ is required for email functionality
Recommended:
  • Operating System: Windows 7 and 8
  • CPU: Pentium 4 2.4GHz+ or AMD 2400xp+
  • System Memory (RAM): 1GB+
  • Hard Disk: 2GB+ free space
  • Network Speed: 768 Kbits/sec
  • Graphics Card: DirectX9 and 3D capable with 256MB of VRAM
  • Screen: 1280x1024, "32-bit True Color"
Mac System Configuration
Minimum:
  • Operating System: Mac OS X 10.6 or later
  • CPU: Any Intel Mac
  • System Memory (RAM): 512MB
  • Hard Disk: 500MB free space
  • Network Speed: 128 Kbits/sec
  • Graphics Card: DirectX9 and 3D capable with 64MB of VRAM
  • Screen: 1024x768, "Thousands of Colors"
Recommended:
  • Operating System: Mac OS X 10.6.8 or later
  • CPU: Dual Core Intel Mac
  • System Memory (RAM): 1GB+
  • Hard Disk: 2GB free space
  • Network Speed: 768 Kbits/sec
  • Graphics Card: DirectX9 and 3D capable with 256MB of VRAM
  • Screen: 1280x1024, "Millions of Colors"
Linux System Configuration
Minimum:
  • Kernel: 2.4 or later
  • glibc: 2.3.2 w/ NPTL or later
  • XFree86-4.0 or x.org R6.7 or later
  • CPU: Pentium 3, 500Mhz
  • System Memory (RAM): 512MB
  • Hard Disk: 500MB free space
  • Network Speed: 128 Kbits/sec
  • Graphics Card: DirectX9 and 3D capable with 64MB of VRAM
  • Screen: 1024x768, "16-bit High Color" screen
Recommended:
  • Kernel 2.6 or later
  • glibc 2.3.5 w/ NPTL or later
  • x.org R6.7 or later
  • System Memory (RAM): 1GB
  • Hard Disk: 2GB free space
  • Network Speed: 768 Kbits/sec
  • Graphics Card: DirectX9 and 3D capable with 256MB of VRAM
  • Screen: 1280x1024, 32 bit color
LSB must be installed in order for Google Earth to run on Linux. Your operating system should install this dependency automatically when you install Google Earth.

Google Earth is officially supported against the most current versions of the Ubuntu and RHEL Linux distributions. Although we do not officially support Google Earth on other Linux distributions, many users have successfully run Google Earth on these platforms.