搜尋
清除搜尋內容
關閉搜尋框
Google 應用程式
主選單

解決 Windows 電腦的當機與圖片錯誤問題

本文將詳細說明如何修正以下問題:

  • 「顯示卡不明」錯誤
  • 「遺失 .dll」錯誤
  • Google 地球中出現白色球體
  • 3D 檢視中出現斑點、綠色方塊、閃爍的線條或黑色區域
  • 其他任何的圖形或顯示問題,包括字元缺漏
  • 任何當機問題

您的電腦必須具有獨立顯示卡或具備 3D 功能的整合式圖形處理器 (IGP),才能使用 Google 地球。這些裝置可讓電腦處理及產生圖形、動畫和視訊畫面。

如果您未安裝相容的顯示卡 (IGP),下列方案將無法解決您的問題。您可以新增或升級這兩種裝置,但我們無法針對特定硬體提供任何建議。

很多因素都會導致 Google 地球無法正常顯示圖像或突然當機,最常見的原因如下:

 

  • 顯示卡型號過於老舊
  • DirectXOpenGL 問題
  • 毀損的 myplaces.kml 檔案造成您的系統在啟動時發生當機

 

大部分情況下,只要根據下列步驟,按照順序一步步地操作,就能解決您的問題。如果您已找出問題所在,可以直接跳到相關步驟。

步驟 1:清除快取

請先試著「清除快取」,再進行其他變更。這個步驟通常可以解決圖像的不正常修補程式出現在錯誤的地點問題。

如果您無法登入 Google 地球,請依照下列步驟來刪除快取:

  1. 移至 [檔案],然後選取 [伺服器登出]。
  2. 依序選取 [工具] > [選項] > [快取]。
  3. 按一下 [刪除快取檔案] 按鈕 (僅限登出時)。

如果您無法登入,則必須從目錄資料夾中刪除檔案。如要這樣做,請依照下列步驟執行:

Windows XP 使用者

  1. 按兩下桌面上的 [我的電腦] 圖示。
  2. 選取 [工具] 然後再選取 [資料夾選項]。
  3. 按一下 [檢視]。
  4. 在 [隱藏檔案和資料夾] 部分中,選取 [顯示所有隱藏檔案和資料夾]。
  5. 按一下 [確定]。
  6. 在以下目錄中尋找 .dat 檔案:C:\Documents and Settings\%username%\Local Settings\Application Data\Google\GoogleEarth
  7. dbCache.datdbCache.dat.index 檔案上按一下滑鼠右鍵,再依序選取 [刪除] 和 [是],將檔案移至資源回收筒。下次當您登入 Google 地球時,系統便會重新建立這些檔案。
  8. 尋找 unified_cache_leveldb_leveldb2 資料夾。
  9. 在這個資料夾圖示上按滑鼠右鍵,然後依序選取 [刪除] > [是],就可以將它移至資源回收筒。

 

Windows Vista 與 Windows 7 使用者

  1. 連按兩下桌面上的 [電腦] 圖示。
  2. 依序選取 [組合管理] 及 [資料夾和搜尋選項]
  3. 按一下 [檢視]。
  4. 在 [隱藏檔案和資料夾] 部分中,選取 [顯示所有隱藏檔案和資料夾]。
  5. 按一下 [確定]。
  6. 在以下目錄中尋找 .dat 檔案:C:\Users\%username%\AppData\%Local 或 LocalLow%\Google\GoogleEarth
  7. dbCache.datdbCache.dat.index 檔案上按一下滑鼠右鍵,再依序選取 [刪除] 和 [是],將檔案移至資源回收筒。下次當您登入 Google 地球時,系統便會重新建立這些檔案。
  8. 尋找 unified_cache_leveldb_leveldb2 資料夾。
  9. 在這個資料夾圖示上按滑鼠右鍵,然後依序選取 [刪除] > [是],就可以將它移至資源回收筒。

 

Windows 8 使用者

  1. 按 Windows 鍵
  2. 依序點選 [Windows 檔案總管] > [電腦]。
  3. 依序點選 [檢視] > [選項]。
  4. 依序選取 [檢視] > [顯示所有檔案和資料夾]。
  5. 按一下 [確定]。
  6. 找出以下目錄中的 .dat 檔案:C:\Users\%username%\AppData\%Local 或是 LocalLow%\Google\GoogleEarth
  7. dbCache.datdbCache.dat.index 檔案上按一下滑鼠右鍵,然後依序選取 [刪除] > [是],將檔案移至資源回收筒。下次當您登入 Google 地球時,系統便會重新建立這些檔案。
  8. 尋找 unified_cache_leveldb_leveldb2 資料夾。
  9. 在這個資料夾圖示上按滑鼠右鍵,然後依序選取 [刪除] > [是],就可以將它移至資源回收筒。

如果清除快取後問題仍然存在,您也可以試著關閉 [大氣層]

步驟 2:關閉 [大氣層]

如要關閉 [大氣層],請按照下列步驟操作:

  • 移至 [檢視] 功能表。
  • 取消勾選標示為 [大氣層] 的選項。

 

如果關閉「大氣層」後問題仍然持續發生,請試著在 DirectX 與 OpenGL 模式之間切換。

步驟 3:在 DirectX 和 OpenGL 之間切換

Windows 使用者可以在 DirectX 模式或 OpenGL 模式下執行 Google 地球 (免費版與專業版)。如果圖像無法正常顯示,請試著分別在這兩種模式下執行 Google 地球,看看哪一種模式比較適合您的系統。

將 DirectX 設為您的預設轉譯器

如要切換到 DirectX,請按照下列步驟操作:

 

  • 依序點選 [開始] > [程式集]。
  • 將滑鼠游標移到在 Google 地球(免費版或專業版) 上,並選取 [在 DirectX 模式中啟動 Google 地球]。

 

將 OpenGL 設為您的預設轉譯器

如要切換到 OpenGL,請按照下列步驟操作:

 

  • 依序點選 [開始] > [程式集]。
  • 將滑鼠游標移到在 Google 地球 (免費版或專業版) 上,並選取 [在 OpenGL 模式中啟動 Google 地球]。

 

如要在 DirectX 與 OpenGL 模式間切換,您必須關閉 Google 地球。

如果切換至 DirectX 和 OpenGL 模式仍然無法解決問題,建議您更新顯示卡驅動程式。如要更新顯示卡驅動程式,您必須先判定您的顯示卡為何

步驟 4:確認您的顯示卡型號

如果您不清楚電腦所安裝的是哪一種顯示卡,可使用偵測程式來判定電腦的硬體、作業系統和顯示卡,方法如下:

 

  • XP 使用者:依序選取 [開始] > [執行]。在隨即出現的方塊中輸入 dxdiag,並按下 [確定]。
  • Vista 與 Windows 7 使用者:按一下 [開始] 按鈕,並在 [開始搜尋] 方塊中輸入 dxdiag,然後在搜尋結果中選取 dxdiag
  • Windows 8 使用者:按 Windows 鍵 + s,然後輸入 dxdiag,接下來按 Enter
  • 在出現的提示中按一下 [是],程式就會開始執行。
  • 點選 [顯示] 分頁,然後從 [裝置] 部分,找出顯示卡的名稱。

 

步驟 5:更新顯示卡驅動程式

確認您的顯示卡型號之後,即可以依照下列步驟來更新顯示卡驅動程式:

筆記型電腦使用者:請造訪電腦製造商的網站,並取得最新的驅動程式:

 

 

桌上型電腦使用者:請造訪顯示卡製造商的網站,並取得最新的驅動程式:

 

 

注意:我們強烈建議不要安裝測試版的顯示卡驅動程式。

如果您更新顯示卡驅動程式之後問題仍然存在,請試著更新 Microsoft DirectX

步驟 6:更新 DirectX 驅動程式

需具備 DirectX 9.0 或以上版本,Google 地球才能正常在 Windows 電腦上執行。

請造訪 Microsoft 下載中心並下載適用於您系統的最新 DirectX 驅動程式。

如果您在嘗試上述所有步驟之後,Google 地球專業版在啟動時電腦就當機了,很有可能是您的 myplaces.kml 檔案毀損,導致啟動時發生系統當機。最好的解決方式就是備份地點資料、清理 Google 地球應用程式資料夾並重新啟動。

步驟 7:移除損毀的 myplaces.kml 檔案

 

Windows XP 使用者:

  1. 確認 Google 地球專業版已關閉。
  2. 依序點選 [開始] > [執行]
  3. 在 [開啟] 列,輸入 C:\Documents and Settings\%username%\Application Data\Google\GoogleEarth 或是複製這個路徑,然後點選 [確定]。另一種方法如下:先按兩下桌面上的 [我的電腦],然後從相同的資料夾結構中找出這個資料夾。
  4. Windows 檔案總管會開啟 GoogleEarth 資料夾,這個目錄含有數個 Google 地球專業版檔案,包括:My Style Templates 資料夾、myplaces.kmlmyplaces.backup.kml 以及 myplaces.kml.tmp
  5. 複製 GoogleEarth 資料夾中的所有檔案,並將這些檔案儲存在不同位置,例如儲存到您桌面上的資料夾。
  6. 確認您已備份所有檔案後,請刪除 GoogleEarth 資料夾中的所有檔案。
  7. 關閉 GoogleEarth 資料夾,並開啟 Google 地球。
  8. 登入伺服器後,Google 地球專業版會在 GoogleEarth 資料夾中建立新的檔案,取代您移除的檔案。

 

Windows Vista 與 Windows 7 使用者:

  1. 確認 Google 地球專業版已關閉。
  2. 依序點選 [開始] > [開始搜尋]
  3. 在 [開始搜尋] 對話方塊中,輸入 C:\Users\%username%\AppData\%Local 或是 LocalLow\Google\GoogleEarth,然後點選 [確定]。另一種方法如下:您可以先按兩下桌面上的 [電腦] 圖示,然後從相同的資料夾結構中找出這個資料夾。
  4. Windows 檔案總管會開啟 GoogleEarth 資料夾,這個目錄含有數個 Google 地球專業版檔案,包括:My Style Templates 資料夾、myplaces.kmlmyplaces.backup.kml 以及 myplaces.kml.tmp
  5. 複製 GoogleEarth 資料夾中的所有檔案,並將這些檔案儲存在不同位置,例如儲存到您桌面上的資料夾。
  6. 確認您已備份所有檔案後,請刪除 GoogleEarth 資料夾中的所有檔案。
  7. 關閉 GoogleEarth 資料夾,並開啟 Google 地球。
  8. 登入伺服器後,Google 地球專業版會在 GoogleEarth 資料夾中建立新的檔案,取代您移除的檔案。

 

Windows 8 使用者:

  1. 確認 Google 地球專業版已關閉。
  2. Windows 鍵 + s
  3. 在 [開始搜尋] 對話方塊中,輸入 C:\Users\%username%\AppData\%Local 或是 LocalLow\Google\GoogleEarth,然後點選 [確定]。另一種方法如下:您可以先按兩下桌面上的 [電腦] 圖示,然後從相同的資料夾結構中找出這個資料夾。
  4. Windows 檔案總管會開啟 GoogleEarth 資料夾,這個目錄含有數個 Google 地球專業版檔案,其中包括:My Style Templates Folder, myplaces.kmlmyplaces.backup.kmlmyplaces.kml.tmp
  5. 複製 GoogleEarth 資料夾中的所有檔案,並將這些檔案儲存在不同位置,例如儲存到您桌面上的資料夾。
  6. 在確認您已備份所有檔案之後,刪除 GoogleEarth 資料夾中的所有檔案。
  7. 關閉 GoogleEarth 資料夾,然後開啟 Google 地球。
  8. 登入伺服器後,Google 地球專業版會在 GoogleEarth 資料夾中建立新的檔案,取代您移除的檔案。

 

如果您在嘗試所有上述步驟後仍遇到問題,那麼有可能是您的電腦本身出了問題。請完全解除安裝 Google 地球專業版,然後再重新安裝一次。