Arama
Aramayı temizle
Aramayı kapat
Google uygulamaları
Ana menü

Windows makinelerde kilitlenme ve grafik sorunlarını giderme

Bu makalede aşağıdaki sorunların nasıl giderileceği açıklanmaktadır:

  • "Bilinmeyen Grafik Kartı" hatası
  • "Eksik .dll" hatası
  • Google Earth'te yerküre beyaz görünüyor
  • Yamalar, yeşil kareler, yanıp sönen çizgiler, titreşen veya 3D görünümde siyah görünen alanlar
  • Eksik karakterler de dahil diğer tüm grafik veya görüntü hataları
  • Tüm kilitlenmeler

Google Earth, 3D özelliklerine sahip bir grafik kartının veya tümleşik grafik işlemcisinin (IGP) kullanılmasını gerektirir. Bu cihazlar bilgisayarın grafikleri, animasyonları ve videoları işlemesini ve görüntülemesini sağlar.

Uyumlu bir ekran kartınız (IGP) yoksa, aşağıdaki çözümler sizin sorununuzu gidermeyecektir. Her ikisini de ekleyebilir veya yeni sürüme geçirebilirsiniz, ancak donanımlarla ilgili öneride bulunamayız.

Google Earth'ün normal olmayan grafik görüntüleri sunmasının veya aniden kilitlenmesinin pek çok nedeni olabilir, ancak en genel nedenler şunlardır:

 

  • Eski grafik kartı
  • DirectX veya OpenGL ile ilgili bir sorun
  • Başlatma sırasında sisteminizin kilitlenmesine neden olan bozuk bir myplaces.kml dosyası

 

Çoğu durumda, aşağıdaki adımları uygulayarak sorununuzu çözebilmeniz gerekir. Bu adımları belirtilen sırada uygulamanızı öneririz. Yine de, sorunu başarılı bir şekilde tanıladığınıza inanıyorsanız doğrudan ilgili adıma geçebilirsiniz.

1. Adım: Önbelleğinizi Temizleme

Herhangi bir değişiklik yapmadan önce önbelleğinizi temizlemeyi denemelisiniz. Bu adım çoğunlukla, yanlış konumda gösterilen garip görüntü yamaları gibi sorunları giderir.

Google Earth’e giriş yapabiliyorsanız önbelleğinizi silmek için lütfen aşağıdaki adımları uygulayın:

  1. Dosya menüsüne gidin ve Sunucu Oturumunu Kapat'ı seçin.
  2. Araçlar > Seçenekler > Önbellek’i seçin.
  3. Önbellek Dosyasını Sil yazan düğmeyi tıklayın (Yalnızca oturum kapalıyken).

Giriş yapamıyorsanız bu dosyayı dizin klasöründen silmeniz gerekir. Bunu yapmak için şu adımları uygulayın:

Windows XP Kullanıcıları

  1. Masaüstünüzde Bilgisayarım simgesini çift tıklayın.
  2. Araçlar'ı, sonra Klasör Seçenekleri'ni belirleyin.
  3. Görünüm’ü tıklayın.
  4. "Gizli dosyalar ve klasörler" bölümü altında, Gizli dosya ve klasörleri göster'i seçin.
  5. Tamam’ı tıklayın.
  6. Şu dizinde .dat dosyalarını arayın: C:\Documents and Settings\%kullanıcı_adı%\Local Settings\Application Data\Google\GoogleEarth.
  7. dbCache.dat ve dbCache.dat.index dosyalarını sağ tıklayın, Sil'i seçin ve ardından dosyaları Geri Dönüşüm Kutusu’na taşımak için Evet'i seçin. Google Earth uygulamasına bir sonraki girişinizde bu dosyalar yeniden oluşturulur.
  8. unified_cache_leveldb_leveldb2 klasörünü bulun.
  9. Klasörü Çöp Kutusu'na taşımak için sağ tıklayın, Sil'i ve Evet'i seçin.  

 

Windows Vista ve Windows 7 Kullanıcıları

  1. Masaüstünüzde Bilgisayar simgesini çift tıklayın.
  2. Düzenle'yi ve daha sonra, Klasör ve Arama Seçenekleri'ni seçin.
  3. Görünüm’ü tıklayın.
  4. "Gizli dosyalar ve klasörler" bölümü altında, Gizli dosya ve klasörleri göster'i seçin.
  5. Tamam’ı tıklayın.
  6. Bu dizindeki .dat dosyalarını arayın: C:\Users\%kullanıcı_adı%\AppData\%Local veya LocalLow%\Google\GoogleEarth.
  7. dbCache.dat ve dbCache.dat.index dosyalarını sağ tıklayın, Sil'i seçin ve ardından dosyaları Geri Dönüşüm Kutusu’na taşımak için Evet'i seçin. Google Earth uygulamasına bir sonraki girişinizde bu dosyalar yeniden oluşturulur.
  8. unified_cache_leveldb_leveldb2 klasörünü bulun.
  9. Klasörü Çöp Kutusu'na taşımak için sağ tıklayın, Sil'i ve Evet'i seçin.  

 

Windows 8 Kullanıcıları

  1. Windows tuşuna basın.
  2. Windows Gezgini'ni ve Bilgisayar'ı tıklayın.
  3. Görünüm'ü ve Seçenekler'i tıklayın.
  4. Görünüm'ü ve Gizli dosyaları ve klasörleri göster'i seçin.
  5. Tamam’ı tıklayın.
  6. Şu dizindeki .dat dosyalarını arayın: C:\Users\%kullanıcı_adı%\AppData\%Local veya LocalLow%\Google\GoogleEarth.
  7. dbCache.dat ve dbCache.dat.index dosyalarını sağ tıklayın, Sil'i seçin ve ardından dosyaları Geri Dönüşüm Kutusu’na taşımak için Evet'i seçin. Google Earth uygulamasına bir sonraki girişinizde bu dosyalar yeniden oluşturulur.
  8. unified_cache_leveldb_leveldb2 klasörünü bulun.
  9. Klasörü Çöp Kutusu'na taşımak için sağ tıklayın, Sil'i ve Evet'i seçin.  

Belleğinizin temizlenmesi, sorunu gidermediyse Atmosfer'i de kapatmayı deneyebilirsiniz.

2. Adım: Atmosferi Kapatma

Atmosfer'i kapatmak için lütfen aşağıdaki adımları uygulayın:

  • Görünüm menüsüne gidin.
  • Atmosfer yazan seçeneğin işaretini kaldırın.

 

Atmosfer'i kapattıktan sonra da sorun yaşamaya devam ederseniz DirectX ve OpenGL modları arasında geçiş yapmayı deneyin.

3. Adım: DirectX ve OpenGL Arasında Geçiş Yapma

Windows kullanıcıları Google Earth'ü (Ücretsiz sürümü ve Pro sürümünü) DirectX veya OpenGL modunda kullanabilirler. Normal olmayan grafik sorunlarıyla karşılaşırsanız, sisteminizde hangi modun daha iyi çalıştığını görmek için Google Earth'ü her iki modda da çalıştırmayı denemelisiniz.

DirectX'i varsayılan oluşturucunuz olarak ayarlama

DirectX’e geçiş yapmak için lütfen aşağıdaki adımları uygulayın:

 

  • Başlat > Tüm Programlar’ı tıklayın.
  • Farenizi Google Earth'ün (Ücretsiz sürüm veya Pro sürümü) üzerine getirin, Google Earth’ü DirectX modunda başlat’ı seçin.

 

OpenGL'yi varsayılan oluşturucunuz olarak ayarlama

OpenGL’ye geçiş yapmak için lütfen aşağıdaki adımları uygulayın:

 

  • Başlat > Tüm Programlar’ı tıklayın.
  • Google Earth'ün (Ücretsiz sürüm veya Pro sürümü) üzerine gelin, Google Earth’ü OpenGL modunda başlat’ı seçin.

 

DirectX ve OpenGL modları arasında geçiş yapmak için Google Earth'ü kapatmanız gerekir.

Hem DirectX hem de OpenGL modlarını denedikten sonra da sorun yaşamaya devam ederseniz, grafik kartı sürücülerinizi güncellemeniz gerekiyor olabilir. Bunun için öncelikle hangi grafik kartına sahip olduğunuzu belirlemeniz gerekir.

4. Adım: Grafik Kartınızı Belirleme

Bilgisayarınızda ne tür grafik kartı yüklü olduğunu bilmiyorsanız bilgisayarınızın donanımını, işletim sistemini ve grafik kartını belirleyen bir program kullanabilirsiniz:

 

  • XP Kullanıcıları: Başlat > Çalıştır'a gidin. Görüntülenen kutuya dxdiag yazın ve Tamam'ı tıklayın.
  • Vista ve Windows 7 Kullanıcıları: Başlat düğmesini tıklayın ve daha sonra, Arama Başlat kutusuna dxdiag yazıp arama sonuçlarınızdan dxdiag öğesini seçin.
  • Windows 8 Kullanıcıları:  Windows tuşu + s tuşuna basın ve dxdiag yazıp Enter'a basın.
  • Görüntülenen istemde Evet'i tıkladığınızda program çalışmaya başlar.
  • Görüntü sekmesini tıklayın, "Aygıt" bölümü altında grafik kartınızın adını listelenmiş olarak görebilirsiniz.

 

5. Adım: Grafik Kartı Sürücülerinizi Güncelleme

Hangi grafik kartını kullandığınızı öğrendikten sonra, aşağıdaki talimatları uygulayarak grafik kartı sürücülerinizi güncelleyebilirsiniz:

DİZÜSTÜ BİLGİSAYAR KULLANICILARI: En güncel sürücüleri edinmek için dizüstü bilgisayarınızın üreticisinin web sitesini ziyaret edin.

 

 

MASAÜSTÜ BİLGİSAYAR KULLANICILARI: En güncel sürücüleri edinmek için grafik kartınızın üreticisinin web sitesini ziyaret edin.

 

 

NOT: Grafik kartı sürücülerinin beta sürümlerinin yüklenmesini kesinlikle önermeyiz.

Grafik kartı sürücülerinizi güncellemek, sorunu gidermediyse Microsoft DirectX'i Güncellemeyi deneyin.

6. Adım: DirectX Sürücülerini Güncelleme

Google Earth'ün Windows makinelerde düzgün çalışabilmesi için DirectX 9.0 veya daha yeni sürümü gerekir.

Sisteminiz için en yeni DirectX sürücülerini indirmek üzere Microsoft Download Center'ı ziyaret edin.

Yukarıdaki tüm adımları uygulamanıza rağmen Google Earth Pro açılış sırasında kilitleniyorsa, başlatma sırasında sistemin kilitlenmesine yol açan bozuk bir myplaces.kml dosyanız olabilir. Bu sorunu gidermenin en iyi yolu yer verilerinizi yedeklemek, Google Earth uygulama klasöründen kaldırmak ve temiz bir başlangıç yapmaktır.

7. Adım: Bozuk bir myplaces.kml Dosyasını Kaldırma

 

Windows XP Kullanıcıları:

  1. Google Earth Pro'nun kapalı olduğundan emin olun.
  2. Başlat > Çalıştır'ı tıklayın.
  3. çubuğuna, C:\Documents and Settings\%username%\Application Data\Google\GoogleEarth yazın veya yapıştırın ve Tamam'ı tıklayın. Alternatif olarak bu klasöre, masaüstünüzdeki Bilgisayarım simgesini çift tıklayıp aynı klasör yapısını izleyerek kendiniz de ulaşabilirsiniz.
  4. Windows Gezgini açılmalı ve içinde pek çok Google Earth Pro Dosyasının olduğu bir GoogleEarth klasörünü karşınıza getirmelidir. Bu dosyalardan bazıları: My Style Templates Klasörü, myplaces.kml, myplaces.backup.kml ve myplaces.kml.tmp.
  5. GoogleEarth klasöründeki tüm dosyaların bir kopyasını oluşturun ve bunları masaüstünüzdeki bir klasör gibi farklı bir konuma kaydedin.
  6. GoogleEarth klasöründeki her şeyi silin (öncelikle her şeyi yedeklediğinizden emin olun!)
  7. Google Earth klasörünü kapatın ve Google Earth'ü başlatın.
  8. Sunucuya giriş yaptıktan sonra Google Earth Pro, GoogleEarth klasöründen taşıdığınız dosyaların yerine koymak üzere yeni dosyalar oluşturacaktır.

 

Windows Vista ve Windows 7 Kullanıcıları:

  1. Google Earth Pro'nun kapalı olduğundan emin olun.
  2. Başlat > Arama Başlat'ı tıklayın.
  3. Arama Başlat iletişim kutusuna C:\Users\%username%\AppData\%Local veya LocalLow\Google\GoogleEarth yazın ve Tamam'ı tıklayın. Alternatif olarak bu klasöre, masaüstünüzdeki Bilgisayar simgesini çift tıklayıp aynı klasör yapısını takip ederek kendiniz de ulaşabilirsiniz.
  4. Windows Gezgini açılmalı ve içinde pek çok Google Earth Pro Dosyasının olduğu bir GoogleEarth klasörünü karşınıza getirmelidir. Bu dosyalardan bazıları: My Style Templates Klasörü, myplaces.kml, myplaces.backup.kml ve myplaces.kml.tmp.
  5. GoogleEarth klasöründeki tüm dosyaların bir kopyasını oluşturun ve bunları masaüstünüzdeki bir klasör gibi farklı bir konuma kaydedin.
  6. GoogleEarth klasöründeki her şeyi silin (öncelikle her şeyi yedeklediğinizden emin olun!)
  7. Google Earth klasörünü kapatın ve Google Earth'ü başlatın.
  8. Sunucuya giriş yaptıktan sonra Google Earth Pro, GoogleEarth klasöründen taşıdığınız dosyaların yerine koymak üzere yeni dosyalar oluşturacaktır.

 

Windows 8 Kullanıcıları:

  1. Google Earth Pro'nun kapalı olduğundan emin olun.
  2. Windows tuşu + s tuşuna basın.
  3. Arama Başlat iletişim kutusunda, C:\Users\%username%\AppData\%Local veya LocalLow\Google\GoogleEarth yazın ve Tamam'ı tıklayın. Alternatif olarak bu klasöre, masaüstünüzdeki Bilgisayarım simgesini çift tıklayıp aynı klasör yapısını izleyerek kendiniz de ulaşabilirsiniz.
  4. Windows Gezgini şimdi açılmalı ve içinde bazı Google Earth Pro Dosyalarının olduğu bir GoogleEarth klasörünü karşınıza getirmelidir. Bu dosyalardan bazıları: My Style Templates Klasörü, myplaces.kmlmyplaces.backup.kml ve myplaces.kml.tmp.
  5. GoogleEarth klasöründeki tüm dosyaların bir kopyasını oluşturun ve bunları masaüstünüzdeki bir klasör gibi farklı bir konuma kaydedin.
  6. GoogleEarth klasöründeki her şeyi silin (öncelikle her şeyi yedeklediğinizden emin olun!)
  7. Google Earth klasörünü kapatın ve Google Earth'ü başlatın.
  8. Sunucuya giriş yaptıktan sonra Google Earth Pro, GoogleEarth klasöründen taşıdığınız dosyaların yerine koymak üzere yeni dosyalar oluşturacaktır.

 

Tüm bu adımları uyguladıktan sonra da sorun yaşıyorsanız makinenizde başka bir hata olabilir. Google Earth'ün yüklemesini tamamen kaldırıp uygulamayı tekrar yüklemeyi deneyin.