Résolution de problèmes de plantage et de problèmes graphiques sur les ordinateurs Windows

Cet article explique comment résoudre les problèmes suivants :

  • Erreur signalant une carte graphique inconnue
  • Erreur signalant un fichier DLL manquant
  • Affichage d'un globe terrestre entièrement blanc dans Google Earth
  • Apparition de tâches, de carrés verts, de lignes clignotantes ou de zones noires ou clignotantes dans la vue 3D
  • Toute autre erreur graphique ou d'affichage, y compris des caractères manquants
  • Tout problème provoquant un blocage

Pour pouvoir fonctionner, Google Earth nécessite une carte graphique ou un circuit graphique intégré (IGP) disposant de capacités 3D. Ces périphériques permettent à l'ordinateur de calculer et d'afficher des éléments graphiques, des animations et des vidéos.

Si aucune carte graphique (ou circuit graphique intégré) compatible n'est installé(e) sur votre ordinateur, les solutions suivantes ne résoudront pas votre problème. Vous pouvez ajouter une carte graphique ou un circuit graphique intégré, ou effectuer une mise à niveau de votre ordinateur, mais nous ne sommes pas en mesure de vous recommander un matériel spécifique.

Il existe plusieurs raisons pour lesquelles Google Earth pourrait présenter des problèmes d'affichage ou de blocage intempestif. Les raisons les plus courantes sont les suivantes :

 

  • Une carte graphique obsolète
  • Un problème avec DirectX ou OpenGL
  • Un fichier myplaces.kml corrompu qui bloque votre système au démarrage

 

Dans la plupart des cas, vous devriez être en mesure de résoudre le problème en suivant la procédure ci-dessous. Il est préférable de suivre ces étapes dans l'ordre indiqué. Toutefois, si vous pensez avoir identifié le problème, vous pouvez passer directement à une étape spécifique.

Étape 1 : vider le cache

Avant toute modification, essayez d'abord de vider le cache. Cette étape permet souvent de résoudre les problèmes liés à l'apparition de taches étranges ou à des images s'affichant à des emplacements incorrects.

Si vous pouvez vous connecter à Google Earth, procédez comme suit pour vider le cache :

  1. Dans le menu Fichier, sélectionnez Déconnexion du serveur.
  2. Sélectionnez Outils > Options > Cache.
  3. Cliquez sur le bouton Supprimer le fichier cache (vous devez être déconnecté).

Si vous ne pouvez pas vous connecter, vous devez supprimer ce fichier dans le répertoire approprié. Pour ce faire, procédez comme suit :

Utilisateurs de Windows XP

  1. Double-cliquez sur l'icône Poste de travail du bureau.
  2. Sélectionnez Outils, puis Options des dossiers.
  3. Cliquez sur Affichage.
  4. Dans la section "Fichiers et dossiers cachés", sélectionnez Afficher les fichiers et dossiers cachés.
  5. Cliquez sur OK.
  6. Recherchez les fichiers .dat dans le répertoire suivant : C:\Documents and Settings\%nomutilisateur%\Local Settings\Application Data\Google\GoogleEarth.
  7. Cliquez avec le bouton droit de la souris sur les fichiers dbCache.dat et dbCache.dat.index, puis sélectionnez Supprimer et Oui pour les envoyer vers la Corbeille. Ils seront recréés la prochaine fois que vous vous connecterez à Google Earth.
  8. Recherchez le dossier unified_cache_leveldb_leveldb2.
  9. Faites un clic droit sur ce dernier, sélectionnez Supprimer, puis cliquez sur Oui pour envoyer le dossier à la Corbeille.  

 

Utilisateurs de Windows Vista et Windows 7

  1. Double-cliquez sur l'icône Poste de travail du bureau.
  2. Sélectionnez Organiser, puis Options des dossiers et de recherche.
  3. Cliquez sur Affichage.
  4. Dans la section "Fichiers et dossiers cachés", sélectionnez Afficher les fichiers et dossiers cachés.
  5. Cliquez sur OK.
  6. Recherchez les fichiers .dat dans le répertoire suivant : C:\Users\%nomutilisateur%\AppData\%Local ou LocalLow%\Google\GoogleEarth.
  7. Cliquez avec le bouton droit de la souris sur les fichiers dbCache.dat et dbCache.dat.index, puis sélectionnez Supprimer et Oui pour les envoyer vers la Corbeille. Ils seront recréés la prochaine fois que vous vous connecterez à Google Earth.
  8. Recherchez le dossier unified_cache_leveldb_leveldb2.
  9. Faites un clic droit sur ce dernier, sélectionnez Supprimer, puis cliquez sur Oui pour envoyer le dossier à la Corbeille.  

 

Sous Windows 8 :

  1. Appuyez sur la touche Windows.
  2. Cliquez sur Windows Explorer, puis sur Poste de travail.
  3. Cliquez sur Afficher, puis sur Options.
  4. Sélectionnez Afficher, puis Afficher les fichiers et dossiers cachés.
  5. Cliquez sur OK.
  6. Recherchez les fichiers .dat dans le répertoire suivant : C:\Users\%username%\AppData\%Local ou LocalLow%\Google\GoogleEarth.
  7. Cliquez avec le bouton droit de la souris sur les fichiers dbCache.dat et dbCache.dat.index, puis sélectionnez Supprimer et Oui pour les envoyer vers la Corbeille. Ils seront recréés la prochaine fois que vous vous connecterez à Google Earth.
  8. Recherchez le dossier unified_cache_leveldb_leveldb2.
  9. Faites un clic droit sur ce dernier, sélectionnez Supprimer, puis cliquez sur Oui pour envoyer le dossier à la Corbeille.  

Si le vidage du cache ne résout pas le problème, vous pouvez également essayer de désactiver la fonction Atmosphère.

Étape 2 : désactiver la fonction "Atmosphère"

Pour désactiver la fonctionnalité Atmosphère, procédez comme suit :

  • Ouvrez le menu Affichage.
  • Désélectionnez l'option Atmosphère.

 

Si vous rencontrez toujours des problèmes après avoir désactivé la fonction "Atmosphère", essayez de basculer du mode DirectX à OpenGL.

Étape 3 : basculer du mode DirectX à OpenGL

Les utilisateurs de Windows peuvent exécuter Google Earth (version gratuite et Pro) en mode DirectX ou OpenGL. Si vous rencontrez des problèmes graphiques, essayez d'exécuter Google Earth dans chaque mode pour déterminer si l'un des deux convient mieux à votre système.

Définir DirectX comme moteur de rendu par défaut

Pour passer en mode DirectX, procédez comme suit :

 

  • Cliquez sur Démarrer > Tous les programmes.
  • Placez le curseur sur votre version de Google Earth (version gratuite ou Pro), puis sélectionnez Démarrer Google Earth en mode DirectX.

 

Définir OpenGL comme moteur de rendu par défaut

Pour passer en mode OpenGL, procédez comme suit :

 

  • Cliquez sur Démarrer > Tous les programmes.
  • Placez le curseur sur votre version de Google Earth (version gratuite ou Pro), puis sélectionnez Démarrer Google Earth en mode OpenGL.

 

Pour changer de mode, vous devez fermer Google Earth.

Si vous rencontrez toujours des problèmes après avoir essayé les deux modes DirectX et OpenGL, essayez de mettre à jour les pilotes de votre carte graphique. Pour ce faire, vous devrez d'abord identifier le type de carte graphique dont vous disposez.

Étape 4: déterminer le type de votre carte graphique

Si vous ignorez le type de carte graphique installé dans votre ordinateur, vous pouvez utiliser le programme suivant pour déterminer le matériel, le système d'exploitation et la carte graphique de votre machine :

 

  • Sous XP : sélectionnez Démarrer > Exécuter. Saisissez dxdiag dans la boîte de dialogue qui s'affiche, puis cliquez sur OK.
  • Sous Vista et Windows 7 : cliquez sur le bouton Démarrer, saisissez dxdiag dans la boîte de dialogue Rechercher, puis sélectionnez dxdiag dans les résultats de recherche.
  • Sous Windows 8 : appuyez sur la touche Windows + s, saisissez dxdiag, puis appuyez sur la touche Entrée.
  • Cliquez sur Oui à l'invite afin de démarrer le programme.
  • Cliquez sur l'onglet Affichage. Le nom de votre carte graphique apparaît dans la section "Périphérique".

 

Étape 5: mettre les pilotes de la carte graphique à jour

Une fois que vous avez identifié la carte graphique dont vous disposez, vous pouvez mettre à jour vos pilotes de carte graphique. Pour ce faire, procédez comme suit :

VOUS UTILISEZ UN ORDINATEUR PORTABLE ? Accédez au site Web du fabricant de votre ordinateur portable pour obtenir les pilotes les plus récents :

 

 

VOUS UTILISEZ UN ORDINATEUR DE BUREAU ? Accédez au site Web du fabricant de votre carte graphique pour obtenir les pilotes les plus récents :

 

 

REMARQUE : Nous vous déconseillons fortement d'installer des versions bêta de pilotes de carte graphique.

Si le problème persiste une fois que vous avez mis à jour vos pilotes de carte graphique, essayez de mettre à jour Microsoft DirectX.

Étape 6 : mettre les pilotes de DirectX à jour

Pour fonctionner correctement sur les ordinateurs Windows, Google Earth requiert DirectX 9.0 ou version ultérieure.

Vous pouvez télécharger les derniers pilotes DirectX compatibles avec votre système à partir du centre de téléchargement Microsoft.

Si Google Earth Pro se bloque toujours au démarrage, il est possible qu'un fichier myplaces.kml corrompu soit à l'origine du mauvais lancement de votre système. Pour résoudre ce problème, nous vous recommandons de sauvegarder vos données de lieu, de vider le contenu du répertoire de Google Earth, puis de démarrer correctement l'application.

Étape 7: supprimer un fichier myplaces.kml corrompu

 

Utilisateurs de Windows XP :

  1. Assurez-vous que l'application Google Earth Pro est fermée.
  2. Cliquez sur Démarrer > Exécuter.
  3. Dans la barre Ouvrir, saisissez (ou copiez et collez) le chemin C:\Documents and Settings\%username%\Application Data\Google\GoogleEarth, puis cliquez sur OK. Vous pouvez également accéder à ce dossier manuellement en double-cliquant tout d'abord sur l'icône Poste de travail sur le bureau, puis en naviguant dans la même structure de dossiers.
  4. L'Explorateur Windows ouvre alors un dossier Google Earth contenant plusieurs fichiers Google Earth Pro, notamment le dossier Mes modèles et les fichiers myplaces.kml, myplaces.backup.kml et myplaces.kml.tmp.
  5. Faites une copie de tous les fichiers du dossier GoogleEarth, puis enregistrez-les dans un autre emplacement, par exemple dans un dossier sur votre bureau.
  6. Supprimez le contenu du dossier GoogleEarth. Auparavant, assurez-vous d'avoir tout sauvegardé.
  7. Fermez le dossier GoogleEarth, puis ouvrez Google Earth.
  8. Une fois que vous vous êtes connecté au serveur, Google Earth Pro doit créer des fichiers dans le dossier GoogleEarth afin de remplacer ceux que vous avez déplacés.

 

Utilisateurs de Windows Vista et Windows 7 :

  1. Assurez-vous que l'application Google Earth Pro est fermée.
  2. Cliquez sur Démarrer > Rechercher.
  3. Dans la boîte de dialogue Démarrer la recherche, saisissez C:\Users\%username%\AppData\%Local ou LocalLow\Google\GoogleEarth, puis cliquez sur OK. Vous pouvez également accéder à ce dossier manuellement en double-cliquant tout d'abord sur l'icône Poste de travail sur le bureau, puis en naviguant dans la même structure de dossiers.
  4. L'Explorateur Windows ouvre alors un dossier Google Earth contenant plusieurs fichiers Google Earth Pro, notamment le dossier Mes modèles et les fichiers myplaces.kml, myplaces.backup.kml et myplaces.kml.tmp.
  5. Faites une copie de tous les fichiers du dossier GoogleEarth, puis enregistrez-les dans un autre emplacement, par exemple dans un dossier sur votre bureau.
  6. Supprimez le contenu du dossier GoogleEarth. Auparavant, assurez-vous d'avoir tout sauvegardé !
  7. Fermez le dossier GoogleEarth, puis ouvrez Google Earth.
  8. Une fois que vous vous êtes connecté au serveur, Google Earth Pro doit créer des fichiers dans le dossier GoogleEarth afin de remplacer ceux que vous avez déplacés.

 

Sous Windows 8 :

  1. Assurez-vous que l'application Google Earth Pro est fermée.
  2. Appuyez sur la touche Windows + s.
  3. Dans la boîte de dialogue Démarrer la recherche, saisissez C:\Users\%username%\AppData\%Local ou LocalLow\Google\GoogleEarth, puis cliquez sur OK. Vous pouvez également accéder à ce dossier manuellement en double-cliquant tout d'abord sur l'icône Poste de travail sur le bureau, puis en naviguant dans la même structure de dossiers.
  4. L'Explorateur Windows ouvre alors un dossier GoogleEarth contenant plusieurs fichiers Google Earth Pro, dont le dossier Mes modèles, et les fichiers myplaces.kmlmyplaces.backup.kml, et myplaces.kml.tmp.
  5. Faites une copie de tous les fichiers du dossier GoogleEarth, puis enregistrez-les dans un autre emplacement, par exemple dans un dossier sur votre bureau.
  6. Supprimez le contenu du dossier GoogleEarth. Mais avant tout, assurez-vous d'avoir tout sauvegardé !
  7. Fermez le dossier GoogleEarth, puis ouvrez Google Earth.
  8. Une fois que vous vous êtes connecté au serveur, Google Earth Pro doit créer des fichiers dans le dossier GoogleEarth afin de remplacer ceux que vous avez déplacés.

 

Si Google Earth Pro se bloque malgré tout au démarrage, il est possible que votre ordinateur présente un autre problème. Essayez de désinstaller complètement Google Earth et de réinstaller l'application.