Navigate around the world on your computer

Check out mountains, hills, landmarks, and underwater scenery with the 3D viewer in Google Earth. You can zoom in and out and tilt or rotate the view to look around.

Navigate with your mouse

Look in any direction
  1. Press and hold the Left mouse button.
  2. Drag until you see the view you want.
Zoom in and out

You can zoom in and out several ways.

Double-click on the globe

  • Zoom in: Put your cursor on the globe and double-click your left mouse button. Keep double-clicking to zoom in more.
  • Zoom out: Double-click your right mouse button. Keep double-clicking to zoom out more.

Press and hold the right mouse button

  1. Position the cursor on the globe.
  2. Press and hold the right mouse button. The cursor will change to a double arrow pointing up and down.
  3. Move the mouse toward you to zoom in or push it away to zoom out.
  4. Release the right mouse button. The cursor will change to the open hand cursor.

Use the scroll wheel

Zoom in by scrolling the mouse wheel away from you. To zoom out, scroll the wheel away toward you.

Tilt and view hills and mountains

When you first start Google Earth, you’ll see a straight view of the globe. You can tilt in any direction.

Use the middle button

Press the middle button and move the mouse forward or back.

Use the scroll wheel

Press the Shift key and scroll forward or backward to tilt up or down.

Use the left mouse button on Windows & Linux

Press Shift+Left mouse button and drag in any direction.

Adjust the elevation settings
  1. Click Tools > Options > 3D View on Windows or Google Earth > Preferences > 3D View on Mac.
  2. Under “Terrain,” enter a number in the box for “Elevation Exaggeration.” You can set the value to any number from .01 to 3.
  3. Click Apply.

Note: A common setting is 1.5, which shows an obvious yet natural elevation. Learn more about how to change 3D viewing, touring, and other viewing preferences.

Explore the ocean

Visit sea floors, deep ocean trenches, and other underwater terrain.

To hide or show the surface of the ocean, click View > Water Surface. You can see from above or below the water’s surface.

Navigate with the tools and compass

You can use the navigation controls and mouse or trackpad to navigate.

Show & hide the navigation controls

The navigation controls are in the upper right corner of the map and fade when you aren’t using them. Mouse over them to make them appear.

If you don’t see the navigation controls at all, go to the top menu bar and click View > Show Navigation > Automatically. Then, try again.

Show & hide the compass
  1. To show or hide the compass, in the top menu bar, click View > Show Navigation.
  2. Choose the setting you want:
    • Automatically
    • Always
    • Compass Only
    • Never
Rotate the globe or pan
  1. Put your cursor over one of the arrows in the compass.
  2. Left-click and hold the button on your mouse or trackpad.
  3. Release the button when you’ve reached the part of the world you want to see.
Zoom in and out

Put your cursor over the + or - button on the navigation tools and hold the left mouse button to zoom in or out.

You can also click the slider and drag it up or down to adjust the zoom more slowly.

Navigate with shortcut keys

Use your keyboard to navigate the globe using Google Earth.

Go to the default view

You can return the globe to point north or set it to its original position any time.

Point the view North

In the top right corner of the screen on the compass, click the North button. The compass and globe will both return to a north-facing view.

Go back to default view

On computers, click the map and press R.

Pick a start location

You can set the starting location that appears each time you launch Google Earth or search for a place.

Set a default start location

  1. Go to the location you want to set up for your start location.
  2. Rotate, tilt, and zoom in until you have the view you want.
  3. In the top menu bar, click View > Make this my start location.

Search for a place

Find places or things to do using the Search box.