Импорт данных с GPS-устройств

Если у вас есть GPS-устройство, можно подключить его к компьютеру, чтобы импортировать путевые точки и треки в Google Планете Земля. Это позволить вам просматривать GPS-данные в Google Планете Земля.

Выберите любую из ссылок ниже для получения дополнительных сведений:

Поддерживаемые GPS-устройства

В настоящее время Google Планета Земля поддерживает большинство устройств от компаний Garmin и Magellan, а также Wintec WBT-201.

На веб-сайте GPSBabel перечислены одобренные устройства, с которых можно импортировать GPS-данные в Google Планете Земля. Можно пытаться использовать и другие, не включенные в данный список устройства, однако все неполадки, или же, наоборот, их бесперебойная работа, к Google никак относиться не будут.

При использовании неподдерживаемого устройства можно попробовать импортировать данные GPS из устройства на компьютер в виде файла .gpx или .loc, а затем открыть его в Google Планете Земля. См. раздел Импорт существующих GPS-данных.

Необходимые средства подключения

GPS-устройство можно подключить к компьютеру через последовательный или USB-порт. В комплектацию большинства GPS-устройств обычно входит какой-либо из необходимых для подключения кабелей. Если кабель к устройству не прилагался, его можно приобрести отдельно на веб-сайте производителя.

Сведения о точках GPS

Процессом импорта GPS-данных в Google Планете Земля можно управлять. Когда в Google Планету Земля импортируются GPS-данные, в диалоговом окне необходимо указать, что именно нужно импортировать: треки, путевые точки, маршруты или все перечисленное.

  • Треки. Треки – это точки с координатами, которые автоматически записывает GPS-устройство во время ваших путешествий.
  • Путевые точки. Координаты путевых точек пользователь вводит самостоятельно. Обычно их помечают такими надписями, как "дом", "разворот".
  • Маршруты. С помощью точек маршрута GPS-устройство указывает путь от одной записанной точки до другой. Точки маршрута могут иметь несколько инструкций следования, в Google Планете Земля их можно импортировать в виде путей.

Импорт GPS-данных

Существует два способа импорта GPS-данных в Google Планете Земля:

  • импорт существующего файла GPS-данных;
  • импорт данных непосредственно из GPS-устройства.
Чтобы после выполнения импорта сохранить GPS-данные, перенесите их в папку "Мои метки", прежде чем закрывать Google Планета Земля.

Импорт существующих файлов GPS-данных

Импорт существующих файлов GPS-данных любого поддерживаемого типа (включая GPX, Garmin GDB, файлы log, используемые NMEA, и другие) возможен следующими способами.

  • Выберите Файл > Открыть..., укажите файл данных и нажмите кнопку "Открыть".
  • Для импорта любого из вышеперечисленных типов файла их необходимо просто перетащить в Google Планету Земля.
  • Выберите Инструменты > GPS и нажмите кнопку "Импорт из файла". Найдите файл и нажмите кнопку "Открыть".

В этом диалоговом окне при импорте GPS-данных можно выбрать способ их отображения.

Параметры "Создать KML-треки" и "Скорректировать высоту по высоте земной поверхности" выбраны по умолчанию.

  • Создать треки KML

    Чтобы данные отображались в виде трека, необходимо выбрать параметр "Создать треки KML". Трек – это линия, полученная с помощью GPS-данных, в которой также содержатся сведения о времени. Если в исходных данных была соответствующая информация, в трек могут быть записаны данные с других датчиков: например, частота сердечного ритма, частота педалирования, температура и мощность. Кроме того, в параметрах трека можно настроить значок.

    Настоятельно рекомендуем воспользоваться треками при просмотре данных в Google Планете Земля 5.2 или более поздней версии. Кроме того, треки лучше всего подходят для работы с профилем рельефности, функцией, появившейся в версии 5.2. Подробнее о GPS-треках.

  • Создать объект LineString формата KML

    Выберите параметр "Создать объект LineString формата KML", чтобы отобразить GPS-данные в виде объектов LineString. Этот способ лучше всего подходит для импорта данных в Карты Google или другие средства просмотра данных в формате KML. LineString – это строка GPS-данных, с которыми не связан элемент времени. Таким образом становится возможным просмотр отдельных точек, составляющих трек. Впрочем, в точках сведения о времени указываются.

    Подобный вариант обработки данных хоть и сохраняет сведения о высоте и местоположении над уровнем моря, однако доступ к этой информации возможен только из каждой отдельной точки, а не всей линии.

  • Скорректировать высоту по высоте земной поверхности

    Чтобы сохраненные точки соответствовали уровню земной поверхности (например, при импорте трека пешего, автомобильного или велосипедного маршрута), выберите параметр "Скорректировать высоту по высоте земной поверхности". Однако если GPS-трек был записан во время полета (например, на дельтаплане или самолете), этот параметр нужно отключить, чтобы точки отображались как надземные.

Импорт данных из GPS-устройства

Импортировать данные из GPS-устройства в Google Планету Земля очень просто.

  1. Если для работы устройства необходимы драйверы, убедитесь, что они установлены. Чтобы использовать USB-устройство Garmin на компьютере с ОС Windows, установите соответствующий драйвер с компакт-диска, поставляемого вместе с GPS-устройством, или загрузите драйвер с веб-сайта производителя.
  2. Подключите GPS-устройство к компьютеру с включенным приложением Google Планета Земля с помощью последовательного или USB-порта, прилагавшегося к устройству. Подключая GPS-устройство к компьютеру, убедитесь, что оно выключено.
  3. Включите GPS-устройство. После включения и активации устройства необязательно ждать, пока оно подключится к спутникам.
  4. В меню "Инструменты" выберите GPS. Откроется окно "Импорт GPS".


  5. В разделе Устройство выберите производителя вашего GPS-устройства. Если вы импортируете данные из файла, выберите "Импорт из файла". Подробнее см. разделИмпорт существующих файлов GPS-данных.
  6. В разделе Импортировать выберите типы импортируемых данных. Рекомендуем использовать настройки по умолчанию, оставляя выбранными все три типа. Таким образом импортироваться будут сразу все GPS-данные.
  7. В разделе Выход выберите параметр отображения GPS-треков: "KML-треки" или "KML LineString". Подробнее см. разделы KML-треки и KML LineString.
  8. Чтобы сохраненные точки соответствовали уровню земной поверхности (например, при импорте трека пешего, автомобильного или велосипедного маршрута), выберите параметр Скорректировать высоту по высоте земной поверхности. Однако если GPS-трек был записан во время полета (например, на дельтаплане или самолете), этот параметр нужно отключить, чтобы точки отображались как надземные.
  9. Нажмите Импортировать. После загрузки GPS-данных в Google Планете Земля появится диалоговое окно подтверждения.
Совет. Если на процесс импортирования данных уходит слишком много времени, рекомендуем настроить GPS-устройство на менее частые замеры. Это можно сделать на большем количестве GPS-приемников. Уменьшив частоту сбора данных вы получите меньшее количество координатных точек за то же период времени.

Данные появятся на вкладке Метки под обозначением GPS-устройство. В папке GPS-устройство будут отображаться все GPS-данные, рассортированные по отдельным папкам в зависимости от их типа (см. рисунок ниже).

Папки можно раскрывать, а их содержимое – просматривать, организовывать, изменять, открывать для общего доступа и сохранять. Если при импорте данных в качестве параметра выхода выбрать одновременно "KML-треки" и "KML LineString", то данные можно будет найти в двух соответствующих папках в разделе Треки.

Примечание. Если при импорте данных вдруг появится сообщение об ошибке соединения, отключите GPS-устройство, включите его снова и вернитесь к выполнению Шага 4.

GPS-слежение в режиме реального времени

Если подключить GPS-устройство к ноутбуку, можно просматривать GPS-данные в режиме реального времени. Например, отправившись в путешествие с ноутбуком и GPS-устройством, в Google Планете Земля можно следить за ходом поездки. Для этого выполните следующие действия.

  1. Подключите GPS-устройство к ноутбуку (см. шаги 1–4 раздела Импортирование данных из устройства GPS.
  2. В диалоговом окне GPS откройте вкладку В реальном времени.
  3. Выберите соответствующие параметры:
    • Выберите протокол. Если вы не знаете, какой протокол использовать, укажите NMEA.
    • Ограничение импорта точек трека. Данный параметр отвечает за количество сохраненных и отображенных на экране точек. Чем меньше точек, тем выше скорость передачи данных и ниже точность прорисовки маршрута, и наоборот.
    • Интервал опроса (с) Данный параметр указывает на частоту, с которой Google Планета Земля опрашивает GPS-устройство.
    • Автоматически следовать этому пути. Установите соответствующий флажок, чтобы в центре окна 3D-просмотра отображалось отслеживание текущего трека GPS в реальном времени.
  1. Нажмите Пуск. Теперь GPS-данные будут отслеживаться в режиме реального времени.