System requirements and browsers

To use the latest Google Drive app, you'll need iOS 12 or later.

To use the latest Google Docs, Sheets and Slides apps, you'll need iOS 12 or later.

Check which version of iOS you're using

  1. On your iPhone or iPad, open Settings.
  2. Tap General and then About.
  3. Next to 'Version', you'll see which version of iOS you're using.

Download the Google Drive, Docs, Sheets or Slides app

Note: Make sure that all apps are updated to the latest version by tapping the links above. 

Was this helpful?
How can we improve it?