System requirements and browsers

The following operating systems and browsers are supported for Google Drive and the Docs editors. If you see some unexpected behavior, you may want to switch to a supported operating system and browser, and enable cookies and JavaScript on your browser.

Operating system requirements

Windows

  • Windows Vista
  • Windows XP
  • Windows 7
  • Windows 8

Mac

  • Mavericks (10.9)
  • Mountain Lion (10.8)
  • Lion (10.7)

To see which version your computer is using, choose an option below.

Linux

Google Drive isn't currently available for the Linux operating system. Linux users can still access Google Drive on the web at drive.google.com or through the Google Drive mobile app.

Mobile devices and tablets

To use the mobile apps after May 31, 2014, you'll need to upgrade to the most recent versions of the Android and iOS operating systems on your mobile device.

  • Android 4.0+
  • iOS 7.0+

Users on the following outdated mobile operating systems will be able to view, but not edit, their files. We encourage these users to upgrade to the versions above if possible.

Browser requirements

You can use Google Drive and the Docs editors if you have enabled cookies and JavaScript in your browser. You must also have one of the two most recent versions of the following browsers:

  • Chrome
  • Firefox
  • Safari (not supported on Windows)
  • Internet Explorer

Other browsers may work with the Google Docs editors but you may not be able to use all of the features available in the browsers listed above.