Как сортировать и фильтровать данные


               

Вашему бизнесу требуются расширенные функции Google Workspace?

Попробуйте Google Workspace уже сегодня

Вы можете сортировать данные в алфавитном или числовом порядке, а также скрывать информацию с помощью фильтров.

Sort and Filter Your Data

Нажмите "Создать копию" ниже, чтобы получить образец таблицы и тренироваться во время просмотра видео.

Создать копию

Как отсортировать данные в алфавитном или числовом порядке

  1. Откройте файл в Google Таблицах на компьютере.
  2. Выделите ячейки, которые нужно упорядочить.
  3. Если на листе есть строка заголовка, закрепите ее.
  4. Нажмите Данные > Сортировать диапазон > Расширенные настройки сортировки диапазонов.
  5. Если у столбцов есть заголовки, установите флажок Данные со строкой заголовка.
  6. Укажите столбец, в котором вы хотите выполнить сортировку в первую очередь, и выберите нужный порядок.
    • При необходимости нажмите Добавить ещё один столбец для сортировки.
  7. Нажмите Сортировать.

Как сортировать данные на всем листе

  1. Откройте файл в Google Таблицах на компьютере.
  2. В верхней части страницы нажмите правой кнопкой мыши на букву, относящуюся к нужному столбцу.
  3. Выберите Сортировать лист А–Я или Сортировать лист Я–А.

Сортировка по цвету

  1. Откройте файл в Google Таблицах на компьютере.
  2. Выделите диапазон ячеек.
  3. Выберите Данные затем Создать фильтр.
  4. Чтобы увидеть доступные фильтры, нажмите на значок фильтра Фильтр в первой строке диапазона.
    • Сортировать по цвету: выберите, по какому цвету текста или заливки нужно отфильтровать или отсортировать данные. Ячейки с указанным вами цветом переместятся в верхнюю часть диапазона. Сортировку можно выполнять по условным, но не по альтернативным цветам.
  5. Если фильтр вам больше не нужен, нажмите Данные > Удалить фильтр.

Как фильтровать данные

Внимание! Добавленный фильтр будут видеть все пользователи, которым доступна таблица. Изменить его смогут все, кому разрешено редактировать таблицу.

  1. Откройте файл в Google Таблицах на компьютере.
  2. Создайте фильтр одним из указанных ниже способов:
    • Выберите диапазон ячеек и вверху экрана нажмите Данные затем Создать фильтр.
    • Нажмите на ячейку или диапазон ячеек правой кнопкой мыши и выберите Создать фильтр.
  3. Чтобы увидеть доступные фильтры, нажмите на значок "Фильтр" Список фильтров.
    • Фильтровать по условию. Выберите условия из списка или введите собственные формулы.

      Примеры собственных формул

      Чтобы найти в диапазоне данных уникальные значения:
      • Выберите Ваша формула.
      • Введите =СЧЁТЕСЛИ(диапазон_данных, диапазон_данных)=1.
      Чтобы найти в диапазоне данных совпадения со словом "Хорошо" или "Отлично":
      • Выберите Ваша формула.
      • Введите =ИЛИ(REGEXMATCH(диапазон_данных, "Хорошо"), REGEXMATCH(диапазон_данных, "Отлично")).
    • Фильтровать по значению. Чтобы скрыть элемент, снимите флажок рядом с ним и нажмите ОК.
      • Чтобы создать фильтр и отфильтровать данные по значению ячейки, нажмите на нужную ячейку правой кнопкой мыши и выберите Фильтр по значению ячейки.
    • Поиск. Чтобы найти нужное значение, введите запрос в строку поиска.
    • Фильтровать по цвету. Выберите, по какому цвету текста или заливки нужно отфильтровать данные. Сортировку можно выполнять по условным, но не по альтернативным цветам.
  4. При необходимости удалите фильтр одним из указанных ниже способов:
    • Нажмите Данные затем Удалить фильтр.
    • Нажмите на нужную ячейку правой кнопкой мыши и выберите Удалить фильтр.

После фильтрации данных в правом нижнем углу экрана будет приведена информация о том, сколько показано строк от их общего количества в таблице.

Как создать, сохранить, удалить или передать режим фильтрации

Внимание! Если у вас есть разрешение только на просмотр таблицы, вы можете создать временный режим фильтрации, который будет доступен исключительно вам. Этот режим не сохранится.

На компьютере фильтры можно использовать таким образом, чтобы отфильтрованные данные были видны только вам. Изменения режима фильтрации сохраняются автоматически.

  1. Откройте файл в Google Таблицах на компьютере.
  2. Выберите Данные затем Фильтры > Создать новый фильтр.
  3. Отсортируйте и отфильтруйте данные.
  4. Чтобы выйти из режима фильтрации, в правом верхнем углу экрана нажмите на значок "Закрыть" Закрыть.
  5. Заданные настройки сохранятся автоматически.

Чтобы удалить или скопировать режим фильтрации, нажмите на значок настроек Настройки > Удалить или Создать копию.

Если вам нужно удалить все фильтры, откройте каждый режим фильтрации, а затем нажмите на значок настроек НастройкизатемУдалить.

Примечание. Изменять порядок режимов фильтрации нельзя.

Как посмотреть существующий режим фильтрации

Внимание! Применять несколько режимов фильтрации одновременно нельзя.

  1. Откройте файл в Google Таблицах на компьютере.
  2. Нажмите Данные затем Фильтры.
  3. Выберите режим фильтрации.
  4. Он будет применен к таблице.
  5. Чтобы выйти из режима фильтрации, в правом верхнем углу экрана нажмите на значок "Закрыть" Закрыть.

Как сохранить фильтр в качестве режима фильтрации

  1. Откройте файл в Google Таблицах на компьютере.
  2. Примените фильтр.
  3. Выберите Данные затем Фильтры > Сохранить как фильтр.

Как переименовать режим фильтрации

  1. Откройте файл в Google Таблицах на компьютере.
  2. Нажмите Данные затем Фильтры.
  3. Выберите режим фильтрации.
  4. В левом верхнем углу таблицы рядом с пунктом "Название" нажмите на название фильтра и укажите новое название.
  5. Нажмите клавишу "Ввод".
Как передать или отправить ссылку на режим фильтрации
  1. On your computer, open a spreadsheet in Google Sheets.
  2. Apply the filter view .
  3. Copy the URL.
  4. Share the filter view link.

Дополнительные сведения о фильтрах и режимах фильтрации

Фильтры и режимы фильтрации обеспечивают более удобную работу с данными таблицы.

Что позволяют делать фильтры:

  • показывать другим пользователям, открывающим таблицу, отфильтрованные данные;
  • выполнять сортировку данных.

Что позволяют делать режимы фильтрации:

  • сохранять группы фильтров;
  • давать фильтрам названия;
  • давать другим пользователям возможность одновременно работать с разными режимами фильтрации;
  • делиться фильтрами с другими пользователями;
  • копировать режимы фильтрации и создавать новые с похожими критериями;
  • фильтровать и сортировать данные в таблице при отсутствии прав на редактирование (в этом случае создается временный режим фильтрации).

 

 

true
Посетите Центр обучения

Используете продукты Google (например, Google Документы) на работе или в учебном заведении? Мы подготовили для вас полезные советы, руководства и шаблоны. Узнайте, как работать с файлами Office, не устанавливая MS Office, как создавать динамические планы проектов и командные календари, использовать автосортировку писем и решать другие задачи.

Поиск
Очистить поле поиска
Закрыть поиск
Приложения Google
Главное меню
13766724856295283812
true
Поиск по Справочному центру
true
true
true
true
true
35