Как сортировать и фильтровать данные

Чтобы использовать Google Документы на работе или в учебном заведении более эффективно, оформите бесплатную подписку на Google Workspace.

Вы можете сортировать данные в алфавитном или числовом порядке, а также скрывать информацию с помощью фильтров.

Sort and Filter Your Data

Нажмите "Создать копию" ниже, чтобы получить образец таблицы и тренироваться во время просмотра видео.

Создать копию

Как отсортировать данные в алфавитном или числовом порядке

  1. Откройте файл в Google Таблицах на компьютере.
  2. Выделите ячейки, которые нужно упорядочить.
  3. Если на листе есть строка заголовка, закрепите ее.
  4. Нажмите Данные > Сортировать диапазон > Расширенные настройки сортировки диапазонов.
  5. Если у столбцов есть заголовки, установите флажок Данные со строкой заголовка.
  6. Укажите столбец, в котором вы хотите выполнить сортировку в первую очередь, и выберите нужный порядок.
    • При необходимости нажмите Добавить ещё один столбец для сортировки.
  7. Нажмите Сортировать.

Как сортировать данные на всем листе

  1. Откройте файл в Google Таблицах на компьютере.
  2. В верхней части страницы нажмите правой кнопкой мыши на букву, относящуюся к нужному столбцу.
  3. Выберите Сортировать лист А–Я или Сортировать лист Я–А.

Сортировка по цвету

  1. Откройте файл в Google Таблицах на компьютере.
  2. Выделите диапазон ячеек.
  3. Выберите Данные затем Создать фильтр.
  4. Чтобы увидеть доступные фильтры, нажмите на значок фильтра Фильтр в первой строке диапазона.
    • Сортировать по цвету: выберите, по какому цвету текста или заливки нужно отфильтровать или отсортировать данные. Ячейки с указанным вами цветом переместятся в верхнюю часть диапазона. Сортировку можно выполнять по условным, но не по альтернативным цветам.
  5. Если фильтр вам больше не нужен, нажмите Данные > Удалить фильтр.

Как фильтровать данные

Внимание! Добавленный фильтр будут видеть все пользователи, которым доступна таблица. Изменить его смогут все, кому разрешено редактировать таблицу.

  1. Откройте файл в Google Таблицах на компьютере.
  2. Выделите диапазон ячеек.
  3. Выберите Данные затем Создать фильтр.
  4. Чтобы увидеть доступные фильтры, нажмите на значок фильтра Фильтр в первой строке диапазона.
    • Фильтровать по условию: выберите условия из списка или введите собственные.
    • Фильтровать по значению: чтобы скрыть элемент, снимите флажок рядом с ним и нажмите "ОК".
    • Поиск: введите запрос в окне поиска.
    • Фильтровать по цвету: выберите, по какому цвету текста или заливки нужно отфильтровать данные. Сортировку можно выполнять по условным, но не по альтернативным цветам.
  5. Если фильтр вам больше не нужен, нажмите Данные > Удалить фильтр.

Как создать, сохранить, удалить или передать режим фильтрации

Внимание! Если у вас есть разрешение только на просмотр таблицы, вы можете создать временный режим фильтрации, который будет доступен исключительно вам. Этот режим не сохранится.

На компьютере фильтры можно использовать таким образом, чтобы отфильтрованные данные были видны только вам. Изменения режима фильтрации сохраняются автоматически.

  1. Откройте файл в Google Таблицах на компьютере.
  2. Выберите Данные затем Фильтры > Создать новый фильтр.
  3. Отсортируйте и отфильтруйте данные.
  4. Чтобы выйти из режима фильтрации, в правом верхнем углу экрана нажмите на значок "Закрыть" Закрыть.
  5. Заданные настройки сохранятся автоматически.

Чтобы удалить или скопировать режим фильтрации, нажмите на значок настроек Настройки > Удалить или Создать копию.

Если вам нужно удалить все фильтры, откройте каждый режим фильтрации, а затем нажмите на значок настроек НастройкизатемУдалить.

Примечание. Изменять порядок режимов фильтрации нельзя.

Как посмотреть существующий режим фильтрации

Внимание! Применять несколько режимов фильтрации одновременно нельзя.

  1. Откройте файл в Google Таблицах на компьютере.
  2. Нажмите Данные затем Фильтры.
  3. Выберите режим фильтрации.
  4. Он будет применен к таблице.
  5. Чтобы выйти из режима фильтрации, в правом верхнем углу экрана нажмите на значок "Закрыть" Закрыть.

Как сохранить фильтр в качестве режима фильтрации

  1. Откройте файл в Google Таблицах на компьютере.
  2. Примените фильтр.
  3. Выберите Данные затем Фильтры > Сохранить как фильтр.

Как переименовать режим фильтрации

  1. Откройте файл в Google Таблицах на компьютере.
  2. Нажмите Данные затем Фильтры.
  3. Выберите режим фильтрации.
  4. В левом верхнем углу таблицы рядом с пунктом "Название" нажмите на название фильтра и укажите новое название.
  5. Нажмите клавишу "Ввод".
Как передать или отправить ссылку на режим фильтрации
  1. On your computer, open a spreadsheet in Google Sheets.
  2. Apply the filter view .
  3. Copy the URL.
  4. Share the filter view link.

Дополнительные сведения о фильтрах и режимах фильтрации

Фильтры и режимы фильтрации обеспечивают более удобную работу с данными таблицы.

Что позволяют делать фильтры:

  • показывать другим пользователям, открывающим таблицу, отфильтрованные данные;
  • выполнять сортировку данных.

Что позволяют делать режимы фильтрации:

  • сохранять группы фильтров;
  • давать фильтрам названия;
  • давать другим пользователям возможность одновременно работать с разными режимами фильтрации;
  • делиться фильтрами с другими пользователями;
  • копировать режимы фильтрации и создавать новые с похожими критериями;
  • фильтровать и сортировать данные в таблице при отсутствии прав на редактирование (в этом случае создается временный режим фильтрации).

 

 

Эта информация оказалась полезной?
Как можно улучшить эту статью?
true
Посетите Центр обучения

Используете продукты Google (например, Google Документы) на работе или в учебном заведении? Мы подготовили для вас полезные советы, руководства и шаблоны. Узнайте, как работать с файлами Office, не устанавливая MS Office, как создавать динамические планы проектов и командные календари, использовать автосортировку писем и решать другие задачи.

Поиск
Удалить поисковый запрос
Закрыть поиск
Приложения Google
Главное меню
Поиск по Справочному центру
true
35
false
false