Edit documents with a screen reader

Once you've turned on screen reader support for Google Docs editors on the web, you can start editing documents.

When you open a document, your focus is at the beginning of the main editing area. You'll hear spoken feedback as you type or navigate through the document.

To navigate quickly through the document, you can use the "Next" and "Previous" shortcuts:

  • The "Next" shortcut lets you move your focus forward to the next item by pressing Ctrl + Alt + n (Windows) or Ctrl + ⌘ + n (Mac) followed by another key. For example, press Ctrl + Alt + n then h to move to the next heading.
  • The "Previous" shortcut lets you move your focus backward to the previous item by pressing Ctrl + Alt + p (Windows) or Ctrl + ⌘ + p (Mac) followed by another key. For example, press Ctrl + Alt + p then h to move to the previous heading.

For a full list, refer to Docs keyboard shortcuts.

Search the menus

To do things quickly in Docs, you can search the menus. Press Alt + / (Windows, Chrome OS) or Option + / (Mac) to start a menu search.

Once your focus is in the search box, type a command, such as "Rename" or "Insert." Press the down arrow to hear search results. For example, if you type "Insert," the options include inserting an image, a comment, and other choices. Press Enter to apply an action.

Keyboard shortcuts

Because Docs is different from a typical website, some standard screen reader shortcuts don't apply. For the best experience, use Docs shortcuts while editing your document.

If you ever forget a shortcut, you can open a list of shortcuts within Docs by pressing Ctrl + / (Windows, Chrome OS) or ⌘ + / (Mac). Along with a list of shortcuts, the dialog has a link to view all shortcuts in the Help Center. To close the dialog, press Escape.

Application menus, top-level buttons, and toolbar

To browse the application menus, start with the File menu. Press Alt + f (Chrome on Windows, Chrome OS), Alt + Shift + f (Windows), or Ctrl + Option + f (Mac). Press the right arrow to navigate to other application menus, including Edit, View, Insert, Format, Tools, Table, Add-ons, and Help.

If you're using VoiceOver on Mac: To go to to the application menus, first use the pass-through key combination Ctrl + Option + Tab, then type the menu shortcut, such as Ctrl + Option + f for the File menu.

From the application menus, you can navigate to two other sets of controls:

  • Press Shift + Tab to go to the top-level buttons. These buttons are for document-level actions, such as renaming, starring, sharing, or moving the document to a different folder.
  • Press Tab to go to the toolbar. The toolbar has editing and formatting tools, such as heading styles, lists, and indentation.

Note: In compact mode, the top-level buttons and application menus are hidden. To turn compact mode on or off, press Ctrl + Shift + f (Windows, Chrome OS, or Mac).

Accessibility menu

If you've turned on screen reader support for the Docs editors, the application menu bar includes an Accessibility menu with shortcuts for navigating and reading your document.

To open the Accessibility menu, press Alt + a (Chrome on Windows, Chrome OS), Alt + Shift + a (Windows), or Ctrl + Option + a (Mac). Press the down arrow to hear options, such as Speak, Comments, Link, Table, and more. Press the right arrow to open a sub-menu, and press Enter to select an option.

Help documentation

To find help documentation, open the Help menu in the application menu bar and select Docs Help. Press Tab to reach the search box, then type a search term, such as "Images," and press Enter. The help opens in a dialog where you can read or navigate to other topics. To dismiss the dialog and return to the document, press Escape.

You can also open the Docs editors Help Center in a new tab or window and search or browse for more information.

Editing and formatting basics

To insert an object in your document, such as an image, table, or footnote, first place the cursor where you'd like to make the insertion. Press Alt + / (Windows, Chrome OS) or Option + / (Mac) to search the menus, then type "insert" to get a list of options to insert. Use the arrow keys to explore the list, and press Enter to make your selection.

To announce the text or paragraph formatting at your cursor's current location, press Ctrl + Alt + a then f (Windows, Chrome OS) or Ctrl + ⌘ + a then f (Mac).

To explore the formatting styles that you can apply, open the Format menu in the application bar. You can also use Docs keyboard shortcuts to change styles.

To clear formatting for selected text, press Ctrl + \ (Windows) or ⌘ + \ (Mac).

Learn more about how to create, edit, and format documents.

Spell-check a document

Docs automatically detects misspellings in your document. To go to the next misspelling, press Ctrl + apostrophe (Windows, Chrome OS) or ⌘ + apostrophe (Mac). To go to the previous misspelling, press Ctrl + semicolon (Windows, Chrome OS) or ⌘ + semicolon (Mac).

To correct a misspelling, open the context menu by pressing Ctrl + Shift + x (Windows, Chrome OS) or ⌘ + Shift + x (Mac). From the context menu, select the correctly spelled suggestion, and press Enter.

You can also use the spell-check tool. From the the Tools menu in the application menu bar, select Spelling. For each misspelling, you can either change it, ignore it, or add it to the dictionary. Learn more about spell-check and automatic corrections.

Add alternative text for an image or drawing

To add or edit alternative text (alt text), follow these steps:

  1. Select the image or drawing.
  2. Open the Format menu in the application menu bar.
  3. Select Alt text.
  4. In the Alt text dialog, enter a description for the image or drawing, then select Enter.

Find and replace text

To perform a quick search within your document, press Ctrl + f (Windows) or ⌘ + f (Mac). Results are found immediately as you type. Press Enter to continue searching through the document.

To find and replace text, press Ctrl + h (Windows, Chrome OS) or ⌘ + Shift + h (Mac) to open the Find and replace dialog. Enter the text you want to locate in the "Find" field, and enter the text you want to replace it with in the "Replace with" field. The buttons in this dialog include Replace, Replace all, Previous, and Next.

Press Escape to exit the dialog. To resume your search, press Ctrl + h (Windows, Chrome OS) or ⌘ + Shift + h (Mac) again to reopen the dialog.

Mary is a Docs & Drive expert and author of this help page. Leave her feedback below about the page.

Was this article helpful?