Edit spreadsheets with a screen reader

Once you've turned on screen reader support for Google Docs editors on the web, you can start editing spreadsheets.

When you open a spreadsheet, your focus is in the first cell. As you move through the spreadsheet, the screen reader announces each cell's address and contents. For example, if cell C4 contains "New York City," the screen reader reads "New York City C4."

You can move around the spreadsheet with the arrow keys and other Sheets shortcuts. For example, use shortcut keys to move between data regions:

  1. To move to the next data region in any direction, hold Ctrl (Windows, Chrome OS) or (Mac) and press the up, down, right or left arrow.
  2. If you start in a cell that has data, you'll jump to the next empty cell. If you start in an empty cell, you'll move you to the next cell that has data. If all cells in the specified direction are empty, you'll move to the end of the row or column.

Keyboard shortcuts

Because Sheets is different from a typical website, some standard screen reader shortcuts don't apply. For the best experience, use the Sheets shortcuts while editing your spreadsheet.

If you ever forget a shortcut, you can open a list of shortcuts within Sheets by pressing Ctrl + / (Windows, Chrome OS) or ⌘ + / (Mac). Along with a list of shortcuts, the dialog has a link to view all shortcuts in the Help Center. To close the dialog, press Escape.

Application menus, top-level buttons, and toolbar

To browse the application menus, start with the File menu. Press Alt + f (Chrome on Windows, Chrome OS), Alt + Shift + f (Windows), or Ctrl + Option + f (Mac). Press the right arrow to navigate to other application menus, including Edit, View, Insert, Format, Data, Tools, Add-ons, and Help.

If you're using VoiceOver on Mac: To go to to the application menus, first use the pass-through key combination Ctrl + Option + Tab, then type the menu shortcut, such as Ctrl + Option + f for the File menu.

From the application menus, you can navigate to two other sets of controls:

  • Press Shift + Tab to go to the top-level buttons. These buttons are for spreadsheet-level actions, such as renaming, starring, sharing, or moving the document to a different folder.
  • Press Tab to go to the toolbar. The toolbar has editing and formatting tools, such as number formatting and alignment.

Note: In compact mode, the top-level buttons and application menus are hidden. To turn compact mode on or off, press Ctrl + Shift + f (Windows, Chrome OS, or Mac).

Accessibility menu

If you've turned on screen reader support for the Docs editors, the application menu bar includes an Accessibility menu with shortcuts for navigating and reading your spreadsheet.

To open the Accessibility menu, press Alt + a (Chrome on Windows, Chrome OS), Alt + Shift + a (Windows), or Ctrl + Option + a (Mac). Press the down arrow to hear options to Speak, Go to range, and Focus toolbar. Press the right arrow to open a sub-menu, and press Enter to select an option.

Help documentation

To find help documentation, open the Help menu in the application menu bar and select Sheets Help. Press Tab to reach the search box, then type a search term, such as "Formulas," and press Enter. The help opens in a dialog where you can read or navigate to other topics. To dismiss the dialog and return to the spreadsheet, press Escape.

You can also open the Docs editors Help Center in a new tab or window and search or browse for more information.

Editing and formatting basics

To edit the contents of a cell, press Enter on the focused cell. Type your changes, then press Enter to apply or Escape to cancel.

As you move through the spreadsheet, you'll hear relevant announcements about the contents of the cells. For example, the screen reader announces the following information if it's present in the cell:

  • Links. To follow a link, press Alt + Enter (Windows) or Option + Enter (Mac).
  • Notes. To add or edit a note on the focused cell, press Shift + F2 (Windows, Mac) or Shift + Search + 2 (Chrome OS). Your focus will be in an editable popup. When you finish typing your note, press Escape. To delete a note, delete all text within the note.
  • Data validation. You'll hear if a cell has invalid contents as a result of data validation.
  • Filtering. If you move from an unfiltered range of cells to a filtered range, you'll hear that you've entered a filtered region.

To determine the formatting of the focused cell, follow these steps:

  1. Open the Accessibility menu in the application menu bar.
  2. Select Speak.
  3. Press the down arrow to hear the different formatting options, then press Enter to select.

To explore all the formatting styles that you can apply, open the Format menu in the application menu bar. This menu includes number formatting, cell formatting, font styles, and more options. You can also use Sheets shortcuts to change formatting.

You can change the formatting for an entire cell or for specific parts of a cell. To change the formatting for an entire cell, select the cell. To change a specific part (for example, to make a single word bold), press Enter to edit the cell, then hold Shift and use the arrow keys to select the part that you'd like to format. Learn more about editing and formatting cells.

To clear formatting for the selected cell, press Ctrl + \ (Windows) or ⌘ + \ (Mac).

The sheet menu lets you perform a variety of actions on the active sheet, such as duplicate, copy, or rename. To use the sheet menu, follow these steps:

  1. Press Alt + Shift + s (Windows) or Option + Shift + s (Mac).
  2. Press the down arrow to navigate through the options, and press Enter to select.

Learn more about how to create, edit, and format spreadsheets.

Work with multiple sheets in a spreadsheet

To insert a new sheet, open the Insert menu in the application menu bar, then select New sheet. The new sheet is inserted after the current sheet, and the focus is in the new sheet.

To determine the names of other sheets, or to move from one sheet to another, press Alt + Shift + k (Windows, Chrome OS) or Option + Shift + k (Mac) to open a list of the sheets. Use the up and down arrows to navigate through the list. To select a sheet, press Enter. When a new sheet is activated you'll hear the name of the sheet. For example, if you move to Sheet 5, you'll hear that Sheet 5 is activated.

Select and work within a range of cells

To select a range of cells, go to the first cell that you'd like to include in the range. Hold Shift and use the arrow keys to select the desired range of cells.

Once a range is selected, you can use the following shortcuts to move your focus within the range:

  • Enter: Move from top to bottom.
  • Shift + Enter: Move from bottom to top.
  • Tab: Move from left to right.
  • Shift + Tab: Move from right to left.

With these shortcuts, your focus stays inside the selected range, allowing you to explore the range without moving too far in any direction.

You can also edit a cell without deselecting your range by pressing F2 (Windows, Mac) or Search + 2 (Chrome OS).

Select and work with columns and rows

To select columns or rows, go to a cell in the column or row that you'd like to select, then use the following shortcuts:

  • Select column: Press Ctrl + Space (Windows, Mac, Chrome OS).
  • Select row: Press Shift + Space.
  • Select additional rows or columns: Once the first row or column is selected, press Shift and the arrow keys to extend the selection.
Add rows or columns
  1. Select a cell where you'd like to add the new row or column.
    • To add multiple rows or columns at one time, start by selecting the same number of cells that as the number of rows or columns that you want to add. For example, to insert two rows at the top, first select one cell each in rows 1 and 2.
  2. Open the Insert menu in the application menu bar.
  3. Choose one of the options to insert rows or columns.
    • If you selected multiple cells in step 1, the Insert menu has options to insert multiple rows or columns.
Delete rows or columns
  1. Select one or more cells in the rows or columns that you want to delete. If you select multiple cells, you can delete multiple rows or columns at a time.
  2. Open the Edit menu in the application menu bar.
  3. Choose one of the options to delete rows or columns.
Move rows or columns
  1. Select a cell in the row or column that you want to move.
  2. Select a column (Ctrl + Space) or row (Shift + Space) that you want to move. To extend the selection to include multiple columns or rows, press Shift and the arrow keys.
  3. Open the Edit menu in the application menu bar.
  4. Choose one of the available options to move the columns or rows.
Hide rows or columns
  1. Select a cell in the row or column that you want to hide.
  2. Select a column (Ctrl + Space) or row (Shift + Space) that you want to hide. To extend the selection to include multiple columns or rows, press Shift and the arrow keys.
  3. Open the context menu by pressing Ctrl + Shift + \.
  4. Press the down arrow until you reach Hide column or Hide row, then press Enter.
Unhide rows or columns
  1. Select the columns or rows surrounding the hidden ones.
  2. Open the context menu by pressing Ctrl + Shift + \.
  3. Select Unhide columns or Unhide rows.
Freeze rows or columns

You can freeze up to ten rows or five columns in any sheet. Freezing rows and columns allows you to keep some of your data at the top or far left as you scroll through the rest of your spreadsheet.

To freeze or unfreeze rows or columns, open the View menu in the application menu bar and select Freeze rows or Freeze columns. Press the down arrow to hear the options from zero through 10, then press Enter to make a selection.

If you place your focus inside a frozen area, the screen reader announces that you're inside frozen rows or columns.

Formulas

You can add a formula to a cell by typing an equal sign (=) followed by the name of the function. You'll hear a read-out of the formula as you type.

To change or delete a formula, press Enter to edit the cell, then type your changes.

If there's an error in your formula, you'll hear an explanation of the error along with the cell contents.

If a cell contains a formula, you'll hear the value of the formula. To read formulas, there are several options:

  • Option 1: Press Enter to edit a cell and read its contents.
  • Option 2: Navigate to the formula bar by opening any application menu then tabbing to the formula bar. If the formula bar is hidden, open the View menu in the application menu bar and select Formula bar.
  • Option 3: Set a preference for a sheet to always view all formulas in the sheet. To turn this preference on or off, press Ctrl + back quote (`). You can also navigate to this preference in the View menu.

Learn more about functions and formulas in Sheets.

Work with charts, images, or drawings

Your spreadsheet can include information that's not part of the data grid, such as embedded charts, drawings, or images.

If you navigate to a cell that's covered by an embedded chart, image, or drawing, the screen reader announces that the cell is covered.

To work with these embedded objects, follow these steps:

  1. Open the Accessibility menu in the application menu bar.
  2. Press e to choose Select, then press the down arrow to browse the objects that you can select, such as charts, drawings, or images. Press Enter to select an object.
  3. The embedded object is now selected. From here, you can choose several options:
    • Press the arrow keys to move the object.
    • Press Tab to move to the options button, then press Enter to open the options menu. Press the down arrow to browse other actions that you can apply to the object, and press Enter to select.

Note: When a chart is selected in your spreadsheet, the screen reader announces the chart title, alt text (if present) and gives you the option to read a summary of the chart.

Learn more about adding charts and images to your spreadsheet.

Mary is a Docs & Drive expert and author of this help page. Leave her feedback below about the page.

Was this article helpful?