Supported browsers for Campaign Manager

Our general policy is to guarantee support for using the Campaign Manager interface for the most recent two versions of Chrome and Firefox. 

Note: Disable any ad blocking software installed on your browser before you use Campaign Manager. Otherwise, Campaign Manager may not work properly and you may not be able to test your tags.

Was this helpful?
How can we improve it?