フィルタを作成、編集、管理する

グラフまたは管理コンポーネントにフィルタを追加する

  1. レポートを編集します。
  2. フィルタを適用するグラフまたは管理コンポーネントを選択します。グラフや管理コンポーネントをグループ化したものにフィルタを適用することも可能です。
  3. プロパティ パネルで [データ] タブを選択します。
  4. [+ フィルタを追加] をクリックします。
  5. [新しいフィルタを作成] をクリックします。
    既存のフィルタを再使用することもできます。
  6. フィルタに [名前] を付けます。
  7. [一致条件] または [除外条件] を選択します。一致フィルタは、指定した式に一致するデータのみを含めます。除外フィルタは、式に一致するデータをすべて削除します。
  8. フィルタを適用するディメンションまたは指標を選択します。
  9. 比較演算子([次に等しい]、[含む]、[次の値より大きい] など)を選択します。
  10. 式の比較値を入力します。
  11. (省略可)OR 句を追加するには、指定した条件の右側にある [OR] をクリックします。
  12. (省略可)AND 句を追加するには、指定した条件の下にある [AND] をクリックします。
  13. [保存] をクリックします。

レポート全体またはページにフィルタを追加する

レポート全体の場合

ページの場合

[ファイル] > [レポート設定] メニューを選択します。

[ページ] > [現在のページの設定] メニューを選択します。

 

  1. [データ] タブをクリックします。
  2. [+ フィルタを追加] をクリックします。

残りの手順は上記と同様です。

フィルタを編集する

  1. レポートを編集モードに切り替えます。
  2. フィルタを適用しているグラフまたはフィルタ オプションを選択します。または上記の [現在のページの設定] や [レポートとテーマの設定] を使用することもできます。
  3. プロパティ パネルで [データ] タブを選択します。
  4. [編集] をクリックします。Edit icon

フィルタの編集と作成には、フィルタ マネージャも使用できます。

既存のフィルタを再使用する

レポートにフィルタを追加すると、そのフィルタは他のコンポーネントやレポートでも使用できるようになります。既存のフィルタをコンポーネントに追加することを「フィルタを再使用する」と表現します。フィルタを再使用してもフィルタのコピーは作成されません。同じフィルタが使用されるため、あるコンポーネントでフィルタを編集すると、そのフィルタはレポートのすべてのコンポーネントにおいて変更されます。

互換性がないデータソースを使用するグラフやフィルタ オプションにフィルタを再使用すると、そのグラフやフィルタ オプションにはエラーが表示されます。エラーを修正するには、フィルタを編集してどちらのデータソースにも共通するディメンションや指標を指定します。

フィルタが適用されたコンポーネントやレポートをコピーする

レポート内のページまたはコンポーネントのコピーを作成した場合、コピー先ではフィルタが再使用されます。

フィルタが適用されたコンポーネントを別のレポートにコピーした場合、新たにフィルタのコピーが作成されます。新たに作成されたフィルタは元のフィルタからは独立しています。コンポーネントをコピーして貼り付けるたびに新しいフィルタが作成され、それぞれのフィルタは関連性を持ちません。

レポートのコピーを作成してデータソースを変更した場合、そのレポートに含まれるすべてのフィルタが新しいデータソースを参照します。

フィルタを管理する

フィルタ マネージャを使うと、レポートに含まれるフィルタのリストを確認できます。このリストからフィルタを編集したり削除したりできます。また、フィルタ マネージャを使って新しいフィルタを作成することもできます。

フィルタ マネージャでフィルタを編集または作成する際に、フィルタで使用するデータソースを選択できます。既存のフィルタのデータソースを変更する場合、新しいスキーマが元のデータソースと一致しないと、フィルタが使用できなくなる場合があります。

フィルタ マネージャを表示するには:

  1. レポートを編集します。
  2. 上部のメニューの [リソース] > [フィルタの管理] をクリックします。
この情報は役に立ちましたか?
改善できる点がありましたらお聞かせください。

さらにサポートが必要な場合

問題を迅速に解決できるよう、ログインして追加のサポート オプションをご利用ください。