Supported Browsers

 

CS First works best in the newest and last prior version of these browsers:

Without the most up-to-date version of your browser, you’ll still be able to use CS First, but you may have problems using newer features. Each time a new browser version is released, we begin supporting that version and stop supporting the third most recent version.

Was this article helpful?
How can we improve it?

Need more help?

Sign in for additional support options to quickly solve your issue