Which browsers are supported?

GME currently supports Firefox 1.5+ and IE 6+.