Device requirements for Google endpoint management

The device requirements for Google endpoint management vary by feature. Unless noted, devices that don’t meet the minimum requirements can't synchronize work data.

Basic management

  • Android 2.2 Froyo and later with the latest version of the Google Play services app. Android 5.1.1 Lollipop and earlier devices need the Google Apps Device Policy app to enforce screen-lock requirements.
  • Apple® iOS® 8 and later or iPadOS 13.1 and later, with an Apple ID and Safari® enabled. Earlier devices can sync work data, but screen-lock requirements aren't enforced.

Advanced management

  • Android 2.2 and later. For devices with work profiles, Android 5.0 Lollipop and later. For user-owned devices that the user sets up as owned by the organization, Android 6.0 Marshmallow and later.
  • iOS 10.0 and later or iPadOS 13.1 and later, with an Apple ID and Safari enabled
  • (G Suite only) Devices that use Microsoft® Exchange ActiveSync® 12.1 (such as Windows Phone® 7 and 8 and BlackBerry® 10)

App management

  • Android 5.0 Lollipop and later devices with a work profile
  • Android 2.2 to 4.4.4 KitKat devices without a work profile
  • iOS 10.0 and later or iPadOS 13.1 and later

Work profiles

  • Android 5.0 and later (supported on most devices—to confirm, contact the device manufacturer)

Company-owned devices

  • Android 6.0 Marshmallow and later 
  • Devices running Chrome OS
  • Mac® 
  • Windows®
Was this helpful?
How can we improve it?