Visualizzare gli errori di provisioning automatico degli utenti

In qualità di amministratore, mentre configuri il provisioning degli utenti puoi riscontrare i seguenti errori:

Di seguito è indicato come eseguire il debug e risolvere questi errori.

Nota. Se dopo che hai eseguito la procedura di risoluzione l'errore non viene risolto, contatta l'assistenza.

Errori in fase di configurazione

I seguenti errori sono relativi alla configurazione del provisioning degli utenti e vengono visualizzati nella Console di amministrazione.

Errore di codice di autorizzazione

Questo errore viene visualizzato quando non è stato possibile cambiare il codice di autorizzazione con un token di aggiornamento. Ciò può verificarsi se il codice di autorizzazione era errato o se si attende troppo a lungo tra l'autorizzazione e il fare clic su Salva modifiche. L'errore dovrebbe risolversi riautorizzando e salvando le modifiche.

Messaggio di errore Risoluzione
Non è stato possibile generare il token di autorizzazione. Prova a ripetere l'autorizzazione e salva di nuovo le modifiche.

Errore di pagina obsoleta

Gli errori di pagina non aggiornata si verificano quando la pagina del browser non è stata aggiornata e la configurazione è cambiata al di fuori della sessione del browser (in un'altra finestra del browser o da un altro utente). Di seguito sono elencati gli errori che potresti visualizzare:

Messaggio di errore Risoluzione
La pagina non è aggiornata. Configurazione del provisioning già esistente. Aggiorna la pagina per eseguire l'override della configurazione esistente.
La pagina non è aggiornata. Configurazione del provisioning non esistente. Aggiorna la pagina per eseguire l'override della configurazione esistente.
La pagina non è aggiornata. Impossibile attivare una configurazione del provisioning non completata. Aggiorna la pagina per eseguire l'override della configurazione esistente.
La pagina non è aggiornata. Impossibile eliminare una configurazione del provisioning non completata. Aggiorna la pagina per eseguire l'override della configurazione esistente.

 

Errore di pagina temporaneo

Questi errori sono transitori e in genere si risolvono ritentando l'azione dopo un certo tempo. Potrebbero essere i seguenti:

Messaggio di errore Risoluzione
Impossibile recuperare l'impostazione del provisioning  Aggiorna la pagina. 
Impossibile recuperare la preconfigurazione del provisioning Aggiorna la pagina. 
Impossibile recuperare lo stato del provisioning Aggiorna la pagina.
Attivazione del provisioning non riuscita Riprova l'attivazione del provisioning.
Errore durante l'eliminazione della configurazione del provisioning Prova a eliminare di nuovo la configurazione.
Impossibile creare la configurazione del provisioning Crea di nuovo la configurazione del provisioning e salva le modifiche.
Impossibile aggiornare la configurazione del provisioning Aggiorna di nuovo la configurazione del provisioning e salva le modifiche.
Impossibile recuperare gli attributi personalizzati Prova a salvare di nuovo gli attributi personalizzati.
Impossibile aggiornare la mappatura degli attributi Aggiorna di nuovo la mappatura degli attributi.
Impossibile aggiornare le impostazioni di gruppo per il provisioning automatico Aggiorna di nuovo le impostazioni di gruppo.
Impossibile aggiornare la configurazione del deprovisioning Aggiorna di nuovo la configurazione del deprovisioning.
Configurazione eliminata. Non è stato possibile revocare l'accesso al client API.

Quando elimini la configurazione, revochiamo le autorizzazioni che consentono all'applicazione di accedere ai tuoi dati su Google.

Se questa operazione non riesce per qualche motivo, revoca manualmente l'accesso accedendo a "Gestisci accesso client API" nella sezione Sicurezza.

Se hai eliminato la configurazione e prevedi di impostarla di nuovo, non dovrai eseguire alcuna operazione. 

Errore durante l'aggiornamento della configurazione del provisioning Aggiorna la pagina. 
Autenticazione non riuscita Le credenziali di autenticazione (ad esempio il token di connessione) fornite nella configurazione non sono corrette. Inserisci le credenziali corrette.
L'URL dell'endpoint SCIM fornito non è valido L'endpoint di destinazione fornito non è valido. Inserisci l'URL corretto.
Errore durante l'attivazione del provisioning Fai clic su Attiva provisioning
Errore durante l'eliminazione della configurazione del provisioning Fai clic su Elimina provisioning
Impossibile recuperare attributi dal provider Internet di destinazione Aggiorna la pagina Mappatura attributi.
Impossibile recuperare schema risorsa target Verifica l'endpoint SCIM fornito durante la configurazione del provisioning degli utenti e riprova a eseguire la mappatura degli attributi Cloud Directory sugli attributi dell'applicazione di destinazione.

Errori nel tempo di esecuzione del provisioning degli utenti

Nota. Fai riferimento a questa sezione se lo stato Provisioning attuale per la configurazione del provisioning degli utenti corrisponde a Errore.


Gli errori nel tempo di esecuzione del provisioning degli utenti possono essere dovuti a problemi nei parametri di configurazione.


Ecco i possibili codici di errore, le descrizioni e le azioni da intraprendere per risolverli.

Errori di servizio interni di Google

Codice errore Descrizione e risoluzione
17003

Descrizione 

Impossibile eseguire l'autenticazione con i servizi interni di Google.

Motivo

Le autorizzazioni sono state revocate da questo ID del client di provisioning degli utenti:

910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com

Risoluzione 

Assicurati che l'ID disponga delle autorizzazioni necessarie per i seguenti ambiti:

https://www.googleapis.com/auth/admin.directory.user.readonly,
https://www.googleapis.com/auth/admin.directory.userschema.readonly,
https://www.googleapis.com/auth/admin.directory.group.member.readonly

Usa "Gestisci accesso client API" in SicurezzaImpostazioni avanzate per verificare che l'ID client disponga di questi ambiti o per aggiungere tali ambiti all'ID client.

17006

Descrizione 

Impossibile eseguire l'autenticazione con i servizi interni di Google.

Motivo

Le autorizzazioni sono state revocate da questo ID del client di provisioning degli utenti:

910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com

Risoluzione 

Assicurati che l'ID disponga delle autorizzazioni necessarie per i seguenti ambiti:

https://www.googleapis.com/auth/admin.directory.user.readonly,
https://www.googleapis.com/auth/admin.directory.userschema.readonly,
https://www.googleapis.com/auth/admin.directory.group.member.readonly

Usa "Gestisci accesso client API" in SicurezzaImpostazioni avanzate per verificare che l'ID client disponga di questi ambiti o per aggiungere tali ambiti all'ID client.

17008

Descrizione 

Impossibile eseguire l'autenticazione con i servizi interni di Google.

Motivo

Le autorizzazioni sono state revocate da questo ID del client di provisioning degli utenti:

910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com

Risoluzione 

Assicurati che l'ID disponga delle autorizzazioni necessarie per i seguenti ambiti:

https://www.googleapis.com/auth/admin.directory.user.readonly,
https://www.googleapis.com/auth/admin.directory.userschema.readonly,
https://www.googleapis.com/auth/admin.directory.group.member.readonly

Usa "Gestisci accesso client API" in SicurezzaImpostazioni avanzate per verificare che l'ID client disponga di questi ambiti o per aggiungere tali ambiti all'ID client.

Errori del token di autorizzazione

Codice errore Descrizione e motivo Risoluzione
17010

Le credenziali non sono sufficienti per effettuare chiamate verso l'endpoint SCIM.

Causa: il token di autenticazione è stato revocato.

Prova ad autorizzare nuovamente l'app facendo clic su Autorizza di nuovo app.
17013

Si è verificato un errore durante il recupero del token dal tuo provider di servizi.

Causa: il token di autenticazione è stato revocato.

Se l'errore non si risolve automaticamente dopo un certo periodo di tempo, prova a ripetere l'autorizzazione facendo clic su Autorizza di nuovo app.

Errori del token di accesso

Codice errore Descrizione e motivo Risoluzione
17002/17007/17011

Impossibile generare un token di accesso.

Motivo: al momento, alcuni servizi interni di Google non sono disponibili.

Questo errore dovrebbe risolversi automaticamente dopo un certo tempo.
17009 L'accesso alla generazione di token dal token di aggiornamento non è riuscito. Prova ad autorizzare nuovamente l'app facendo clic su Autorizza di nuovo app.

Errori generali

Codice errore Descrizione e motivo Risoluzione
1200x

Errore interno

Questo errore dovrebbe risolversi automaticamente dopo un certo tempo.
25001 Backend/servizio Google momentaneamente non disponibile. Imposta nuovamente il provisioning automatico.
25002

Backend/servizio Google momentaneamente non disponibile. 

Causa: l'applicazione non è installata per il cliente.

Installa l'applicazione, quindi imposta nuovamente il provisioning automatico.
25005 Backend/servizio Google momentaneamente non disponibile. Questo errore dovrebbe risolversi automaticamente dopo un certo tempo.
25016 Backend/servizio Google momentaneamente non disponibile. Imposta nuovamente il provisioning automatico.
50001 Errore interno Questo errore dovrebbe risolversi automaticamente dopo un certo tempo.
50003 Errore interno Questo errore dovrebbe risolversi automaticamente dopo un certo tempo.
50005 È presente un gruppo eliminato nei filtri gruppo configurati. Rimuovi il gruppo eliminato dalla configurazione dell'ambito di provisioning.
50006 Errore interno Questo errore dovrebbe risolversi automaticamente dopo un certo tempo. 

Errori a livello di risorsa

Fai riferimento a questa sezione se viene visualizzato un numero per le azioni di provisioning non riuscite.
Tale numero è un link per scaricare un file dei dettagli dell'errore contenente il codice e la descrizione dell'errore per ogni risorsa non creata, cancellata o aggiornata durante il provisioning.
Si tratta di errori a livello di risorsa e riguardano unicamente le risorse specificate nel file. La descrizione dell'errore nel file scaricato spiega il problema.

Di seguito sono elencati i codici e le descrizioni degli errori dal file dei dettagli degli errori, nonché le azioni da intraprendere per risolverli:

Codice errore Descrizione errore Risoluzione
45003

La richiesta di aggiornamento, creazione o eliminazione della risorsa non è stata accettata dalla tua applicazione basata su SCIM. Consulta i dettagli dell'errore nel file degli errori scaricato.

Possibili cause:

  1. Limite licenze superato: hai licenze per creare solo 5 utenti nella tua applicazione basata su SCIM e hai attivato il provisioning per 6 utenti.
  2. Valore troppo a lungo: il valore, ad esempio l'ID email, è troppo lungo e non è accettabile per l'applicazione basata su SCIM.
  3. Devi disporre di almeno un diritto, uno dei quali deve essere l'ID profilo.
  4. Il nome utente è già esistente. Deve essere univoco in tutta l'organizzazione.
  5. Risorsa (utente) non trovata sul lato fornitore di servizi (SP).
  6. Valore ID utente SCIM non valido.
Correggi l'errore e riprova dopo avere salvato le modifiche.
45005 L'endpoint SCIM che hai configurato non è raggiungibile. Controlla l'endpoint SCIM che hai indicato nella Console di amministrazione. Correggi l'errore e riprova dopo avere salvato le modifiche.
45006

La richiesta di aggiornamento, creazione o eliminazione della risorsa non è stata formulata correttamente o non è stata accettata dall'applicazione basata su SCIM. Consulta i dettagli dell'errore nel file degli errori scaricato.

Possibile causa:

  1. Valore troppo lungo
  2. Licenze insufficienti
  3. Licenza non valida
  4. Valore diritto non esistente
Correggi l'errore e riprova dopo avere salvato le modifiche.
45016

La richiesta di aggiornamento, creazione o eliminazione della risorsa non è stata accettata dalla tua applicazione basata su SCIM perché non hai compilato un campo obbligatorio. Consulta i dettagli dell'errore nel file degli errori scaricato.

Correggi l'errore e riprova dopo avere salvato le modifiche.
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