/chromecast/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
How to fix stuttering YouTube video 0 Recommended Answers 13 Replies 21 Upvotes
1 Recommended Answer
$0 Recommended Answers
1 Relevant Answer
$0 Relevant Answers
Certain videos stutter when I cast them.  Other videos play fine.    I have turned off 50Hz mode as others have suggested, but this has no impact.  Here is a link to one of the troublesome videos:

Most Relevant Answer Most Relevant Answers (0)
All Replies (13)
Most Relevant Answer
Hello, thanks for taking the time to post your issue.
 
Does your supported sending device (e.g phone), TV or router have a task killer app, standby, firewall, antivirus, sleep mode, power saver, a parental control, tv HDMI-CEC settings, wifi network extender, or electromagnetic devices (stereo receiver, DECT cordless phone, microwave, baby monitor, refrigerator, LCD monitor, etc) causing interference?  A wifi repeater may cause a micro second delay.
 
If you have DECT or baby monitor, or other bluetooth devices, make sure their batteries are fresh and check their user manuals about changing channels. Speaking of channels, if you have an Android device, install the Google Play app, Wifi Analyzer and run it. Your wifi router may be on a congested channel. Try channel 1, 6 or 11. Not Auto setting.  Please keep in mind that resetting or making changes to your router settings may have unintended consequences. If you have questions or concerns, please consult your router manufacturer or Internet Service Provider before making any changes. See What router settings do I need to set up Chromecast?
https://productforums.google.com/forum/#!topic/Chromecast/ZGm4p8VcpAU
 
Try Chromecast on the SAME 2.4 (Chromecast 1st gen requirement) Ghz frequency wifi router band as your Android devices
 
marked this as an answer
Most relevant based on info available
-
Most Relevant Answer
I do not have any of the things you mentioned on my device.  I am using iOS.  If there were a problem with my setup it would affect ALL videos, correct?  But that’s not the case.  Only CERTAIN videos are affected.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Hi John,
 
Apologies with the late response. are you still experiencing stuttering video when you cast YouTube videos?
 
Regards,
Craig
marked this as an answer
Most relevant based on info available
-
Most Relevant Answer
Yes I am...
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Hi John,
 
Thanks for the reply. I have some clarifying questions I'd like to ask:
  1. Have you tried to cast using a different casting device?
  2. Have you tried changing the quality on that specific video?
1st generation Chromecast can only do 30fps, if the video content exceeds 30fps, the played video may experience stuttering.
 
Regards,
Craig
marked this as an answer
Most relevant based on info available
-
Most Relevant Answer
I have cast from my iPhone and my iPad with the same result.  I have also confirmed that the frame rate for the particular video I referenced in my original question is 30.  So this is not the issue.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Hi John,
 
Thanks for the reply. Longer/bigger video content tends to experience network fluctuation if the internet speed is below 5-7 Mbps, adding other devices connected to your WiFi router sharing the bandwidth.
 
Regards,
Craig 
marked this as an answer
Most relevant based on info available
-
Most Relevant Answer
My download speed is 33 Mbps...

Would a current model chromecast work better or would I have the same issue?
marked this as an answer
Most relevant based on info available
-
Most Relevant Answer
Over two weeks and no response?
marked this as an answer
Most relevant based on info available
Most Relevant Answer
For several weeks now I have a similar problem, Youtube-videos in the format 1080p60 (not 1080p30) have stuttering audio. This started occuring after a firmware-update. The Google support exchanged my Chromcast for free (although I suspected the firmware from the beginning). The new Chromecast worked, but only for a few hours, before this Chromecast got it's firmware-update (from 1.42.172094 to 1.49.220167).

Currently my Chromecast is unusable for me because most of the videos I watch are in 1080p60 and I specifically bought the new version for 60 frames playback.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
I also have preview firmware 1.49.220167, and 1080p60 YouTube videos are stuttering like crazy.  I have also noticed that Hulu has buffering issues since the firmware update.  Streaming either of these things on anything other than my Chromecast (e.g., my phone and PC) produces stutter-free video, and neither had issues on the Chromecast before the firmware update.

I also note that if I plug a 1080p60 YouTube video URL into a site designed to enable downloading of YouTube videos (for testing purposes only, of course), and then pass that URL onto VidCast, the Chromecast starts streaming from the exact same source URL, but produces stutter-free video.

It is really to the point that I don't even use the Chromecast anymore because the stuttering video is too annoying to be useful.  I removed myself from the preview program in an effort to 'roll back' to the previous firmware, but from what I read it will take a few weeks for leaving the program to actually kick in.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
> For several weeks now I have a similar problem, Youtube-videos in the format 1080p60 (not 1080p30) have stuttering audio. This started occuring after a firmware-update. The Google support exchanged my Chromcast for free (although I suspected the firmware from the beginning). The new Chromecast worked, but only for a few hours, before this Chromecast got it's firmware-update (from 1.42.172094 to 1.49.220167).

This sounds familiar to me. I bought 3rd Gen CC in July and verified that 1080p60 on Youtube works without issues. I don't remember the original out of box firmware or the one it may have installed during the first reboot(s), but then someone time after I got 1.49.220167 (preview program firmware). Now I can not play 1080p60 on Youtube or Twitch properly.

Here is one video I use for testing:
https://youtu.be/LXb3EKWsInQ

Once the actually played quality goes up to 1080p60 (enable "stats for nerds" to see) the symptoms begin: microstutter every few seconds, followed up by audio briefly breaking up. On Twitch it is the same, but much worse and so much worse sometimes can't even make sense of speech.
marked this as an answer
Most relevant based on info available
Most Relevant Answer
Same here. 
*Only* using youtube with chromecast. Netflix, Prime and others are okay when casting and don't stutter like I experience with only *specific* videos on youtube. 

Any ideas on what this could be related to?
marked this as an answer
Most relevant based on info available
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
Report post
What type of post are you reporting?
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/chromecast/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/chromecast/profile/0?hl=en