/chromecast/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
1/30/19
Using voice to cast youtube to chromecast receives restricted error message. 0 Recommended Answers 13 Replies 24 Upvotes
1 Recommended Answer
$0 Recommended Answers
Last edited 2/19/19
I tried installing the assistant last night. Ultimately I want to be able to use Siri to open Google Assistant and have it show whatever I want from youtube on my TV which has the 2nd gen chromecast on it. 
When I use just google assistant to give a voice command to play youtube on my chromecast on my TV I usually get a 'restricted access' error show on my TV. Everywhere I can find youtube on my computer or iphone or ipad apps restricted mode is off in the settings. I can cast directly from youtube on my computer, iphone, or ipad without issue. I can use google home to give voice commands to cast youtube to my chromecast without issue. It's only when I try to use the assistant.  I have tried looking for the restricted access option in the assistant as some websites have said that option is not listed anywhere that I can find.
I went through chromecast support and worked my way up to senior level support. They said that they cannot help me any further since there is not a support team for google assistant since it is a free program like a chat program. :(

Thankyou for your help!
All Replies (13)
1/30/19
I've got the same problem here in the Netherlands
Last edited 2/19/19
marked this as an answer
Helpful?
1/30/19
Me to in Poland. Chromecast 3 Netherlands version.
marked this as an answer
Helpful?
1/30/19
Same problem here. When you cast first using the cast button on youtube and then use the voice command it works just fine. But when I give a voice command to google assistant to cast through you tube on my Chromecast it gives message that restricted mode is enabled.
Last edited 2/19/19
marked this as an answer
Helpful?
1/30/19
same, i can watch video on YouTube on my TV through the app, but when i try to use Google Assistant, it loads up the app then i get the error message before any video. i have an Android phone & TV.

I have turned restricted mode off everywhere,
Last edited 2/19/19
marked this as an answer
Helpful?
2/4/19
Also experiencing on my end in Canada. Never happened before, aways used assistant this way for several months, just all of a sudden stopped working and started doing the same as OP.
Last edited 2/19/19
marked this as an answer
Helpful?
2/5/19
Hi all,

I see that the Chromecast community's manager, Grace, has posted over in that community. Here.

Seems to be a known issue that they are looking into now.

Thanks for reporting!
Jill
marked this as an answer
Helpful?
2/7/19
I'm having the same issue here in the US. But funny thing. If you use the assistant on the Google Home App it works normal, sadly the app doesn't work with Siri Shortcuts.
Last edited 2/7/19
marked this as an answer
Helpful?
2/8/19
Any updates at all?
Last edited 2/19/19
marked this as an answer
Helpful?
2/10/19
Ready for this fix!!
marked this as an answer
Helpful?
2/13/19
Me too.  I agree with Rabindra.  As a workaround I'll try a 2step Routine.  First OPEN YOUTUBE. Second, play my video on Chromecast.  Fingers crossed...
Last edited 2/19/19
marked this as an answer
Helpful?
2/20/19
I am also having the same issue in Canada. Can open YouTube music, or YouTube kids, but not YouTube.i can also open Netflix and Spotify this way. Turned off restricted node everywhere. Works fine if the app is already open, but can't ask the assistant to open it for me
marked this as an answer
Helpful?
5/26/19
I am now having this problem, several months after thread start, although I have a new wrinkle. This problem is only affecting one (1) video on YouTube. Unfortunately it is my special needs grand-daughters favorite song. I can cast from any device in the house, but the error message pops up when the assistant is voice controlled. My apps are all up to date. Help!
marked this as an answer
Helpful?
11/15/19
Seeing as how this forum is so limiting you cannot start your own goddamn thread I will just ask this unrelated question here.

When I bought my TV it's a Vizio and cast enabled in other words Chromecast is built in it worked fine I noticed that at some point Google home updated on my tablet now it doesn't work I've jumped through every fucking possible hoop that I can think of and it won't work I can control the TV with my tablet it's just will not work with Google Assistant I get the stupid damn message that says something on the order of
(I can only play videos on Chromecast or cast enabled TVs)

 and before you ask yes it's on the same network is my tablet it's on the same network is my Google mini and everything is on the same network. Except for my second Google mini which is upstairs on the 5 gigahertz system.

I have even went so far as to link it to Google home through the Vizio websites process and nothing works I mean everything is updated all the settings seem correct except for when you click on the TVs device settings they are dissimilar than all my other TVs. It looks totally different there is no line that indicates what network it's on I have to go into the TVs menus to find that and yes again it is correct same Network

I can control the volume and things like that I can turn the TV off and on with Google Assistant so it sees the device it just doesn't think it's able to play videos and I don't know why I've looked through every sitting on the TV and nothing has changed. Everything is the same as it was the first day when it worked

I'm quite certain that I won't get anywhere doing this but I've run out of options I'm very close to blowing up my Google mini and putting it on YouTube
marked this as an answer
Helpful?
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/chromecast/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/chromecast/profile/0?hl=en