/chromebook/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
-
6/18/19
Fails to connect to http://localhost:8016 1 Recommended Answer 4 Replies 44 Upvotes
1 Recommended Answer
$0 Recommended Answers
I'm running a program in Linux (Beta) terminal. This appears to run correctly and ends with:
2019/06/18 11:09:12 Serving on http://localhost:8016

I next open a chrome browser tab and enter: http://localhost:8016

This results in:
This site can’t be reached
localhost refused to connect.
Try:
ERR_CONNECTION_REFUSED

I have tried a number of solutions found on the web, which involve change chrome://flags
These either haven't worked or mention flags that no longer exist.

Any ideas?
All Replies (4)
-
6/19/19
Hey, thanks John, this (using http://penguin.termina.linux.test:8016/) worked!

I wouldn't mind knowing how you arrived at that URL.

Incidentally, the program is from edublocks.org - I'm following through this How-to and at step 6 they give a program to render a markdown file locally.

Cheers,
Rob
marked this as an answer
Helpful?
6/20/19
Hi Rob,

I'm glad to hear that worked!

The documentation for the Linux (Beta) feature is a bit lacking, so I regularly follow the r/Crostini subreddit to stay up on the latest information. There was a thread posted there a while back that highlighted this change:

This changes the hostname for the default Crostini container to be penguin.linux.test. It also changes the hostnames for any container to be <container>.<vm>.linux.test.

Cheers,
John
marked this as an answer
Helpful?
7/14/19
In Termux you can use the command 'ifconfig' to find the ip-address you need. 

As John mentioned, each program is effectively a separate computer so the ifconfig command will show the address you need, for example I run a local server using KSWeb and one of the services run on 8002 so the address is 100.115.92.2:8002/ 

If you want to learn more about the ifconfig or any command in Linux, use 'man ifconfig'
marked this as an answer
Helpful?
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/chromebook/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Marked as Recommended Answer
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
/chromebook/profile/0?hl=en