/chromebook/community?hl=en
This content is likely not relevant anymore. Try searching or browse recent questions.
Enabeling zRam doesn't work in crosh 0 Recommended Answers 1 Reply 9 Upvotes
1 Update
$0 Updates
1 Recommended Answer
$0 Recommended Answers
1 Relevant Answer
$0 Relevant Answers
0
Hello world,

I have an Acer Chromebook R13 CB5-312T-K7SP. It has 4GB RAM but when i'm having college in MS teams while taking notes, it refreshes the MS teams page because a lack of memory. Annoying!

I was looking for solutions online. Since the hardware RAM isn't upgradable, I was happy to notice you can enable zRam by using Crosh. Looks easy enough!

After switching to the beta channel I tried this command in crosh: swap enable 2000, but there is no response after hitting enter. Other commands do work or give an error. I also tried swap enable 1000 etc. But still no response. 

Am I doing something wrong? Is there anything else I need to do first? Isn't this possible for my Acer?

Thank you very much already for your response! Saves me from buying a new Chromebook ;)

Kind regards
Relevant Answer Relevant Answers (0)
All Replies (1)
Relevant Answer
Bart R,
 
After switching to the beta channel I tried this command in crosh: swap enable 2000, but there is no response after hitting enter. Other commands do work or give an error. I also tried swap enable 1000 etc. But still no response. 
 
zRam is enabled in Chrome OS by default with default sizes, there's no need for you to 'enable' it manually.
You can see what it is set at, how much is used, free, etc. by opening a crosh session with Ctrl+Alt +t and entering: free -ht 
Here's an example on one of my systems:
 
crosh> free -ht
          total    used    free  shared  buff/cache   available
Mem:      7.7Gi   3.1Gi   950Mi   876Mi       3.7Gi       3.3Gi
Swap:      11Gi      0B    11Gi
Total:     19Gi   3.1Gi    12Gi
 
If you want to set your own sizes you can, at your own risk, using the crosh swap command but, as the 'swap usage' message states it will take effect at the next boot, see below:
 
crosh> swap -h
swap [ enable <size (MB)> | disable | start | stop | status
 | set_margin <discard threshold (MB)> | set_extra_free <amount (MB)>
 | set_min_filelist <amount (MB)> ]  
  Change kernel memory manager parameters
  (FOR EXPERIMENTS ONLY --- USE AT OWN RISK)
  "swap status" (also "swap" with no arguments) shows the values of various
  memory manager parameters and related statistics.
  The enable/disable options enable or disable compressed swap (zram)
  persistently across reboots, and take effect at the next boot.
 The enable
  option takes the size of the swap area (in megabytes before compression).
  If the size is omitted, the factory default is chosen.
  The start/stop options turn swap on/off immediately, but leave the settings
  alone, so that the original behavior is restored at the next boot.
  WARNING: if swap is in use, turning it off can cause the system to
  temporarily hang while the kernel frees up memory.  This can take
  a long time to finish.
  The set_margin, set_min_filelist, and set_extra_free options change
  kernel parameters with similar names.  The change is immediate and
  persistent across reboots.  Using the string "default" as the value
  restores the factory default behavior.
 
I've never had a need to set the swap size any differently from the system defaults but, on most of my systems, I have 8GB of RAM. 
 
 
 Hope this helps, ~DennyL
 
marked this as an answer
This question is locked and replying has been disabled.
Discard post? You will lose what you have written so far.
Write a reply
10 characters required
Failed to attach file, click here to try again.
Discard post?
You will lose what you have written so far.
Personal information found

We found the following personal information in your message:

This information will be visible to anyone who visits or subscribes to notifications for this post. Are you sure you want to continue?

A problem occurred. Please try again.
Create Reply
Edit Reply
Delete post?
This will remove the reply from the Answers section.
Notifications are off
Your notifications are currently off and you won't receive subscription updates. To turn them on, go to Notifications preferences on your Profile page.
Report abuse
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
Report post
What type of post are you reporting?
Google takes abuse of its services very seriously. We're committed to dealing with such abuse according to the laws in your country of residence. When you submit a report, we'll investigate it and take the appropriate action. We'll get back to you only if we require additional details or have more information to share.

Go to the Legal Help page to request content changes for legal reasons.

Reported post for abuse
Unable to send report.
This reply is no longer available.
/chromebook/threads
//accounts.google.com/ServiceLogin
You'll receive email notifications for new posts at
Unable to delete question.
Unable to update vote.
Unable to update subscription.
You have been unsubscribed
Deleted
Unable to delete reply.
Removed from Answers
Removed from Updates
Marked as Recommended Answer
Marked as Update
Removed recommendation
Undo
Unable to update reply.
Unable to update vote.
Thank you. Your response was recorded.
Unable to undo vote.
Thank you. This reply will now display in the answers section.
Link copied
Locked
Unlocked
Unable to lock
Unable to unlock
Pinned
Unpinned
Unable to pin
Unable to unpin
Marked
Unmarked
Unable to mark
Reported as off topic
Known Issue
Fixed
Marked Fixed
Unmarked Fixed
Unable to mark fixed
Unable to unmark fixed
/chromebook/profile/0